mikrocontroller.net

Forum: Platinen problem mit raster bei eagle


Autor: Benjamin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo, ich hab ein problem mit dem raster bei eagle.
Ich habe in mein schaltplan die raster verstellt, d.h. ich habe mehrere 
verschiedene raster und weis auch nicht mehr welche.
Gibt es eine Funktion, oder Trick, mit dem man alle bauteile bzw 
schaltplan wieder auf ein gemeinsames Raster setzen kann???

Vielen Dank im Voraus

Benjamin

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Benjamin (Gast)

>Gibt es eine Funktion, oder Trick, mit dem man alle bauteile bzw
>schaltplan wieder auf ein gemeinsames Raster setzen kann???

Nein. Das ist aber auch nicht nötig. Wenn die Bauteile halbwegs OK 
platziert sind lass sie einfach so. Routen kannst du jedes Bauteil auf 
jedem Raster, du musst nur am Pin des Bauteils anfangen, Eagle springt 
dann auf das aktuelle Raster.

MFG
Falk

Autor: Benjamin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mir geht es nicht um das board sondern um schematic, wenn i dich richtig 
verstanden habe, und beim board habe ich auch keine probleme.
eagle fängt die raster anscheinend nicht mehr.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ist dann rel. viel Arbeit, je nachdem, wie vermasselt du das hast.
Mit "info" bekommst du die Position numerisch angezeigt (am besten Grid 
0.1, Raster on stellen, dann siehst du gleich, welche Bauteile 
ausserhalb des Rasters liegen).
Dann wirds etwas kniffelig, je nachdem, was du vorher so alles 
angestellt hast. Einfach ist es noch, wenn du beispielsweise 0.05"/50mil 
benutzt hast. Stellst das Raster auf 50mil, Grid on, *2. Dann kannst du 
das Bauteil auf das 100mil-Raster bewegen. Genauso, falls du noch andere 
mil-Einheiten benutzt hast.
Hast du einige Teile sogar in irgendweinem mm-Raster platziert, wirds 
kniffeliger.
2 Möglichkeiten:
Dein Platzierungsraster einstellen, das Bauteil auf den Nullpunkt 
ziehen, Standard-Raster wieder einstellen und das Bauteil zurückbewegen.
Alternativ: Grid auf Inch, mit Info die aktuelle Position geben lassen, 
Differenz zum 0.1"-Raster ausrechnen, diese Differenz als Grid 
einstellen, Bauteil um diesen Betrag bewegen. Das sit dann auch noch für 
x und y getrennt nötig :-)
Im Board kann man auch per Kommandozeile exakt platzieren, im Schaltplan 
geht das leider nicht. Warum eigentlich nicht?
mov r5 (500 1000)
bewegt R5 exakt auf die Position (500, 1000), wobei 500 bzw 1000 dann 
Absolutwerte sind in der jeweilig eingestellten Einheit.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Benjamin (Gast)

>mir geht es nicht um das board sondern um schematic, wenn i dich richtig

1.) Im Schaltplan zeichnet man IMMER mit 100mil Raster, sonst gibts 
massig Probleme!

2.) Um deinen Schaltplan wieder zu reparieren stelltst du als erstes 
100mil Raster ein. Dann aktivierst du MOVE. Wenn du nun mit gedrückter 
CTRL-Taste die Bauteile anclickst werden sie auf das aktuelle (100mil) 
Raster verschoben. Funktioniert aber erst ab Eagle 4.0

MFG
Falk

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ho, wo hast du das den her? Habe ich zwar noch nie gebraucht, geht aber 
prima.

Autor: Benjamin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
VIELEN DANK  Falk Brunner!!

geht gut, sieht zwar jetzt bissle blöd aus, aber das bekomm i noch 
hin*gg*

immerhin besser als alles neu zu zeichnen---> das mit den 100mill werd i 
mir merken.

MfG Benjamin

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
alternativ gibts auch ein ulp, das dir im schematic die bauteile aufs 
raster fängt. is wohl leider schon zu spät ^^

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.