mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Makefile einstellungen


Autor: Jones (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe probleme mit den makefile einstellungen für seriellen Port, 
9polig. Ich hab auch für die gleiche schnittstelle ein lpt programmer 
was auch funktioniert aber die serielle kriege ich nicht hin. Kann mir 
da jemand paar tips geben?

Danke!

Autor: Thomas B. (yahp) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe probleme mit dem Verständnis dieses Beitrages. Was für ein 
Makefile? Was für eine "gleiche Schnittstelle"? Um was geht es 
überhaupt?

Autor: Severino R. (severino)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Du musst das Makefile mit der neuesten Version für die gleiche 
Schnittstelle nochmals compilieren und mit dem lpt Programmer linken. 
Dann sollte es funktionieren ;-)

Severino

Autor: Jones (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

tut  mir leid für die schlechte formulierung. Also nochmal: Ich benutze 
WinAVR entwicklungsumgebung und habe schwierigkeiten mit der 
einstellungen des Makefiles für serielle schnittstelle. Was muss ich 
genau hier einstellen?

# Programming hardware: alf avr910 avrisp bascom bsd
# dt006 pavr picoweb pony-stk200 sp12 stk200 stk500
#
# Type: avrdude -c ?
# to get a full listing.
#
AVRDUDE_PROGRAMMER = ..............

# com1 = serial port. Use lpt1 to connect to parallel port.
AVRDUDE_PORT = ........................

Gruß

Jones

Autor: Michael Herder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube kaum dass die Einstellung der seriellen Schnittstelle damit 
zu tun hat.

Autor: Jones (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das problem ist das ich das programm über serielle schnittstelle nicht 
in dem µC reinladen kann. Ich dachte, dass ich makefile einstellungen 
nicht richtig eingestellt habe, hmm

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dürfte nicht das Problem sein.. Mal mit dem parallen Adapter probiert? 
Ein paar Widerstände und läuft bei mir zuverlässiger als seriell, und 
PonyProg als Flasher.

Autor: Jones (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab es mir von der seite: www.mikrokid.de den seriellen kabel und 
parallele kabel bestellt. Bei parallelen funktioniert es mit reinladen 
aber mit dem seriellen nicht.

Autor: Jörg X. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das serielle Kabel sieht aus, als wäre das SI-Prog (urspünglich für 
PonyProg). Also Probier mal: "AVRDUDE_PROGRAMMER = siprog"
(für alles weitere könntest du evtl. sogar selbst die Doku lesen, die 
bei WinAVR dabei ist....)

hth. Jörg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.