mikrocontroller.net

Forum: Compiler & IDEs Probleme mit Keil Vision3


Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mache grad die ersten Schritte beim Microcontroller programmieren und 
bin ein wenig ins stocken geraten. Verwende einen SAB80C517A und 
programmiere im Assembler.

Sobald ich auf "Build Target" klicke kommt folgende fehlermeldung:

RAMSIZE(256)
*** FATAL ERROR L213: I/O ERROR ON WORK FILE:
EXCEPTION 0029H: ACCESS TO FILE DENIED
FILE: C:\DOKUME~1\B”lter\LOKALE~1\Temp\$$L51$$$.TMP
Target not created

im Output Window.

Hoffe mir kann hier jemand weiterhelfen.
Dank schonmal!

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der Link hilft nicht wirklich...

Der Pfad existiert auf meinem Rechner und wird von anderen Programmen 
auch genutzt, verstehe nicht wirklich warum Vision3 da nichts 
reinschreiben kann...

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1/ Hat das Verzeichnis C:\DOKUME~1\B”lter\LOKALE~1\Temp\ "full access 
permissions"?
2/ Welches Zeichen stellt das ” in deinem Pfad dar?
3/ Hast du schon mal TMP, TEMP, and C51TMP auf einen "normalen" (ohne 
Sonder- und Leerzeichen, 8.3 Namen) Pfad geleitet?
http://www.keil.com/support/docs/65.htm
http://www.keil.com/support/man/docs/c51/c51_cm_envvars.htm
Checke das Setting für User (das benutzt Keil)!
http://8052.com/forum/read.phtml?id=79655
4/ Schau mal nach ob es C:\DOKUME~1\B”lter\LOKALE~1\Temp\$$L51$$$.TMP
als Datei (read-only?) oder Verzeichnis (ups!) gibt. Wenn ja, 
weglöschen.

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scheint tatsächlich am zeichen " zu liegen. Das steht eigentlich für ein 
"ö" in meinem Benutzernamen, aber wie es aussieht kann Vision3 das nicht 
verarbeiten! Hab jetzt ein pfad mit der selben schreibweise wie in der 
Fehlermeldung erstellt und es funktioniert. Aber ein bisschen komisch 
find ichs ja schon....

Autor: Klaus Falser (kfalser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest kein Verzeichnis mit einem " im Namen erzeugen, das gibt nur 
Probleme.
B”lter als DOS-Name kann nicht richtig sein.
Wenn ich auf meinem Rechner (Windows XP) ein Verzeichnis mit Namen 
Bölter anlege, dann ist der DOS-Name BLTER~1.
Ich vermute eher, dass die TEMP Variablen irgendwie falsch gesetzt sind.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.