mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik spannungteiler für ad-wandler


Autor: PaRu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich möchte mit dem ad-wandler von meinem avr eine spannung messen von
maximal 20v. die referenzspannung habe ich auf 5v fest gelegt, so dass
ich einen spannunsteiler von  1:3 benutze. damit da möglichst wenig
strom fließt, habe ich einen gesamtwiderstand von 1,333megaohm gewählt.
könnte das zuviel sein, denn der avr zeigt auch nichts vernünfiges an.
meistens werte um die null. wieviel ohm gesamtwiderstand sollte der
spannungsteiler maximal haben?
Gruß Patrick

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du den Spgs.teiler direkt vor dem AD-Wandler?

Das kann nicht funktionieren, ich habe die genauen Daten nicht im Kopf
(stehen im Datenblatt), aber wesentlich über 10k solltest Du nicht
gehen.
Schalte einen Spannungsfolger dazwischen, dann kannst Du den Teiler
hochohmig machen und misst trotzdem noch genau.

Alternative:
Schalte einen niederohmigen Spgsteiler per FET ab, wenn Du nicht misst,
dann brauchst Du in den Messpausen Null Strom.

Stefan

Autor: PaRu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Stefan
danke. wo hast du denn im datenblatt den wert mit den 10kohm gesehen?
der spannungsteiler hängt direkt am avr. was ist ein spannungsfolger
und wonach sollte der gewählt werden?
Gruß Patrick

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lese mal hier unter Artikel, Operationsverstärker, Spannungsfolger.

Zuerst den Spgsteiler mit Deinen M-Ohm, dann den Spannungsfolger (ist
ein IC ohne weitere Beschaltung), dann damit auf den AD-Eingang.

Die 10kohm habe ich nicht aus dem Atmel-Datenblatt, sondern von einer
NEC-CPU mit AD-Wandler, dürfte sich aber nicht so wahnsinnig
unterscheiden.

I.d.R. sitzt hinter dem Multiplexer der AD-Eingänge eine kleine
S/H-Schaltung, hier wird ein C vor der Messung auf den Analogwert
umgeladen. Wenn Dein Eingang nun zu hochohmig ist, wird der C nicht auf
den exakten Analogwert umgeladen. Je nachdem welche Spg an den anderen
AD-Eingängen anliegt, kann dann Dein Ergebnis mehr oder weniger
fehlerhaft sein.

Bitte schau Dir im Datenblatt den Teil
anaolog input circuit
genauer an.

Falls Du einen ATmega mit agin-amplifier hast, kannst Du auch mit
diesem probieren. Das kann ev. den externen Spgsfolger ersetzen.

Stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.