mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Emulator Firmware Udate beim MSP430F2013


Autor: Christoph Beyer (beyarea)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich hab ein Problem mit meinem MSP430F2013 USB Stick. In der IAR 
Programmierumgebung erschien eine Warnmeldung, daß die Emulation 
Firmware der Software nicht mit der des MSP übereinstimme. Das 
vorgeschlagene und automatisch durchgeführte Update scheiterte, seitdem 
erkennt die Programmierumgebung den FET nicht mehr, vorher klappte 
natürlich alles. Schon einer dieses Problem gehabt oder weiß jmd. wo ich 
Emulator Firmware Updates finde?

Autor: Rundordner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein ez430 ist jetzt leider reif für den Rundordner.

Autor: Tilo S. (thesurfer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn du noch einen 2.ten ez430 und einen normalen jtag - adapter hast, 
kannst du den ueber die 5 Pins anschliessen und die Firmaware des 2. 
auslesen. Dann den zertsoerten anschliessen und die Firmware des 2. 
draufspielen.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Christoph Beyer,

der Beitrag ist zwar schon älter, aber wie sieht es mit dem USB-Stick 
aus ?
Hat das Wiederherstellen geklappt ? ich mußte leider die Erfahrung 
machen, daß bei mir die Wiederherstellung versagt hat. In anderen Foren 
habe ich gelesen, daß IAR ein falsches Firmware-Update einspielt. Man 
kann nur raten, das ganze mit IAR zu lassen.
Ich hatte sogar das Phänomen, daß ein von TI-Original-hergestelltes 
Board nur noch mit einem F2013 zu bestücken war, per Software (TI) und 
original TI-USB-FET zu verbinden war, ABER keine Funktion. Ich verwende 
Win2k SP2 ????

Ich habe dann schweren Herzens einen anderen MSP verwendet und warte bis 
zur nächsten Messe, um IAR und TI den ganzen Schrott vor die Füße zu 
werfen !!! Abgesehen vom Preis (der ja noch akzeptabel wäre) habe ich 
über eine Woche damit zugebracht Tools zusammenzutragen und in Foren 
nach diesem Problem zu suchen.

Der Support von TI verweist dabei auf IAR und IAR sitzt das Problem 
damit aus, daß man das ganze ja nicht direkt und mit Support von IAR 
gekauft hat.

Der 2. Versuch nach 10 Jahren IAR-Compiler einzusetzen ist gründlich in 
die Hose gegangen. Da bleib ich doch lieber wie bisher erfolgreich bei 
gcc !!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.