mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fehlermeldung beim AVR ISP


Autor: franzi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
ich hoffe ihr könnt mir mal wieder weiter helfen ;-)
Ich hab diese Fehlermeldung bekommen als ich meine Platine programmieren 
wollte, dort hab ich nen Atmega8 drauf, hab zuvor eine baugleiche 
Platine programmiert -> keine Probleme

dann hab ich aufgrund der fehlermeldung die Frequenz runtergesetzt, das 
hat aber auch nichts gebracht...

auslesen kann ich noch alles, aber nix mehr programmieren?

könnte es an den LockBits liegen,
die stehen nämlich auf:

Application Protection Mode 3: LPM and SPM prohibited in Application 
Section

Boot Loader Protection Mode 4: LPM prohibited in Boot Loader Section

wenn ja, kann ich das Problem irgendwie beheben oder hat es sich mit dem 
controller erledigt?

gruß franzi

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zuerst einmal solltest du lernen die Suchfunktion zu benutzen. Diesye 
Frage wird wöchentlich hier 2x gestellt und man sollte Antworten in 
allen Farben und Formen finden.

Am wahrscheinlichsten ist das die ISP Frequenz zu niedrig ist. Wenn du 
die Lockbits gesetzt hast kannst du den Controller nicht mehr auslesen.

Bzw sind die beiden Lockbits die du genannt hast für den Bootloader 
zuständig solang du keinen benutzt dürfte das uninteressant sein.

Autor: franzi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tut mir leid, ich wusste nicht so recht nach was ich suchen soll...
doch auslesen lässt sich was, wenn ich die lockbits lese, zeigt es mir 
aber an das diese beiden gesetzt sind...

und woran könnte es liegen das es mit einer platine geht, mit der 
nächsten dann nicht mehr?

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Platinen sind selber Bauart ?
dann solltest vielleicht doch mal den Controller wechseln.

Autor: franzi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, das ist ja das was mich so wundert...
naja. dann werd ich den Controller mal tauschen,
oder hat noch jemand ne andere idee?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe genau die gleiche Fehlermeldung, nur leider kann ich auch gar 
nichts auslesen!
Hat jemand eine Idee?

Vielen Dank

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du denn schonmal das versucht worauf die Fehlermeldung hinweist ?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja alle Geschwindigkeiten durchprobiert und das Kabel steckt auch 
richtig!

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Checkliste:

Controller muss laufen (Quarz schwingt ? (falls ein externer gesetzt 
ist))
Versorgungsspannung und Masse müssen an allen entsprechenden Pins des 
Controllers beschaltet und da sein.
Alle ISP Leitungen (MISO,MOSI,SCK) müssen korrekt verbunden sein.
ISP Frequenz muss unter 1/4 der Taktfrequenz des Controller sein.

Wenn die Bedingungen alle erfüllt sind und dein Controller und ISP ganz 
ist, funktioniert ISP.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.