mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit ATmega8535 --> wird nicht erkannt


Autor: Marc Rie (planet-rieke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich hab ganz neu mit Microcontrollern etc. angefangen und daher kann es 
gut sein, dass die Lösung zu meinem Problem auf der Hand liegt, bzw. 
total klar ist. Ich hab mir nen ATmega8535 gekauft und den wie im 
Tutorial auf ne Platine gelötet. Ich hab aber nur nen ganz normalen 
Quarz genommen. Bei meiner Verbindung zum Computer verbinde ich jede 
Ader (MISO, MOSI etc) außer GND mit 220ohm widerstand dazwischen direkt 
mit dem Parallelport.

Nun hab ich aber das Problem das mein Controller von sämtlichen 
Programmen nicht erkannt wird. Woran kann das liegen??? Hab schon 
Lötstellen und Kontakte überprüft. Da ist alles in Ordnung.

Wär um Hilfe sehr dankbar.
Gruß
-marc

Autor: Sigint 112 (sigint)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Marc,
  hast du noch irgendwas anderes an den ISP-Pins hängen? Und sind alle 
Pins richtig belegt? Vielleicht gibts Probleme mit deinem 
Parallelport... das kommt ab und zu vor. Probier mal EPP oder ECP im 
BIOS einzustellen.
Ansonsten kannst du noch AVREAL32 runterladen und ein wenig mit den 
Delays rumspielen (-1 -2 -3 -4 -5)...

Gruß,
  SIGINT

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht die Spannungsversorgung des µC aus?

Autor: Marc Rie (planet-rieke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Johannes:Ich hab ein Netzgerät mit 5V dran...
@Sigint: ähm. Epp oder ECP im BIOS einstellen??? Sorry aber ich bin 
total neu in all dem.

Vielen Dank aber.

Autor: Marc Rie (planet-rieke)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mein ISP sieht so aus:

Autor: Marc Rie (planet-rieke)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Zudem fällt mir gerad auf, dass ich den 100nF Kondensator zwischen Minus 
und Plus pol nicht eingebaut hab. Ist das schlimm??? Ich sah irgendwie 
nicht den Sinn in dem Teil

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Zudem fällt mir gerad auf, dass ich den 100nF Kondensator zwischen Minus
>und Plus pol nicht eingebaut hab. Ist das schlimm??? Ich sah irgendwie
>nicht den Sinn in dem Teil

Lässt du bei deinem Auto auch die Reifen weg wenn
du irgendwohin fahren möchtest ? Die brauchst du ja nicht.
Reifen machen keinen Sinn. Kosten bloss Geld und sind
irgendwann abgefahren.

Autor: planet-rieke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lol ok das heißt ich brauch das....
ich seh nur nicht den großen Sinn einen Kondensator 
dazwischenzustellen... naja aber ich kenn mich auch nicht so damit 
aus... ok dann werd ich das mal dazulöten... Danke

Autor: Sigint 112 (sigint)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur weil man den Sinn nicht versteht bedeutet das nicht, daß es keinen 
Sinn gibt. Der Kondensator dient einerseits zum Glätten der 
Versorgungsspannung und andererseit kurzzeitige Laständerungen (durch 
umschaltprozesse im IC) zu kompensieren. Es KANN ohne funktioniere, MUSS 
aber nicht. Also immer einbauen...
Noch eine kleine Bemerkung: Du hast im Schaltplan einen AT90S4433... ich 
hoffe du hast die ISP-Pins richtig am ATmega8535 angeschlossen.

Gruß,
  SIGINT

Autor: planet-rieke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja ich hab meinen Fehler gefunden.. Hab bei meinem Parallel-Stecker die 
Kabel falsch angelötet... Jetzt klappt alles wie geschmiert....
Vielen Dank

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.