mikrocontroller.net

Forum: PC Hard- und Software EWF mit WinXPpro auf CF


Autor: Didi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein gut laufendes WinXPproSp2 auf einer
CF SanDisk Extreme III 4GB. Hardware ist ein Alix1c Board.

Ich versuche, EWF gemaess
http://www.taunusstein.net/index.php?option=com_co...
zu installieren und erhalte
'Failed getting protected volume configuration with error 1'

Woran koennte das liegen?

Zu erwaehnen ist noch, dass die in der Anleitung aufgefuehrte
Registry-Aenderung
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
BootExecute=""
nicht durchgefuehrt wird, der Wert bleibt auf 'autocheck autochk *'
stehen. Ich hab das dann manuell angepasst.

Besten Dank im Voraus -Didi

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch die beiden Schlüssel für alle Lesbar gemacht? Ich hab auf 
meiner Seite die REG Datei komplett zum herunterladen, hatte auch durch 
das Copy und Paste einige Fehler in den REG schlüsseln (Zeilenumbruch 
etc.)

Autor: Didi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe alles exakt nach Anleitung gemacht.
Zuerst die Rechte auf Full gesetzt, dann die ewf.reg executed und
dann die Rechte wieder auf den ursprunglichen Zustand zurueckgesetzt.
Ich hab selber schon etliche reg-files geschrieben und die Datei
verifiziert. Ferner habe ich anschliessend jeden einzelnen Eintrag
manuell in der Registry verifiziert (deshalb hab ich ja auch die
nicht ausgefuehrte Aenderung des BootExecute bemerkt).

Autor: Yatsuya (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Didi

Ich habe genau dasselbe Problem. Beim Stöbern im Netz bin ich auf ein 
Dokument von Microsoft gestossen, in dem ein zusätzliches Parameter 
"VolumeID" erwähnt wird. Laut diesem Dokument sollte der letzte Registry 
Key so aussehen:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ewf\Parameters\Protected\Volume0]
"VolumeID"="{1EA414D1-6760-4625-8CBE-4F9F85A48E15}"
"Type"=dword:00000001
"ArcName"="multi(0)disk(0)rdisk(0)partition(1)" 

Ich habe es allerdings noch nicht selber ausprobiert.

Viel Erfolg ;-)

Autor: Uli Huber (ulihuber)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe genau das gleich Problem mit identischem Ablauf wie vom Didi 
beschrieben an einem Intel D201GLY Board mit einer A-Data 4GB CF.

Beim Versuch die den ewfntldr in Root auf ntldr umzubenennen kam 
allerdings ein Fehler, da das File bereits existieren würde. Ich hatte 
aber den orginalen ntldr auf ntldr_old umbenannt.
Bei einem weiteren Versuch konnte ich jedoch ein in einem anderen 
Verzeichnis umbenanntes File nach root kopieren.

Trotzdem scheint EWF nicht zu laufen.

Bin mal gespannt ob wir da eine Lösung finden...

Gruß
Uli

Autor: Uli Huber (ulihuber)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

bei mir geht's jetzt.
Blöderweise schreiben bei dem Thema alle voneinander ab und jeder 
vergißt dabei irgendwas.

Hier die vollständige Reg. Datei. Sie enthält auch den nötigen Key 
'Enable' und den Eintrag für das 'minlogon'.

Gruß
Uli

------------------------------------


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction]
"Enable"="N"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OptimalLay 
out]
"EnableAutoLayout"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
"NtfsDisableLastAccessUpdate"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session 
Manager\Memory Management\PrefetchParameters]
"EnablePrefetcher"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
BootExecute=""

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_EWF]
"NextInstance"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_EWF\0000]
"Service"="EWF"
"Legacy"=dword:00000001
"ConfigFlags"=dword:00000020
"Class"="LegacyDriver"
"ClassGUID"="{8ECC055D-047F-11D1-A537-0000F8753ED1}"
"DeviceDesc"="EWF"
"Capabilities"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_EWF\0000\C 
ontrol]
"ActiveService"="EWF"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ewf]
"ErrorControl"=dword:00000001
"Group"="System Bus Extender"
"Start"=dword:00000000
"Type"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71A27CDD-812 
A-11D0-BEC7-08002BE2092F}]
"UpperFilters"="Ewf"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ewf\Parameters\Pro 
tected\Volume0]
"Type"=dword:00000001
"ArcName"="multi(0)disk(0)rdisk(0)partition(1)"
"Enabled"=dword:00000001
"VolumeID"="{1EA414D1-6760-4625-8CBE-4F9F85A48E15}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Winlogon]
"Config"=dword:00000017

Autor: Manfred Richter (manfredr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie es mit dem "neuen ewf" - fbwf - geht, steht hier: 
http://www.mp3car.com/vbulletin/winnt-based/121088...

Die benötigten vier files kann man aus dem XPe feature-pack extrahieren:
http://www.microsoft.com/downloads/thankyou.aspx?f...
Dazu einfach die ca. 65MB grosse Installationsdatei im ISO Image starten 
und die files im temporären Order unter "rep" suchen.

Der Vorteil von fbwf gegenüber ist, dass man einzelne Verzeichnisse oder 
Dateien zum Schreiben freigeben kann. Ist z.B. für Datenlogger o.ä. ganz 
nützlich.

Läuft bei mir mit einem alix.1c und Sandisk Extreme III 4GB.

Grüsse,
Manfred

Autor: Hendrik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habt ihr irgendwie weiter gemacht mit dem Thema? Ich stehe gerade vor 
dem selben Problem.

Folgende Info dazu:

Die CF Card (4GB SanDisk Extreme III) beinhaltet eine einzige Partition, 
die den gesamten Flash einnimmt (bis auf 13MB).

Angeblich soll EWF eine Partition benötigen. Ich möchte aber, dass EWF 
überhaupt nicht auf die CF Card schreibt, auch nicht auf eine andere 
Partition. Also wenn EWF schon eine eigene Partition benötigt, dann doch 
bitte auf der zusätzlich noch angeschlossenen Festplatte (ich möchte aus 
technischen Gründen das XP von der Festplatte fernhalten, es auf CF 
installieren). Oder eben vollständig im RAM.

Ich komme jedoch nicht einmal so weit, irgendwas ausprobieren zu können, 
da ich die selbe Fehlermeldung erhalte wie ihr.

"Failed getting protected volume configuration with error 1"

Auch Uli Hubers REG File hat keine Abhilfe geschaffen. Das Problem 
besteht weiterhin. Ich bitte um Unterstützung! Danke!

Erreichbar über ICQ: 105-029-641
oder per eMail: seveq[at]seveq.de

Danke

Grüße,
Hendrik

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Angeblich soll EWF eine Partition benötigen.

Was magst Du damit meinen? Zumindest das "echte" XPe kann mit exakt 
einer Partition auf einer CF-Karte auch komplett ohne Schreibzugriffe 
auskommen, es benötigt halt ein bisschen mehr RAM, um Schreibzugriffe zu 
(ver)puffern.

Das geht mit dem FBWF genauso, nur lässt dieser auch nachträgliche 
Änderungen zu, was äußerst praktisch ist, möchte man am 
"festgemeisselten" Betriebssystemimage doch noch was ändern.

Autor: Ferika (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
FBWF - habe auch bei einfacher WinXP Pro.SP3 DE installation (nur HW 
Treiber und notwendige Patches bis 12.2010 installiert) nicht zum laufen 
gebracht. EINSCHALTEN geht, aber beim auschalten mit FBWFMGR /disable 
gibt es einen Bluescreen. Bei etwas komplizierten WinXP installation 
mit AV, Spielen usw. geht auch das einschalten nicht mehr. Entweder wird 
alles ignoriert, oder kommt ein Bluescreen beim hochfahren. Hat jemand 
erfolgreich FBWF installiert - oder EWF mit einer Grösse von 
512MB-1024MB zum laufen gebracht? Welche parameter?

(PS: FBWF wäre mir lieber!)
Danke,
Feri

ferika@a1.net

Autor: Manfred Richter (manfredr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ja, bei mir läuft fbwf auf einer 4GB Karte mit XP SP3 und akuellem 
Patchstand. Allerdings halt nicht auf 512-1024 MB sondern mit 4 GB.

Anleitung:
http://www.mp3car.com/vbulletin/winnt-based/121088...

Um XP auf unter 1GB zum Laufen zu bekommen musst Du vermutlich einiges 
mit nlite aus dem Setup entfernen, oder? Vermutlich liegt da schon das 
Problem.

Grüsse,
Manfred

Autor: Ferika (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke und sorry - habe ja etwas blöd geschrieben - WinXP ProDE SP3 auf 
einem Rechner mit 4GB RAM installiert.

Mit dem 1GB habe ich das Overlay gemeint - also den RAM für den EWF 
Buffer. Bei mir geht es EWF einschalten nur wenn ich z.B. 256 MB wähle. 
Bei grösseren Overlay bleibt es ausgeschaltet auch nach dem Restart.

FBWF geht einschalten - aber nicht mehr ausschalten. Bluescreen kommt 
gleich!

kannst ja auch auf meine Email : k*nk*li@a1.net (statt * gib ja einen 
"o" - will den Spammern die Arbeit nicht zu leicht machen.)

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

da kann ich Dir dann leider auch nicht weiterhelfen. Mein PC hat nur 
256MB RAM und dafür werden dann 128MB für den Overlay verwendet.
Ich hatte vor langer Zeit mal mit W2K3 und FBWF auf einer VM gespielt 
und dort auch mehr Speicher verwendet, hatte dann auch blue screens. Ich 
habe das aber nicht weiter verfolgt.

Viele Grüsse,
Manfred

Autor: Feri (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, schau mich mal um, wenns nicht anders geht, mache ich einfach mit 
Acronis ein abbild der kompletten Installation und schalten dann das 
overlay ein. Wenn es eine Änderung, oder Installation geben sollte, dann 
spiele ich den Image erneut ein, mache das, was ich brauche und friere 
das mit dem Overlay wieder ein. Etwas komplizierter, soll ja aber an 
Maschinen laufen, die deppensicher sein sollten - und nicht zum 
herumprobieren da sind.

Danke und bye!
Feri

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.