mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Programmverlust


Autor: Reinhard Schmaderer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute

ich habe das board DL7UNO 1 mit den atmel 90s2313 drin.
es funst alles bestens nach den bespielen mit einem programm läuft es
auch bestens und fehlerfrei, aber nach ca 1/2 stunde ist das programm
verschwunden?.
ich dachte nach den beschreiben ist es für immer im chip drin?
die LED für die versorgungsspannung ist immer an?
die versorgungsspannung nehme ich vom LPT port??

hat jemand eine idee oder eine antwort?

danke
reini

Autor: Joerg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Womit stellst Du denn fest, daß das Programm ,,verschwunden'' ist?
Wie sieht das ,,verschwundene'' Programm denn aus, ist der ROM auf
0xff rückgesetzt worden?

Autor: Reinhard Schmaderer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich habe es aufgespielt, getestet, dann bleibt alles eingeschalten wie
ich es verlassen habe.
die kontrolle für spannung ist immer an, nach ca einer halben stunde
will ich es noch mal probieren also taster drücken und die reaktionen
darauf sehen aber es geht nichts mehr als ob ich kein programm
aufgespielt hätte.
das selbe passirt auch wenn ich die  LPT verbindung trenne und wieder
herstelle ist auch keine reaktion mehr zu verzeichnen.

ob es nun an der schnittstelle liegt oder das der chip das programm
nicht speichert weis ich nicht da ich neuling bin und keine ahnung habe
wie ich ein programm das auf den chip ist wieder in BASCOM sichtbar
machen kann.
ich folge zur zeit die beispiele von http://www.rowalt.de/mc/
nur wie gesagt wenn ich testen will ob die led's leuchten geht das
eine halbe stunde prima und plötzlich ist alles so als ob noch nie was
drauf war auf den chip
wie gesagt ich bin nur bei den ganz einfachen beispiel led per
tastendruck an!!!

besten dank
reini

Autor: Andreas Jäger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ein Schaltungsfehler? Heisse Bauteile?

Wenn der Fehler auftritt, Spannung abklemmen, 15 min. Warten, Spannung
wieder anklemmen und nocheinmal testen.

MfG
Andreas Jäger

Autor: thkais (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnte sein, daß der PC (bzw. die dazugehörige Software) den Reset-Pin
auf Masse zieht. Zieh die Schaltung vom LPT-Port ab und versorge sie
extern mit Spannung, dann sollte sie funktionieren. Oder trenne die
Reset-Leitung auf und mach einen Jumper rein.
Das Programm wird im Flash-Speicher gespeichert, dort geht es auch ohne
Spannungsversorgung für einige Dekaden nicht verloren.

Autor: Reinhard Schmaderer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Danke für die antworten.
Bauteilfehler oder so ist nicht, da wird nichts heiß und sonst ist auch
alles ok.
nehme mal an das das die resetleitung ist, wenn ich es nun richtig
verstanden habe, muß diese ständig an pluß liegen??
werde als mal mit den voltmeter nachmessen wenn die schaltung mal
wieder nicht geht, als vorher, naher messen.

danke nochmal
reini

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.