mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit SI-Prog, Pony Prog und WinXP


Autor: Alex22 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend!
Ich habe mir Heute den im Anhang abgebildeten ISP Adapter aufgebaut und 
wollte damit unter Windows XP mit Pony Prog einen Atmega32 
programmieren. Trotz mehrfacher Überprüfung der Hardware meldet Pony 
Prog immer einen Error 24 (=Device not found).
Hat jemand eine Idee woran das liegen könnte?
Ist der ISP Adapter eventuell nicht zu aktuellen PC's kompatibel?

Für einen Tipp wäre ich sehr dankbar,

schöne Grüße,
Alex

Autor: Alex22 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:

Der Atmega befindet sich im Auslieferungszustand, also laut Datenblatt 
auf interner Taktquelle. Ansonsten sind nur die beiden GND's und das VCC 
angeschlossen (5V). Reset über 10k gegen Vcc.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lade Dir mal "Giveio". Dieses Programm gestattet direkte Portzugriffe 
unter WinXP und die braucht Ponyprog.

MfG Paul

Autor: Alex22 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat leider(auch nach neustart) nicht geklappt.
Würde mich über weitere Beiträge freuen.

Autor: Kunde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kaufe dir einen Atmel AVR ISP, gibt's bei u. a. bei Reichelt und kostet 
knapp 40 Euro.

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieser Option bin ich mir bewusst. Mein Ziel war es mir einen absoluten 
low-cost Brenner zu bauen, um damit dann die Firmware in den Atmega im 
USBprog (http://www.ixbat.de/index.php?page_id=128) brennen zu können.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fällt mir nur noch ein: Alles "durchklingeln", evtl. bei einem Bekannten
an dessen Rechner hängen. Die Schaltung (von S.Hühn) ist so jedenfalls 
in
Ordnung und ich habe sie hier auch mit XP im Gange.

MfG Paul

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich hab auch schon mal damit gearbeitet und weiß, dass es von der 
Theorie her klappt. Es scheint nur aus mir unbekannten Gründen an meinem 
PC nicht zu klappen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.