mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Spannungsversorgung vom AVR


Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Wenn die Betriebsspannung des AVR abgeschaltet ist, und jedoch an einem 
ADC Pin eine Spannung zwischen 0 und 5V anliegt, kann dadurch der AVR 
zerstört werden?

Viele Grüße

Max

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Datenblatt darf die Spannung an den PINS auf keinen Fall groesser
als die Versorgungsspannung sein sonst kann ueber die eingebauten
Schutzdioden ein unzulaessig hoher Strom fliessen. Im extermfall kann 
dadurch ein sogenannter Latchup effekt entstehen der das Ic's zerstoeren 
koennte. Beim Latchup werden innerhalb des IC's parasitaere Thyristoren 
gezuendet die einen hohen Strom durch das IC fliessen lassen koennen.

Wenn nun die Versorgungsspannung wegfaellt dann darf auch den Pins keine
Spannung mehr anstehen.

Siehe auch im Datenblatt unter absolute Maximum ratings nach.

Gruss Helmi

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Vielen Dank für die Antwort! Die Werte aus dem Datenblatt sind mir 
bekannt, ich werde das Problelm noch etwas genauer beschreiben.
Der ADC misst die Spannung eines Spannungsteilers, welcher einen 
Gesamtwiderstand von mehreren 10k besitzt. Es kann dadurch auch auch in 
den Eingangspin nur ein Strom <1mA fließen.
Kann es dann trotzdem noch zur Zerstörung des AVRs kommen?


Vielen Dank für Eure Hilfe!

Viele Grüße

Max

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Normaler weisse nicht.

Stroeme unter 1 mA halten die Eingangsschutzdioden normalerweise aus.
Zur Sicherheit kannst du je eine 1N4148 (oder besser Schottky) Diode 
nach +5V und eine nach GND
schalten , so werden die Stroeme aussen abgeleitet.

Allerdings bei mehr als 10 K Innenwiderstand der Signalquelle ergibt
sich die Frage wie schnell willst du messen. Den die Eingangskapazitaet 
des
ADC bildet mit dem Innenwiderstand einen Tiefpass.


Gruss Helmi

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Die Messgeschwindigkeit ist sehr niedrig. ca. 1 mal pro sec. Die 
Schaltung selbst funktioniert bereits korrekt, ich war nur unsicher 
bezüglich der Spannungsversorgung.

Viele Grüße

Max

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.