mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Optokoppler koppelt nicht...


Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute, bin arg verzweifelt, da meine elektronik-einsteiger
-laufbahn nur mit pech behaftet ist....erst probleme mit dem isp bau.
und jetzt klappt sogar das betreiben von einfachen optokopplern nicht.
da dies für mich aber auch neuland ist, frage ich lieber mal nach ob
ich bei diesem einfachen teil nicht auch irgendwas falsch machen:

ich will zwei kontakte über den optokoppler verbinden, einmal den plus
(ca 3V) und einmal den massekontakt, das was sonst ein taster macht,
soll nu der optokoppler machen. also an ermitter und collector kommen
jeweils die beiden kontakte dran (der eigentliche taster wird somit
ersetzt)
an anode kommt die 5v-spannung und an cathode halt masse.
dennoch "zieht" der optokoppler nicht an. habe alle pins
nachgemessen. spannung liegt an, aber nichts passiert...das sowohl mit
einem PC 829 als auch mit einem PC 817....woran kann das liegen?
da alles wohl weniger als 50mA verlangt, sollte es doch gehen....

oder mache ich grundlegend was falsch?

Besten dank für eure hilfe

Autor: mmerten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn du die LED ohne Vorwiderstand an +5V betrieben hast, dürfte sich
der Optokoppler bereits in's Nirvana verabschiedet haben.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich dachte so ein pc 817/829 kann bis zu 6V ab? auf wieviel müsste ich
denn runter bzw was für widerstand benutzen?

Autor: funker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das datenblatt dürfte auch weiterhelfen. Wonach hast du denn die
Optokoppler ausgewählt?

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
im datenblatt steht Vce=5V und reverse voltage 6V...und als ich im laden
meinte, daß ich bei 5-12 volt koppeln will mit möglichst geringem
stromverbrauch und niedriegem ansprechverhalten, gab es diese....also
was nun tun? bin mehr als ratlos...hab jetzt mal 470ohm an die 5
voltleitung gepackt, aber auch da passiert nichts....

Autor: ThomasB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Mike:
Mess mal mit einem "Ohmmeter",die Anschlüsse Kollektor und
Emitter,ob
sie "durchschalten".

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so, wie es aussieht, scheint die 5v vom 7805 die koppler doch zu
killen...ich hab dann mal einen 470 ohm rangemacht und mit dem
messgerät gemessen: zwischen 088 und 092 ersscheint auf dem display,
dort wo sonst bei der durchgangsmessung entweder 1 für kein durchgang
oder 001 für durchgang erscheint.....dann hab ich nochmal eine
ohm-messung gemacht: 430 Ohm....aber was soll das? ich dachte immer,
die optokoppler sein so eine art relais, welche halt einen durchgang
ermöglichen....irre ich mich da?

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eieieiei!

Also ein Optokoppler koppelt, wie der Name schon sagt, optisch, also
mit Licht. Auf der Eingangsseite ist dazu eine LED eingebaut die, so
wie jede andere auch, max. 20mA an Strom verträgt. Am Ausgang ist dann
entweder eine Photodiode oder ein Phototransistor die mit Hilfe des
Lichts in den leitenden Zustand versetzt werden. Wenn du also den
OK-Eingang direkt an 5Volt hattest, ist der nur noch als "Schmuck"
für die Freundin geeignet. Das nennt sich dann Lehrgeld bezahlen. Macht
nichts, ich habe auch schon einiges an Lehrgeld gelassen.

MFG Uwe

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>>>Wenn du also den
OK-Eingang direkt an 5Volt hattest, ist der nur noch als "Schmuck"
für die Freundin geeignet. Das nennt sich dann Lehrgeld
bezahlen.<<<<<<

Hihi - Du solltest für die Sendung mit der Maus schreiben!!!!

Gruß, Thomas (der auch schon ne ganze Menge Lehrgeld gezahlt hat)

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
okay kindas, und nu? was muß ich nun machen, daß ich einen verlustfreien
durchgang habe?mit anderen worten, was muß an anode und cathode ran,
damit es funzt. wenn 5v vom 7805 nicht gehen, wie dann?

Autor: Frank Linde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie Uwe schon schrieb: Das Zauberwort heißt "Vorwiderstand", damit Dir
beim nächsten Versuch nicht wieder der Optokoppler abraucht. Im
Datenblatt feststellen, welchen Maximalstrom die LED im Koppler
verträgt und nach Ohmschem Gesetzt den Vorwiderstand berechnen. Oder
mit dem üblichen Daumenwert "max. 20 mA" arbeiten.

Gruß, Frank

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also das wären ca 330 ohm bei 5v, richtig ? mal eine frage nebenbei,
geht das eigentlich (also das verbinden von zwei kontakten) mit einem
Optokoppler (pc 814/817/829)? oder habe ich da schon von vorneherein
verloren und sollte auf miniaturrelais wechseln?

Autor: Frank Linde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, mit 330 Ohm bleibst Du unterhalb der 20 mA. Ja, ein Optokoppler
überträgt ein Signal im Eingangsstromkreis per Licht 1:1 (idealisiert)
auf den Ausgangsstromkreis.

Gruß, Frank

Autor: Steffen Burr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon, aber nicht vergessen, dass der Fototransistor (bzw. die
Fotodiode) auch nicht unbegrenzt Strom vertägt! Also auch hier im
Datenblatt überprüfen!

Grüße Steffen

Autor: edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mike,


also an ermitter und collector kommen
jeweils die beiden kontakte dran (der eigentliche taster wird somit
ersetzt)

nach moeglichkeit 0V an emitter und kollektor an die positive ...

ed

Autor: ---- (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Optokoppler ist sekundärseitig kein Relais. Also 2 Kontakte, die
dann verbunden sind is da nicht. Denk dran, das ist ein Halbleiter (mit
entsprechenden Übergängen - Diodenwirkung...).
Nimm doch besser ein Miniaturrelais.

---- (QuadDash).

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so, nach zigmal probieren hats dann doch geklappt, aber nur mit 9V und
800ohm, leitungen in flußrichtung richtig an emitter und collector
angeschlossen, alles funzt! *freu
relais sind aber zu groß und zu teuer, deswegen wollte ich es mit
optokopplern probierien....einzig die 9V stören ein wenig, da ich alles
auf 5V lauf lassen wollte....ist es eigentlich schlimm, wenn ich an
eine masse, an der normalerweise 3 Volt-Plus anliegen ich 9V-Volt masse
anlege? oder ist masse gleich masse?

Autor: edi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mike,

wo brauchst du 9 volt,damit es funktioniert?...primaer an der diode?
oder sekundaer am transistor?

ed

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
an der anode, da liegen dann über 800 ohm die 9v an und der collector
und emitter werden dann widerstandsfrei verbunden - bei 5volt waren da
je nach widerstand an der anode zwischen 100 ohm und 700ohm gemessen
worden bei emitter und collector

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.