mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega8 Beschaltung


Autor: Udo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ich brauche nochmal eure Hilfe - vielen Dank an dieser Stelle - das 
Forum ist echt klasse.

Ich habe Probleme den ATmega8 vom STK500 auf eine eigene Platine zu 
befördern.
Auf dem STK500 läuft alles absolut planmäßig, habe an PortC 3 LEDs, an 
PortB 3 Taster und an PortD ein LCD am laufen.

Wenn ich jetzt den µC in den Sockel auf der Lochplatine setze bekomm ich 
an den Pins völlig andere Spannungen als sie eigentlich sein sollten.

- VCC  = AVCC = 5V (kurz vor dem Pin noch ein 100nF gegen Masse)
- Aref habe ich aufgrund verschiedener Meldungen zwei Sachen probiert
     - Pin freiliassen
     - Pin über 100nF an Masse
- GND beide Pins auf Masse
- Reset über 10kOhm an 5 V und über einen 60pF an Masse

Irgendwas falsch verschaltet ?
Ich brauche doch Aref nicht, wenn ich die Pins von PortC als Ausgang 
verwende oder ?

Die von mir über einen LM7805 generierte Spannung hab ich schon durch 
die Spannung vom STK ausgetauscht - dort liegt der Fehler nicht.
Ich habe beispielsweise an allen PINs von PORTC 5V obwohl ich einige auf 
0V gelegt habe, was auch auf dem STK wunderbar funktioniert und messbar 
ist.

Gruß
Udo

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
>Wenn ich jetzt den µC in den Sockel auf der Lochplatine setze bekomm ich
>an den Pins völlig andere Spannungen als sie eigentlich sein sollten.
kannste das mal genauer beschreiben? Nicht das der Mega seinen externen 
Takt vermisst(weil gesetzt)

MFG, Uwe

Autor: The Devil (devil_86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jaja, mehr Infos wären schon nicht schlecht.

Autor: Udo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab noch einige Tests gemacht um das Problem genauer zu Beschreiben. 
Der Fehler tritt zur Zeit nicht mehr auf. Mein Verdacht ist ein 
Wackelkontakt in der Spannungsversorgung aber ich melde mich nochmal, 
falls der Fehler nochmal auftritt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.