mikrocontroller.net

Forum: Platinen Layout büdde checken


Autor: Kai Scheddin (zeusosc)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,..

diese Platine wurde erstellt geätzt gelötet, der 2te "µC" ist nur als 
pinadapter gedacht, also besitzt die schaltung in wirklichkeit nur einen 
"µC".

Alle ISP PINS haben verbindung zum proger, ich habe auch keinen Kurzen 
endecken können, der µC ist ok, das habe ich in ner anderen schaltung 
ge-checked,.. stromversorgung ist ok, beim versuch zu progen zieht der 
reset auf low,.. dennoch ich kann den µC in dieser schaltung nicht per 
ISP proggen,.. und ich habe keine ahnung warum,.. der 6er pin in der 
rechten seite ist richtig "ge"jumpert, und hat gerade mal~0.3 Ohm...

Hat irgend jemand ne idee wo der Zwerg in der schaltung ist???

grüüße

----------------------------------
achso falls ich vom layout n stück vergrößern soll sagt bÖschÄid,..

Autor: sechsnullsechs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist irgendwie schwierig das Layout zu pruefen, wenn das Bild zu klein 
ist. Das Schema mein ich.

Autor: Kai Scheddin (zeusosc)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier n neues,..

Autor: die ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für sowas gibts den
show

Befehl?!?

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Scheddin wrote:
> Hi,..
>
> diese Platine wurde erstellt geätzt gelötet, der 2te "µC" ist nur als
> pinadapter gedacht, also besitzt die schaltung in wirklichkeit nur einen
> "µC".

Ehrliche Meinung ?
Sieht scheisse aus..

Warum ist das Layout auf der Bauteileseite ?


>
> Hat irgend jemand ne idee wo der Zwerg in der schaltung ist???

SCK ist nicht angeschlossen, wenn Du den 10-poligen ISP-Stecker nimmst

Warscheinlich hast Du in deiner "Busstruktur" einen Fehler drin.
Den kann man aber so nicht sehen, häng mal die Eagle-Dateien an.

Grüße
Björn

Autor: Kai Scheddin (zeusosc)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Gut, SCK ist SPI3, leider ist das namentlich nicht gekennzeichnet, wenn 
man sich den ersten µC anschaut sieht man am PB7 ein zweiten BUS, das 
ist der SPI[..] bus, an welchem SPI3 an PB7 läuft, sck ist also 
angeschlossen, leiter wurde auch auf einen kurzen und güte geprüft, ist 
ok,...

Zum top ätzen, naja wie gesagt ist das eine adapterplatine wo die pins 
des "zweiten" µC's nach unten rausführen, hatte keine andere idee wie 
man am besten löten könnte, deshalb der toplayer,..

Im anhang ist eine SFX ZIP mit dem schema und pcb layout von eagle,..

Vielen dank für eure mühe,.. :)

Autor: hubert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.exe? eine höchst brisante sache ;)

.zip haette auch gerreicht

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daumenregel für VCC/GND-Kondensatoren: Jedes solche Pärchen kriegt 
einen, und der sitzt so dicht dran wie möglich. Auch der Quarz könnte 
dichter dran. Ist hier beides nicht kritisch (lies: schon Schlimmeres 
gesehen) aber kein Grund erkennbar es nicht besser zu machen.

Autor: Kai Scheddin (zeusosc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, naja, wie Du sagst mit den quarz gehts noch, der vcc/gnd kondi hätte 
ruhig dichter dran sein können,. nächste mal :)

nächste mal mach ich nur ne zip, das häckchen an SFX war bloß in dem 
moment sooo verlockend ;),...
hat schon jemand das potentielle problem erkannt ?,..

grüüüße

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo Kai,

Kai Scheddin wrote:

> hat schon jemand das potentielle problem erkannt ?,..
>


NEIN und es wird vermutlich auch keiner erkennen wollen und können,

da....

1. keiner deine EXE runtergeladen hat. Und auch keiner die EXE laden 
wird.
2. Du nur eine Seite vom Board veröffentlicht hast. Es gibt aber noch 
die
   blaue Seite ;-) sieht man an den VIA's

was sagen eigentlich ERC und DRC Check ?????

lass das mal drüber laufen und stell die Fehlerliste hier rein.


lg
Peter

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sag mal hast du die strippen etwa mit "WIRE" gezogen? das könnte dazu 
führen dass du überhaupt kein funktionierendes board bekommst, ich 
spreche da aus erfahrung ;) hab erst nach nem monat in der anleitung 
gelesen dass man das nicht machen darf..

Autor: l00k (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, zu seiner Verteidigung:

1. man kann eine exe auch entpacken, ohne sie zu starten. Winrar erkennt 
trotzdem, dass es ein Archiv ist und ignoriert das SFX-Geraffel

2. Es sind keine Vias sondern alles Bauteile - sieht man in der Grafik 
nur nicht.

Jetzt zum Problem:

Von den 4 ISP-Pins sind nur SCK  und RESET richtig verbunden.

- MOSI geht bei dir nur auf PIN2 von SV2. Müsste aber auf PIN6 vom 
Mega32.
- MISO geht auf PIN5 von SV2 statt PIN7 vom M32

PS: sieht wirklich Scheisse aus... ;-)

Autor: Kai Scheddin (zeusosc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Bauteil SV2 ist ne Jumperbrücke, also Jumper sind gesetzt SV2[1,2] 
und SV2[5,6]; 0,3 Ohm ist eigentlich vernachlässigbar klein,..

also durch die jumper sind die MOSI und MISO auch an dem entsprechenden 
platz,...
Entsprechende durchgangsprüfung vom ISP 10Pin zum PB5,6,7 habe ich auch 
gemacht,..
das scheint es nicht zu sein,...

was meinst Du warum wegen "wire" das board nicht funzt??

cool das ihr euch meinen problem annehmt,..
danköööö :)

Autor: l00k (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal ein Schuss ins Blaue: bau mal den R1 aus. Habe in meinen Schaltungen 
festgestellt, dass ein Mega8 sich mit Pullup an Reset nicht per ISP 
programmieren lässt.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wire funzt nicht. definitiv. wenn du dein schema gemacht hast und an den 
layouter übergibst, kommt nur müll dabei raus. bauteile werden nur an 
einem pin angeschlossen, usw. du hast dich auch sicher gewundert, wieso 
du an jedes bauteil eine junction klicken musstest.

mach die schaltung nochmal neu mit NET statt WIRE.
wie ich in deinem screenshot sehe ist ein IC nur an einem pin 
angeschlossen, der rest hängt in der luft. das ist eine folge von dem 
was ich gerade geschrieben habe!

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da ist noch viel mehr im Argen.

hab eben mal RipUp über die LP laufen lassen.

mein Layout ist komplett anders.

im Schaltplan hängen anscheinend auch noch Leitungen in der Luft.

Mann Mann das is vielleicht ein Knorz :(

g
Peter

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wo soll den Pin 5 von SV2 hin ??? der hängt in der Luft

Autor: Kai Scheddin (zeusosc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Peter S*:
sry, aber das ist bloß ein top layer layout,
ERC besagt 0 Fehler,..
Poste doch mal büdde dein layout,..

Wo hängen welche in der Luft???
so wie der screenshot vom pcb ist so wurder dieser auch geätzt, man 
sieht alle leitungen sind nach schaltplan verbunden,..

@lOOk: habe ich auch schon probiert, dasselbe ergebnis, funzt net,..

@Gast: das mit den Junctions hat bei eagle schon seinen grund, somit 
können wires aufm schaltplan sich kreuzen ohne das die Netze sich 
verbinden,..

hat jemand vlt. noch irgendwelche ideen?

dankööö

Autor: Kai Scheddin (zeusosc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahhhhhhhhhhhh,. da fällt mir was auf,... und zwar die beiden gnd flächen 
sind garnet miteinander verbunden,...
ui,.. das check ich erstma und meld mich dann wieder dankööö für eure 
müh

__________________
edit:
ach shit,.. die sindoch verbunden,..mist

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter S* wrote:
> wo soll den Pin 5 von SV2 hin ??? der hängt in der Luft

sorry, mein Fehler. der hängt nur an Pin 9 vom ISP

lg
Peter

Autor: Peter S* (sandmannnn)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
soderle...

ohne zwei Brücken gings jetzt nit auf die schnelle.

die Leiterbahnen durch den Stecker pfriemeln wollt ich nit.

Das is murks. so was macht man nit, wenns nit unbedingt sein muss.

lg
Peter

... perfekt ist das noch nicht. aber erst mal ohne Fehler

Autor: Peter S* (sandmannnn)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
so hab mir deins jetzt noch mal zu Gemüte geführt.

so unterschiedlich ist es jetzt doch nicht.
( manchmal sieht man den Wald vor lauter Bäumen nicht ;-) )

guck dir mal die gelb markierten Bereiche an.

Ich möchte wetten, das du da irgendwelche Kurzschlüsse hast.

mit ner Lupe oder unterm Mikroskop gucken

und mit Ohmmeter nachmessen.

lg
Peter

Autor: Kai Scheddin (zeusosc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo danke peter, werd ich morgen gleich mal machen,...

grüüüße

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Scheddin wrote:
> @Gast: das mit den Junctions hat bei eagle schon seinen grund, somit
> können wires aufm schaltplan sich kreuzen ohne das die Netze sich
> verbinden,..

Richtig. Trotzdem setzt man keine Junctions direkt an Bauteilpins, 
sondern eben nur genau dann, wenn man wirklich sich kreuzende 
Leiterbahnen verbinden will.

Benutze NET statt WIRE!

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter S* wrote:
> guck dir mal die gelb markierten Bereiche an.

Guck dir vor allem mal die Leiterbahn oben links an. Das müsste an der 
zweipoligen Buchse da sein. Na ob das gut geht...

Btw, man legt Leiterbahnen in aller Regel in 45° Schritten, weil das 
einfach unchaotischer und professioneller aussieht ;)

Autor: Kai Scheddin (zeusosc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok,. ich habe n kurzen zwischen ISP PIN 3 MISO leitung,... ich probier 
mal obs jetzt funzt,..

grüüße

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Scheddin wrote:
> ok,. ich habe n kurzen zwischen ISP PIN 3 MISO leitung,... ich probier
> mal obs jetzt funzt,..
>
> grüüße

grins ;-)

Autor: Kai Scheddin (zeusosc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok,. funzt :) jipiiiiii,... danke leutz :D

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.