mikrocontroller.net

Forum: PC Hard- und Software Vista: MP3-Wiedergabe stockt bei hoher CPU-Last


Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich musste am Freitag auf Windows ausweichen, da ich ein Programm nutzen 
musste, welches nur dort läuft.

Auf unseren Workstations ist Windows Vista Business bereits installiert.

Ich höre bei der Arbeit igentlich immer Webradio. Also auch unter 
Windows mit dem MediaPlayer.

Aber: Immer wenn ein anders Programm mal viel CPU-Last erzeugt, ruckelt 
die Musik.

Am Mediaplayer lag es nicht, ich habe den VLC installiert: gleiches 
Problem.
Auch die Internetverbindung wars nicht: lokale MP3 ruckelt auch.

Die Priorität vom Mediaplayer/VLC kann ich nicht erhöhen: Access denied
Die Priorität der Last verursachenden Anwendung kann ich nicht 
verringern: Access denied.
Und das obwohl ich Owner der Prozesse bin.

Es kann doch wohl nicht sein, dass ich nicht nebenbei ein bisschen Audio 
abspielen kann!

Als ich das Programm installierte (rund 700MB), konnte ich nebenbei 
nichts anderes machen. Selbst InternetExplorer bedienen ging nicht, da 
die Kiste so laaaaangsam war.

Das ist ein Quadcore-Rechner mit 8GB RAM...

Mache ich jetzt was falsch oder ist das Scheduling unter Vista nur so 
grottenschlecht?
Da muss irgendwas falsch sein!

Ich höre gerade Webradio auf meiner Linux-WS zu Hause. Die ist gerade 
nicht schlecht beschäftigt mit vielen vielen anderen Dingen (die Load 
liegt gerade bei 13) und mein xmms stockt ja auch nicht.

Bei uns in der Firma teilet sich die Verwaltung einen einzigen SunRay 
Server. 20-25 Personen, die gleichzeitig mit Openoffice und anderen 
Programmen arbeiten können auch nebenbei Webradio hören. Und der Server 
ist (nur) ein Dual Opteron mit 4GB RAM.

Autor: rayelec (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zurück in die Zukunft! Vista macht's möglich! Dasselbe Problem habe ich 
auch. Nur ist mein Computer ein PIII-1GHz (Win2K). Der Ruckelt bei mp3, 
wenn ich gleichzeitig grosse Datenmengen herumkopiere. Bei mir liegt's 
eindeutig an der Gesamtperformance des Systems. W2K wird auf dem alten 
PIII proportional ähnlich viele Ressourcen fressen.

mfG
Rayelec

Autor: popdog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hasse eigentlich den Glaubenskrieg der Betriebssystemanhaenger, aber 
am Montag habe ich Windows Vista kennengelernt. Eine Woche 
Fortbildung...

Sozusagen mein erster Kontakt mit Windows (mal abgesehen von drei Tagen 
Windows 3.11 in der Schule).

Als das Ding startete kam bei mir schon so ein: "Aha, schick". Es kam 
sogar ein leichter Anflug von Neid auf; aber nur kurz...

Windows Vista stinkt!

Ich musste die Muehle am ersten Tag viermal rebooten. Meine Workstation 
reboote nicht so oft in drei Jahren.

mc@amalthea:[~]uptime
 12:21am  up 218 days,  4:36,  10 users,  load average: 8.04, 3.98, 0.89

Ich bin meinem Papa ueberaus dankbar, dass er mir damals keinen PC, 
sondern eine Sun Ultra gekauft hat ;)

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey, ich habe die gleichen probs mit meinem lappy.

ich höre immer mp3s wenn ich zocke. seit vista ruckelt dann entweder der 
mp3 sound oder der sound des spiels. auch die ganzen games sind total 
langsam geworden.

mein lappy ist ein core 2 duo 2ghz mit 2gb ram 2 160gb festplatten im 
raid 0 und einer ati x1900.

mir ist es schon oft passiert das vista während eines onlinespiels 
updates heruntergeladen hat. erst ruckelt die inet verbindung und dann 
startet vista einfach neu ohne irgendwie vorher zu fragen.

so ein scheiss das vista


ich nehme wieder xp. dx 10 brauche ich jetzt noch nicht. kann man sowie 
nicht vernünftig auf vista zocken. erst wenn ein super-16-core intel 
core xyz rausgekommen ist.

Autor: Kai G. (runtimeterror)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann jetzt gerade nur für XP sprechen... ich schaffe es bei meinem 
Athlon X2 unmöglich meinen Rechner so auszulasten, dass mein Winamp 
hängt. Höchstens einen einzelnen Kern bei UT2004 auf höchster 
Detailstufe. Der andere Kern langweilt sich zu Tode...

Die einzige Erklärung die ich hätte wäre, dass Vista auf irgendwelche 
Hardware warten muss - da hängt Windows gerne mal komplett.

Einfach mal Chipsatztreiber und Treiber der Laufwerkscontroller auf 
Vordermann bringen, falls nciht eh schon geschehen. Sonst fällt mir da 
nichts ein.

Gibt der Taskmanager evtl. Aufschluss darüber, ob alle Kerne ausgelastet 
sind?

Hört sich alles irgendwie sehr unausgegoren an...

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das Problem auch noch nicht gelöst.

Die Audioausgabe von VLC (192kbps MP3 stream) ruckelt selbst, wenn ich 
im Explorer in ein Unterverzeichnis gehe.

Okay, Audio apsielen ist momentan nicht wichtig. Ich bin momentan 
sowieso alleine im Büro. Da kann ein anderer Rechner das übernehmen ;)

Das schlimme ist aber, dass meine Entwicklungssoftware gerade immer 
wieder absemmelt.
Und am Montag kommt unser Auftraggeber für eine erste Präsentation.
Leider wurden hier alles neue Rechner gekauft und alle mit Vista.
Auf Windows hat hier niemand geachtet, da fast ausschliesslich Linux 
benutzt wird.

Meine Windows-XP-CD von zu Hause funktioniert auch nicht, da der 
Festplattencontroller nicht gefunden wird. Man soll eine Treiberdiskette 
einlegen, nur die Rechner haben kein Diskettenlaufwerk mehr. 
Anschliessen geht auch nicht, da die legacy-free Mainboards keinen 
Floppy-Connector mehr haben.
Mein Chef hat sich eben über meinen Anruf sehr gefreut. Er den Kunden 
morgen vertrösten.


So. Jetzt aber ab nach Hause ;)

Autor: C.S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte ebenfalls Windows Vista Business mal ausprobiert, da es auf 
meinem neuen Firmennotebook schon drauf war.

Lief nicht wirklich schön. Und wenn man sowieso die Grafikeffekte 
abstellt, kann man gleich XP nutzen. Wirklich tolle Neuerungen gibts 
nicht. Das neue Filesystem ist noch nicht enthalten.

Nur bunt und nervig. Anscheinend wollte man nur ganzen Dau-User mit dem 
Bunti-Zeugs ködern.

Ich habe wieder XP Pro drauf. Ich hatten ebenfalls Probleme mit dem 
Festplattencontroller, der nicht erkannt wurde (FSC Amilo Notebook).

Da gibt es ein Programm mit dem Namen XP ISO Builder oder so ähnlich.
Der liest deine XP-CD ein, integriert den Treiber und schreibt eine neue 
CD.
Von dieser Installiest du dann und da ist der Treiber dann gleich schon 
mit drin.

Autor: Phony Pony (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das Windows Vista von meinem neuen Notebook auf meinem anderen 
PC installiert.
Ich wollte die Betriebssysteme einfach tauschen. Auf dem PC Vista vom 
Notebook und auf dem Notebook XP vom PC.

Nun habe ich mich doch entschlossen auf meinem PC XP zu behalten weil 
Vista da einfach zu langsam ist.

Ich kann aber auf dem Notebook Vista nicht mehr installieren. Erstens 
muss ich es jetzt aktivieren, was ich vorher nicht musste und 2. läuft 
die Aktivierung nicht durch.
Wenn ich übers Internet aktivieren will, sagt er geht nicht und ich muss 
anrufen.
Als ich dann da angerufen habe und die Nummer eingegen hatte wurde mir 
gesagt der Schlüssel könne nicht erzeugt werden und werde mit einem 
Hotliner verbunden.
Der sagte mir ich könne das Windows da nicht installieren, da diese OEM 
version nicht für diesen PC bestimmt sei. Aber das Vista war bei dem 
Notebook ja dabei. Und auf meinem anderen PC konnte ich es ja auch 
installieren und aktivieren.

Warum geht die Aktivierung nicht mehr? Die Microsoft-Typ konnte mir 
nicht helfen und konnte mir die Aktivierungsnummer auch nicht geben.

Gibt es irgendeinen Patch, den ich installieren muss?

Autor: Kai G. (runtimeterror)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Als mir das das letzte mal mit XP passiert ist, bin ich auf Linux 
umgestiegen :)

Mein Bruder hat das XP dann übernommen, bei ihm funktionierte die 
Aktivierung dann allerdings... keine Ahnung, wie die sich das 
vorgestellt haben. Die zwingen einen ja schon fast dazu irgendwelche 
gecrackte-Software zu installieren... lässt sich viel komfortabler 
installieren und läuft nachher ohne nerviges CD-Gewechsel (bei Spielen 
insbesondere)... aber ich komme vom Thema ab...

Autor: Grubby (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die zwingen einen ja schon fast dazu irgendwelche
>gecrackte-Software zu installieren... lässt sich viel komfortabler
>installieren und läuft nachher ohne nerviges CD-Gewechsel (bei Spielen
>insbesondere)... aber ich komme vom Thema ab...

Stimmt.

Ich nutze obwohl ich ein echtes Windows XP habe immer die gecrackte CD.

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scheinen wohl viele Probleme mit Vista zu haben.

Auf der einen Seite schreien die Vista-Jünger "Vista ist schneller als 
XP, Vista ist stabiler als XP, Vista ist das beste Windows aller 
Zeiten".

Auf der anderen Seite die Anti-MSler: "Vista ist Schrott, Windows 
allgemein ist Müll"

Bei hatte Windows XP sowie Linux beides seine Daseinsberechtigung. Ich 
nutze einige Programme, die es unter Linux (noch) nicht gibt. Auf der 
anderen Seite bin ich auch oft zu faul zum Umstieg.
Surfen, E-Mails verfassen und lesen, Office, AVR Programme schreiben, 
compilieren und hochladen usw. mache schon alles unter Linux.

Gestern haben mein Vater und ich uns beide ein neues Notebook gekauft. 
Ich ein FSC Amilo Xi 1554 und mein Vater das etwas schlechter 
ausgestattete Amilo Xi 1526.
Beide kommen mit Vista Home Premium daher.

Ich finde es eigentlich schon eine Frechheit, dass ein neues Notebook so 
langsam ist.
Einschalten, "Windows bereitet sich für den ersten Start vor", warten, 
warten, warten
Ich habe nicht auf die Uhr geschaut, aber das hat schon extrem lange 
gedauert. Auch die Bedienung ist eher langsam.
Auf dem Notebook meines Vaters (1,86GHz Core 2 Duo, 1GB RAM) merkt man 
das noch viel deutlich als auf meinem (2GHz Core 2 Duo, 2GB RAM).


Deswegen habe ich heute zwei mal Windows Vista entsorgt. Mein Vater hat 
Ubuntu Gutsy Gibbon bekommen und ich Ubuntu und Windows XP.

Leider ist das Vista an die Geräte gebunden. Sonst würde ich es bei eBay 
verscheuern.


Ich habe die Lizenz-Aufklber abgeknibbelt. Die nehme ich zur Arbeit mit 
und klebe sie dort auf die Klobrille ;)

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hänge mein Problem einfach mal hier an:


Ich habe Probleme mit Vista und dem Soundmixer.

Ich ich Sound abspiele und dann einen Köpfhörer reinstecke, dann kommt 
der Sound immernoch aus den Boxen und der Kopfhörer ist tot.

Beim Mixer gibts einmal Kophörer und Lautsprecher. WinAMP oder andere 
Programme stehen dann immer bei Lautsprecher.
Also habe ich in der Systemsteuerung Kopfhörer als Standard-Ausgabe 
eingerichtet. Nun stehen die Programme, die Sound ausgeben, beim Mixer 
alle unter Kopfhörer, aber es kommt jetzt kein Sound raus. Weder aus dem 
Kopfhörer noch aus den Boxen.

Wenn ich jetzt den Kopfhörer raussziehe und nochmal reinstecke, dann 
erscheint im Mixer nochmal Lautsprecher.
Wenn ich dann in der Systemsteuerung das zweite Paar Lautsprecher als 
Standard auswähle, dann kommt der Ton wirklich aus dem Kopfhörer.

Nun wenn die Kopfhörer rausziehe, muss ich immer alle Soundprogramme 
schliessen die Standard-Soundausgabe in der Syssteuerung umstellen und 
dann wieder die Soundprogramme starten.


Ich kapier das nicht.
Wie bekomme ich das so hin wie unter XP?
Sound kommt aus den Boxen. Wenn ich den Kopfhörer reinstecke, sind die 
Boxen still und der Sound kommt ausm Kopfhörer.

Wie geht das unter Vista?

Autor: Domino (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey, bei mir gibts immer einen Bluescreen wenn ich den Kopfhörer 
reinstecke.

Ist der Original Vista Treiber. Für mein Mainboard gibts keine Vista 
Treiber.

Sobald ich einen Stecker in die rote (Mikro) oder grüne (Kopfhörer/ 
Lineout) Buche stecke, friert das System ein und nach etwa einer halben 
Minute gibts einen Bluescreen. Da wird der Speicher irgendwie auf die 
Festplatte kopiert und dann startet der Rechner neu.


Ausserdem ist es mir schon zwei Mal passiert, dass er angezeigt hat dass 
das Vista nicht Original sei, obwohl ich es gekauft habe (Retail Box 
Vista Home Prem).

Ich habe schon bei Microsoft angerufen und die meinten mein Mainboard 
sei kaputt.
Das glaube ich aber nicht, da es unter XP ja funktioniert.

Leider will der Händler das Vista nicht mehr zurücknehmen, da ich es 
schon installiert habe.
Und das obwohl es nicht funktioniert. Ich habe vor dem Kauf diesen 
Hardwarekompatibilitätstest heruntergeladen und der sagte es sei alles 
OK (bis auf mein Anti-Virusprogramm).

Ich habe dann eine (sachliche!) Beschwerdemail an Microsoft geschreiben, 
die natürlich auf nach zwei Monaten nicht beantwortet wurde.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leutchen, für dieses Problem gibt es nur eine vernüftige Lösung:

           SCHMEISST DIESES KACKBETRIEBSYSTEM WEG!
            Es ist so überflüssig, wie ein Kropf.
           Klagen darüber sind ebenso überflüssig.

Wenn Ihr Windows braucht, nehmt XP Pro SP2 in der 32-Bit-Version.

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich habe schon bei Microsoft angerufen und die meinten mein
> Mainboard sei kaputt.

Das lernen die Call-Center-Mitarbeiter(innen) in ihrer Kurzeinweisung
als die zu ziehende Notbremse bei Problemen, deren Lösung länger als
zehn Minuten zu dauern droht.

> Ich habe dann eine (sachliche!) Beschwerdemail an Microsoft
> geschreiben, die natürlich auf nach zwei Monaten nicht beantwortet
> wurde.

Dass Microsoft überhaupt nicht antwortet, finde ich nicht sehr nett.
Wenigstens eine kurze Nachricht, aus der du ersehen kannst, dass deine
Beschwerde gelesen wurde, wäre drin gewesen. Auf der anderen Seite
kann ich mir gut deren Spam-Flut vorstellen, so dass die eine oder
andere E-Mail sicher verloren geht. Auf einen papiernen Beschwerde-
brief würde ich aber auf jeden Fall eine Antwort erwarten.

Auf Alpha-Tester wie dich und alle anderen Privatanwender, die gerade
einen neuen Rechner gekauft haben, sind die ja schließlich angewiesen.
Die Firmenkunden sind meist nur Beta-Tester und setzen ein neues
Windows i. Allg. erst nach Erscheinen des ersten Service-Packs ein. Um
aber den SP zu entwickeln, ist eben gerade das Feedback von den
Privatanwendern erforderlich.

PS: Ich selbst bin immer am besten als Release-Tester gefahren. Auf
die nächste Windows-Version steige ich nämlich immer erst dann um,
wenn die übernächste schon auf dem Markt ist. Ab da lohnt es dann
nicht mehr, auf SPs und Bug-Fixes zu warten, da es praktisch keine
mehr gibt (außer vielleicht ein paar Sicherheits-Patches). So bin ich
erst vor ein paar Wochen von 2000 auf XP umgestiegen. Ich bin zwar
nicht wirklich glücklich damit, aber besser wird's halt nicht mehr
werden.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieses "ich starte jetzt einfach neu ohne zu Fragen" ist mir auch schon 
untergekommen.

Gerade wärend ich meinen Film am rendern war. Schwupps, neustart.

Ich fand die Taktik in XP schon immer assozial: Jetzt neu starten oder 
15 min, aber das geht ja überhaupt nicht.

Ich werde meinen neuen Rechner mit Vista, den ich am Mi geliefert 
bekommen habe vielleicht wieder zurückgeben und mir einen Mac kaufen.
Ich gehe heute mal in den Apple Shop und schaue mir die Dinger mal an.

Ich brauche den Rechner sowieso hauptsächlich für Office-Aufgabe, 
Bildbearbeitung (Hobby) und Videobearbeitung (Hobby).
Dazu kommt ein bisschen AVR.

Alles das kann ich auf einem Mac auch machen. Zur not könnte man Windows 
dort auch noch installieren.

Ich bin zum Glück schon seit einige Jahren von Microsoft Office weg und 
nutze  seit dem StarOffice bzw. OpenOffice.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sebastian wrote:

Das geht jetzt nicht gegen Sebastian.

> alle unter Kopfhörer, aber es kommt jetzt kein Sound raus. Weder aus dem
> Kopfhörer noch aus den Boxen.

Kann mir bitte mal ein Mensch erklären, wozu man bei einer
Soundausgabe einen Kopfhörertreiber braucht?
Was bitte ist falsch an den Klinkenbbuchsen, die seit Menschen-
gedenken benutzt werden, die beim Einstecken des Steckers den
Pfad zum Lautsprecher mechanisch unterbrechen. Simpel und zuverläsig.

Es wird wirklich Zeit, den Fetzenschädeln in Redmond einen
vor den Latz zu knallen. Dort ist meiner Meinung nach der
unfähigste Haufen Programmierer dieses Planeten versammelt.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Scheinen wohl viele Probleme mit Vista zu haben.

Schau dir die Bewertungen und Kommentare bei alternate an. Vista ist an 
sich nicht schlecht, nur hat es massive Kinderkrankheiten. Bei mir läuft 
es stabiler und schneller als XP. Empfehlen würde ich es aber auch nur 
bedingt. Einen echten Mehrwert sehe ich noch nicht. Die angesprochenen 
Probleme kann ich so nicht nachvollziehen.

Dass noch immer keine Treiber für alle Hardware zur Verfügung steht, 
sollte man eigentlich wissen. Da hilft kein meckern sonder nur lesen 
lernen.

>Ist der Original Vista Treiber. Für mein Mainboard gibts keine Vista
>Treiber.

Wie nun?

>Dieses "ich starte jetzt einfach neu ohne zu Fragen" ist mir auch schon
>untergekommen.

Das wurde von XP übernommen und lässt sich genauso wie dort umstellen, 
so dass die Updates geladen aber erst beim Herunterfahren installiert 
werden.

>Kann mir bitte mal ein Mensch erklären, wozu man bei einer
>Soundausgabe einen Kopfhörertreiber braucht?

Das Problem liegt beim Codec. Die meisten Mainboards haben 5.1 sowie 
einen Kopfhörerausgang. Nun muss du dem Codec nur mitteilen, wohin er 
die Ausgabe schicken soll. Da das nicht durch anschreien funktioniert, 
macht dies ein Treiber. Warm aber jemand den Lautsprecher in den 
Kopfhörerausgang steckt, ist mir schleierhaft. Hierzu braucht man eine 
Weiche, die meist passiv aufgebaut sind, sodass man zwar im Lautsprecher 
was hört, aber eben auch im Kopfhörer, was aber wiederum egal ist.

Autor: Sebastian Mazur (izaseba)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Da ich vor kurzem einen neuen Laptop bekommen habe, bin ich jetzt auch 
ein 'stolzer' Besitzer von WinVista.

Normalerweise bin ich ein Überzeugter Linux Anwender, aber ein Blick 
über
den Tellerrand kann ja nicht schaden ;-)

Tja, so schlimm finde ich das ganze garnicht, alle Anwendungen, die ich 
brauche laufen ohne Probleme, zugegeben, auf dem Laptop wird 
hauptsächlich
µC Programmierung gemacht, aber wie gesagt, ich bin noch nicht soweit, 
daß ich mir Linux draufspiele.

Es hat zwar paar Tage gedauert, bis ich die wichtigsten Tastaturkürzel 
drin hatte, es gibt nichts schlimmeres als die Hände von der Tastatur 
abzunehmen...

Das einzigste, was ich zu meckern habe, die Kiste ist schon paar mal mit
einem Bluescreen abgeschmiert.

Gruß Sebastian

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vista soll also schnell sein ?!

Keine Spur.

Wenn ich mal meine beiden Workstations miteinander vergleiche:

1. Intel Core 2 Duo 2,0GHz, 2GB RAM, Vista Business 64
2. Intel Celeron 430 1,8GHz, 512MB RAM, Ubuntu Netboot (Diskless) über 
100MBit LAN

Wenn ich auf beiden den Firefox starte, dann ist meine 2. Workstation 
fast doppelt so schnell.

Selbst OpenOffice startet unter der Ubuntu deutlich schneller.


Das kanns doch wohl nicht sein...

MPEG4-HD (1080p) kann ich unter Vista nicht ruckelfrei abspeilen. Unter 
Linux geht das. Auch mein alter iMac (Core Duo 2GHz) konnte das 
problemlos.


Ich kann Vista nichts positive abgewinnen.
Ich bin aber auch kein Fan bunter Oberflächen.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann unter Linux auf meinem Zweitrechner mit einem P2-450 flüssig TV 
schauen (DVB-S, Budgetkarte ohne Hardwaredecoder!).

Das ging unter Windows 2000 nicht.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> 1. Intel Core 2 Duo 2,0GHz, 2GB RAM, Vista Business 64

Scheinbar hast du etliche Fehler drin. Wozu 64bit, wenn du nur 2 GB RAM 
hast?
Und man sollte es wissen, dass x64 noch nicht voll unterstützt wird. Das 
meiste läuft dann als x32-Emulation.

BTW: Bei mir startet Firefox auf einem 1.8 GHZ-Rechner ca. 3x so 
schnell, wie unter Ubuntu mit einem Core Duo 2.33 GHZ. Von OO rede ich 
erst gar nicht, das es ca. 30s zum starten braucht.

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Scheinbar hast du etliche Fehler drin. Wozu 64bit, wenn du nur 2 GB RAM
>hast?

Genau. Wenn ich dann 2GB Speicher nachrüste, dann installiere ich mal 
eben das Betriebssystem neu.

Ich denke, dass du da einiges verpasst hast. 64bit-BS bedeutet nicht nur 
den grösseren Addressierbereich des RAMs nutzen können.

Ubrigends können viele Unix-Betriebssysteme in den 32-bit Versionen mehr 
als 4GB RAM addressieren. Das nennt sich dann PAE (physical address 
extension).


>Und man sollte es wissen, dass x64 noch nicht voll unterstützt wird. Das
>meiste läuft dann als x32-Emulation.

Bei IA64-CPUs würde ich dir zustimmen. Aber x86_64-CPUs können IA32-Code 
nativ ausführen. Also nix mit Emulation.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Genau. Wenn ich dann 2GB Speicher nachrüste, dann installiere ich mal
>eben das Betriebssystem neu.

Wer erzählt dir denn diese Märchen? Hast du die aus einem Linuxforum?

>Bei IA64-CPUs würde ich dir zustimmen. Aber x86_64-CPUs können IA32-Code
>nativ ausführen. Also nix mit Emulation.

Eben nicht. Sonst gäbe es keine Probleme mit den Treibern. 
32bit-Anwendungen laufen in einem Subsystem des 64bit-Windows.

Welchen Vorteil hat denn das 64bit-System für dich? Für die Probleme, 
die du oben ansprichst, existieren keine 64Bit-Versionen. Den Adressraum 
nutzt du auch nicht aus. Viele 32Bit-Anwendungen laufen langsamer als 
auf einem 32Bit-System. Ist es eigentlich nur cool und 1337, ein 
64Bit-BS zu haben?

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Genau. Wenn ich dann 2GB Speicher nachrüste, dann installiere ich mal
>>eben das Betriebssystem neu.
>
>Wer erzählt dir denn diese Märchen? Hast du die aus einem Linuxforum?

Du hast gefragt, warum ich ein 64Bit-Windows nutze, wenn ich nur 2GB RAM 
habe.
Windows in der 32Bit-Version kann eben nur 2^32 Byte = 4 GiB Speicher 
addressieren. Darin enthalten ist aber z.B. noch der Memory-mapped-I/O 
usw. Da ich aber auf 4 GiB aufrüsen möchte, brauche ich ein 64 Bit BS, 
da sonst nur etwa 3,5 GiB nutzbar wären.


>>Bei IA64-CPUs würde ich dir zustimmen. Aber x86_64-CPUs können IA32-Code
>>nativ ausführen. Also nix mit Emulation.
>
>Eben nicht. Sonst gäbe es keine Probleme mit den Treibern.
>32bit-Anwendungen laufen in einem Subsystem des 64bit-Windows.

Treiber sind keine eigenständigen Anwendungen, sondern nur 
"Erweiterungen" des Kernels. Da der Kernel nun mal bei einem 64-Bit-BS 
im 64-Bit-Mode des Prozessors läuft, kann man keine 32-Bit-Treiber 
verwenden.

Das Betriebssytem kann für ein beliebiges Codesegment den sog. 
Compability-Mode aktivieren. So können 32-Bit-Anwendungen nativ 
ausgeführt werden.

32-Bit-Programme sind dann nicht langsamer als auf einem 32-Bit-System. 
Allerdings sind bei einem 64-Bit-System die Adressen natürlich doppelt 
so gross und desshalb ist der Speicherverbrauch höher. Theoretisch 
könnte man hier sagen, dass dies zur Folge hat, dass Programme daher 
auch langsamer ausgeführt werden.
Allerdings ist der reale Geschwindigkeitsunterschied mehr als marginal.


Und das habe ich nicht aus einem Linuxforum, sondern aus dem "Intel 64 
and IA-32 Architectures Software Developer's Manual".

Autor: Harry (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte unter Vista auch Probleme mit dem Kopfhöreranschluss.
Obwohl es einen Sound-Treiber für Vista von dem Notebookhersteller gibt, 
funktioniert der Kopfhöreranschluss einfach nicht.

Wenn ich da einen Stecker reinstecke, dann bleibt der Lautsprecher an 
und der Kopfhörer tot.

Ich bin wieder zurück zu XP. Der Kopfhöreranschluss ist sehr wichtig für 
mich. Ausserdem ruckeln einige Spiele unter Vista.
Das Notebook ist zwar nicht das neuste, aber unter Windows laufen die 
ruckelfrei.

Autor: Harry (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich meinte unter Windows XP laufen die Spiele ruckelfrei.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Wer erzählt dir denn diese Märchen? Hast du die aus einem Linuxforum?

>Du hast gefragt, warum ich ein 64Bit-Windows nutze, wenn ich nur 2GB RAM
>habe.

Liest du auch, was du schreibst?

Zitat:
>Wenn ich mal meine beiden Workstations miteinander vergleiche:

>1. Intel Core 2 Duo 2,0GHz, 2GB RAM, Vista Business 64

Für was steht bei dir die 64 ganz hinten?


>Und das habe ich nicht aus einem Linuxforum, sondern aus dem "Intel 64
>and IA-32 Architectures Software Developer's Manual".

Du verwechselst was mit dem Itanium.

Autor: popdog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Itanium = IA-64-Architektur => Ausführung von IA-32 Code nur im extrem 
langsamen Firmware-Emulationsmodus

Intel 64 = AMD64 = x86_64 = EMT64 = IA32e => Erweiterung der 
IA-32-Architektur; kann IA-32-Code im Compability-Mode ausführen

http://en.wikipedia.org/wiki/Amd64

Autor: Spock (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Als wir neue Server angeschafft haben, kam die Frage auf, ob wir ein 
i386 oder gleich ein amd64-Linux installieren wollen, da unsere 
Groupware-Serversoftware nur für i386 erhältlich ist.

Wir haben das recht ausführlich getestet und konnten feststellen, dass 
elf32-Binaries auf einem amd64 nicht langsamer waren als auf einem 
reinen i386-System.

Allerdings sind die elf64-Bins etwa 20-30% grösser.

Autor: Charger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Windows Vista stinkt!

Stimmt! Dagegen riechen faule Eier noch angenehm.


Die einfachsten Programm und Tools laufen nicht mehr. Alles ist so 
langsam und träge.

Bei mir starten manche Anwendungen beim ersten mal nicht. Ich klicke auf 
das Symbol im Startmenü, es wird geladen und es passiert nichts. Beim 
zweiten oder dritten Mal startet das Programm dann.
Dieser Fehler tritt auch bei den Programmen auf, die Vista mitbringt.

Und Bluescreens hatte ich auch schon drei!

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei uns in der Firma hatte die Geschäftsführung entschlossen "mit der 
Zeit zu gehen" und auf Vista umzusteigen.

Unser IT-Dienstleister sollte vorher die Kompabilität prüfen. Dies hat 
er aber wohl nicht so ganz richtig gemacht, denn die rund 240 
Vista-Lizenzen gehen wieder zurück, da unsere Software teilweise nicht 
richtig läuft.
Die Software lässt sich zwar starten, kann aber nicht zum Server 
verbinden. Das Programm stürzt dann immer ab.

Da Teile der Software extra für uns geschrieben wurden, müssten diese 
jetzt angepasst werden.
Das kommt wohl zu teuer. Desshalb werden nur ca. 20 Rechner der 
Verwaltung auf Vista geupdatet.

Mit Microsoft gabs hier schon so einige üble Überraschungen.
Nachdem die Server von Win 2000 Server auf Win 2003 Server geupdatet 
wurden, hatten wir 4 Tage frei, da nichts mehr lief.
Dabei waren für das Update extra Techniker von Microsoft da. Das Update 
wurde acht Wochen geplant, aber trotzdem ist alles schief gegangen.

Unser Partnerunternehmen arbeitet mit IBM-Mainframes (die haben noch 
alte AS400). Dort gibt es kaum Probleme. Richtige ausfälle gab es noch 
nie.

Unser E-Mail Server liefert regelmässig keine Mails mehr aus. Zum Glück 
gibts Spam. So sieht man wenigstens, dass was nicht stimmt.


Ich selbst mag Linux nicht und glaube auch nicht, dass es besser für uns 
laufen würde, aber das was Microsoft da abliefert ist doch totaler Müll!

Autor: Jesus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vor 4 Wochen ist mein neuer Rechner gekommen. War gleich Vista drauf.

Erstes Anschalten: Ihr System wird für den ersten Start vorbereitet...
Dann flackert kurz ein Blaues Bild auf und der Rechner startet neu. Ich 
habe dann die Vista DVD eingelegt, Vista komplett neuinstalliert und 
wieder nach der Installation kackt das Ding immer ab.

Windows Hotline angerufen. Angeblich Hardware defekt.
Ich habe dann die CD mit dem PC-Testprogramm reigelegt. Alle Tests 
angeblich erfolgreich.
Dann habe ich mal Windows XP Pro installiert und siehe da: es läuft.
Seit dem hatte ich keinen einzigen Absturz obwohl der Rechner teileweise 
über 30 Stunden am Stück ein Video reencodet. Bildbearbeitung mit 5GB 
grossen Bildern: kein Problem.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.