mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Kabel


Autor: Dirk Schreiner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe probleme mit dem ISP Kabel. Ich habe im Internet nach 
Programiermöglichkeiten gesucht und habe viele gefunden. Aber alle diese 
Programme haben irgendwie ein anderes Kabel. Ich habe mir die Controller 
Platine bestellt und aufgebaut habe aber bis jetzt noch kein Programm in 
den Controller übertragen können. Vieleicht könnt Ihr mir ja helfen. 
Danke
Dirk

Autor: Guido (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dirk,

welches Board hast Du enn und welchen Adapter benutzt Du? Ich hatte 
anfangs auch Probleme mit dem im Netz angebotenen Adaptern gehabt und 
arbeite jetzt letztendlich mit einem 1:1 durchgeschliffenen Adapter ohne 
den 244, weil mein Board (opticompo) quasi schon einen Buffer 
beinhaltet.

Gruß, Guido

Autor: Siegfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei den ISPs gibt es 2 Brücken, die direkt am Druckerport geschaltet 
werden (die Belegung hab ich gerade nicht zur Hand). Jedenfalls fragt 
die ISP-Software diese Brücken ab, um herauszufinden welche 
ISP-Hardware-Version verwendet wird.

Siegfried

Autor: GuidoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich schätze Du meinst die Brücke zwischen

12 - > 2 und
11 -> 3

oder?

Guido

Autor: Jonas Diemer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
versuchs mit ponyprog (auf lancos.com glaub ich). das funzt mit dem hier 
vorgestellten programmer.

Autor: Siegfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@GuidoF
genau!

Autor: GuidoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ist denn Deine mir jezt unklare Frage damit beantwortet?

Guido

Autor: Ingo B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hier gibt es eine Auflistung der üblichen ISP-Programme und deren 
ISP-Kabelbelegung. Damit dürften alle Fragen beantwortet sein, oder?

http://home1.t-online.de/home/k.leidinger/Microcon...

oder http://www.rc-elektronik.de

Bis dann,
Ingo

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Link funzt nich!

Holger

Autor: Ingo B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

man findet die Tabelle mit allen Belegungen unter 'Meine Links' auf der 
Seite. Framelink ist leider nicht möglich...

Bis dann,
Ingo.

Autor: Stefan_H (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Heißt das ich kann mir bei jedem AVR das Programmiergerät eigentlich 
sparen??

lg,

Stefan

Autor: Ingo B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

das "Programmiergerät" ist nur ein Treiber.

Man kann alle AVRs und auch den AT89S8252 mit einem einfachen Kabel am 
Parallelport programmieren. Allerdings sollte man ein paar 
Serienwiderstände 220R in das Kabel schalten.

Bis dann,
Ingo.

Autor: Stefan_H (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

@Ingo B.: Hab mir mal die von dir obengenannte Seite angeschaut und habe 
folgende Frage:

-Wozu ist der Schalter S1, muss ich den Schließen wenn ich PonyProg 
benutze??


lg,

Stefan

Autor: Toerli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dumme frage aber warum verwendet man einen ISP-Adapter ( 74HC244N
) wenns auch ohne mit einem einfachem stück kabel geht?

Autor: FrankL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weil sich die Wahrscheinlichtkeit erhöht, wenn man kein *244 benutzt, 
das man den parallelen Port leichter aufdampft.

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, ich bevorzuge da doch den ISP-Programmer von Atmel mit nem 
AT90S1200 drin. Der tut, ist mit dem AStudio kompatibel und kostet fast 
nichts. (Und ist ziemlich sicher.)

Bis denn, ERDI - Soft.

Autor: Dirk Schreiner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich möchte mich bei Euch allen für die Beiträge bedanken. Vieleicht kann 
ich euch auch einmal helfen.

Autor: Empir (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich hab' die Verkabelung wie auf http://www.rc-elektronik.de vorgenommen 
(AT90S4433 & PonyProg) jedoch meldet sich PonyProg mit der Fehlermeldung 
"unknown device...-21". Ich hab' auch schon gelesen, dass der reset-pin 
während der Programmierung auf Masse gezogen werden muss. Dies ist bei 
meinen Messungen aber nicht der Fall gewesen. Hat jemand die Schaltung 
ausprobiert oder jemand eine Idee was ich machen kann?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.