mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 und Atmega 8 Problem


Autor: Stefan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

kann mir jemand bei diesem Problem helfen?

Ich weiss gar nicht was ich tun soll! Habe schon alles mögliche 
ausprobiert!

So wie es aussieht programmiert AVR STUDIO ohne Problem mein Flasch, hat 
aber Probleme beim auslesen nach der Programmierung. Warum auch immer. 
Ich habe auch versucht nur Flasch zu programieren über Menü auto, aber 
dannach kommt nichts sinvolles heraus, weil nur 3 LEDs aufleucheten. 
STK500 ist richtig beschaltet, das habe ich schon mehrere male 
nachgeschaut.

Meine Einstellungen sind im zweiten Beitrag in einem Bild dargestellt!

Ist es eigentlich OK wenn Punkt "SPI enabled" gesperrt und mit 
Fragenzeichen ist? Was bedeutet das?

Hielfe dringend.

Gruß Stefan

Autor: Stefan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Einstellungen

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Setze die ISP-Frequens mal etwas höher, so ~57kHz.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe ich gerade gemacht.

Leider der gleiche Fehler!

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe bei Deinem Fragezeichen einen Haken. Versuche den Haken zu 
setzen und neu zu programmieren

oder Verusche bei Advanced die Arbeitsfrequenz einzugeben (Bei mir steht 
da 8Mhz)

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Setze die ISP Frequenz auf 230.4 kHz

Autor: Anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
If the ATmega8 is plugged into the STK500 socket SCKT3200A2 (green)
then use "Ext. Clock; Start-up time: 6 CK + 64 ms".

*

Autor: Stefan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe versucht ein Häckhen zu setzen geht nicht, da diese 
Chexbox gesperrt ist! Warum?

@Anonymous
Habe auch Fuse neu gesetzt! Sieh Anhang! Hast du das gemeint?

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
scheint auch falsch zu sein! auch andere Fuses bei "Ext. Clock; Start-up 
time: 6 CK + 64 ms".

Help!!!!

Autor: Anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
There are only two reliable clock sources when
AVR is plugged into the STK500 socket:

"External clock" or "Internal RC oscillator".

*

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verusche Verify zu drücken, eventuell verschwindet das Fragezeichen...

oder Beende das Programm und starte es neu, vielleicht geht es dann

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Fragezeichen ist bei mir auch, ISP-Freq 28,36kHz
Programmieren geht einwandfrei auch verify.

Autor: Anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
The question mark "?" is normal because the SPIEN Fuse is
not accessible in Serial Programming mode.
You can read or change the fuse bit SPIEN if you use the
parallel High-voltage programming mode. (ATmega8).

Note that if you can read and write the fuse bytes in SPI mode,
then the fuse bit SPIEN is programmed.

Autor: Anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Make sure that while you are programming the ATmega8 there is
nothing connected to the STK500 port header "PORTB".
(PB3, PB4 and PB5 are used for SPI programming).

*

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.