mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik elektronisch kommutierter Motor an PWM


Autor: Andreas R. (moron)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
ich habe hier eine bürstenlose, elektronisch kommutierte 12V 
Umwälzpumpe. Ich möchte sie an eine Spannung von 20V anschließen und sie 
dann mit pwm auf 6-12V laufen lassen. die schaltung ist im anhang.
leider funktioniert es nicht, da, sobald ich einen elko parallel 
schalte, dieser sich auf 20V aufläd. es scheint daran zu liegen, das 
sich der elko schneller auf als entläd. lass ich ihn weg funktionmiert 
die schaltung auch nicht, weil die interne elektronik für die 
kommutierung die pwm-taktung nicht mag. hab 500Hz-20kHz durchprobiert.

frage: ist die schaltung so überhaupt für diese art von motor möglich? 
oder ist schon mein ansatz falsch? hat jem eine möglichst einfache 
lösung oder bereits erfahrung, was sowas angeht?

gruß
andreas

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bau zwischen Motor und Spannungsversorgung eine Spule ein, dann sollte 
es funktionieren.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>elektronisch kommutierte 12V
>Umwälzpumpe. Ich möchte sie an eine Spannung von 20V anschließen

12V Netzteile sind ja auch wirklich schwer zu finden ;)

Autor: Hegy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Außerdem haben solche "intelligente" Motoren oft (immer?) auch eine 
Überspannungsabschaltung drin.

Autor: Andreas R. (moron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@gast: mit einer spule hab ichs bereits probiert, ohne erfolg. 
vielleicht muss ich nochmal mit anderen induktivitätswerten 
rumprobieren.

@holger: danke für den äußerst hilfreichen kommentar.

@hegy: ja, daran kanns liegen, dass der motor bei zu hoher spannung 
abschaltet. ich hatte allerdings gehofft, dass ich mit der obigen 
schaltung und einem genügend großen Kondensator die mittlere spannung 
auf einen maximalen wert 12v runterpulsen und glätten kann.

es wird aber wohl an der schaltung selbst liegen. da die elektronik des 
motors jeweils die vollen 20V-spannungspulse sieht, sobald der fet 
durchschaltet - denn sie ist ja nicht so träge wie eine normale pumpe 
mit bürsten, sondern wird wohl ebenfalls mit einer hohen abtastfrequenz 
arbeiten - schaltet sie ab oder hängt sich auf.

danke und grüße
andreas

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andreas R. (moron)

>Dateianhang: Unbenannt.JPG (27,1 KB, 48 Downloads)

Bildformate (wenn ich für jedes Mal nur einen Euro bekommen würde . 
.  .)

>ich habe hier eine bürstenlose, elektronisch kommutierte 12V
>Umwälzpumpe.

Mit welcher Leistung?

> Ich möchte sie an eine Spannung von 20V anschließen und sie
>dann mit pwm auf 6-12V laufen lassen. die schaltung ist im anhang.
>leider funktioniert es nicht,

Deine Schaltung ist grosser Murks.

>frage: ist die schaltung so überhaupt für diese art von motor möglich?

Nein.

>oder ist schon mein ansatz falsch? hat jem eine möglichst einfache

Ja.

>lösung oder bereits erfahrung, was sowas angeht?

Kommt auf die Leistung an.

1.) Sagen wir mal bis 1 A -> Spannungsregler LM317 mit Kühlkörper, nicht 
perfekt aber geht, muss dannhalt 8W verheizen.

2.) Schaltregler, verheizt wesentlich weniger.

>abschaltet. ich hatte allerdings gehofft, dass ich mit der obigen
>schaltung und einem genügend großen Kondensator die mittlere spannung
>auf einen maximalen wert 12v runterpulsen und glätten kann.

Schau dir mal die Grundlagen von Schaltreglern an und wie da Spule und 
Kondensator angeordnet sind.

MFG
Falk

Autor: Andreas R. (moron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo.
@ falk:
ok, dass ich anscheinend ohne schaltregler nicht auskomme, hab ich dann 
begriffen. spannungsregler kommt wegen der verluste nicht in frage.
die pumpe zieht etwa 1A bei 12V.
dass die schaltung "großer murks" ist bezieht sich aber nur auf 
elektronisch kommutierte motoren, oder? (die spule in der skizze ist 
übrigens nicht die drossel, sondern soll für den motor stehen)
mich würde aber interessieren, warum genau es nicht gehen kann?
ich hatte halt gehofft, dass man durch eine richtige auslegung von einer 
spule in reihe und einem kondensator parallel auch ohne schaltregler 
auskommt. und dass jem. weiß, wie man es auslegt.

das mit den bildern im anhang hab ich dann auch kapiert.

gruß
andreas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.