mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit ADC


Autor: Thomas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab eine Schaltung mit einem ADC und es lässt sich damit nicht 
vernünftig  die Eingangsspannung U messen (z.B. Batterie), weil die 
Werte sehr stark schwanken. Wenn ich den IN- mit GND verbinde 
funktionierts, aber dann hab ich keinen wirklichen Differenzverstärker 
mehr.

Weiß jemand, was ich da falsch mache?

Mfg
Thomas

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der LT1286 sollte LTC1286 heißen ... sorry

Autor: Berti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spontan würd ich sagen das hier kein Bias Strom, fließen kann.
Also zumindest die Masse der batterie über einen Wiederstand an deine 
LTC1286 Masse hängen

Autor: Aufnehmer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nee, Du hast vergessen, VRef zu beschalten (siehe Datenblatt)

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon einmal mit den Kondensatoren wie im Datenblatt Seite16 Bild 8 
probiert. Das würde den Stromfluss ermöglichen.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@berti:
>Spontan würd ich sagen das hier kein Bias Strom, fließen kann.

Interessant ... ich hab danach mal gegoogelt und das könnte mein Problem 
wirklich sein. Ein 1M-Widerstand soll anscheinend reichen ...

@aufnehmer:
>nee, Du hast vergessen, VRef zu beschalten (siehe Datenblatt)
Doch, das ist exakt wie im Datenblatt, aber ich hab den Teil 
weggelassen, weil da sich nicht der Fehler verstecken dürfte

@Hubert.G:
>Schon einmal mit den Kondensatoren wie im Datenblatt Seite16 Bild 8
>probiert. Das würde den Stromfluss ermöglichen.

Wieso das? Kannst du mir das kurz erklären?

Danke schonmal ...

Mfg
Thomas

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Widerstand von -IN nach AGND (220k und 1M getestet) hat leider nicht 
viel gebracht ... Etwas schon, aber leider noch nicht Verwendungsfähig 
:-(

Autor: Christian L. (lorio)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Möglicherweise hast du kein saubere Referenzspannung?
Zeig bitte auch mal deine Beschaltung von VRef.

Gruß
Christian

Autor: Thomas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch die VREF-Erzeugung ... ist aus dem Datenblatt.

Hmm ... irgendwie ist das echt seltsam ... Hat noch jemand Tipps?

Verbinde ich -IN mit AGND hab ich nur "Wackeln" im letzten Bit ... tu 
ich das nicht, wackeln min. 5 Bits

Mfg
Thomas

Autor: Berti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was willst du mehr! +/- 1 LSB is bei 12 bit eh fast nix! Das wackeln is 
dann durchaus legitim. -> das mit dem R auf -IN ist der richtige weg!
5 LSB is schon ne ganze Menge

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Differenzeingang heißt nicht floatend!

Beide Eingänge müssen immer innerhalb Uin- und Uin+ sein.
Bei rail to rail also innerhalb GND..VCC, sonst noch weniger.

Und Differenzeingänge haben natürlich nur ne begrenzte Bandbreite, 50Hz 
Störungen dürften sie unterdrücken, 1MHz wohl nicht mehr.

Und die Biasströme müssen auch abgeleitet werden.

Genaue Angaben stehen im Datenblatt.


Peter

Autor: Berti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: 1LSB = 0,61mV !

Autor: Klaus Falser (kfalser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube, du hast die falsche Vorstellung von einem Differenz-Eingang.
Ein Differenz-Eingang bedeutet nicht, dass die Signale dort beliebig zur 
Versorgungsspannung liegen dürfen.
Du musst dafür sorgen, dass die Signale IN+ und IN- bezogen zu GND 
innerhalb des vorgeschriebenen Bereichs liegen, der im Datenblatt 
angegeben liegen.
Dazu braucht es eine Verbindung zwischen GND und einem Punkt der zu 
messenden Schaltung.
Wenn Du das nicht machst, dann hast Du beliebige Einkopplungen, die 
Differenzspannung ist dann zwar richtig, aber absolut liegen die 
Eingangswerte außerhalb des gültigen Bereichs.

Autor: Christian L. (lorio)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin zwar nicht groß bewandert, aber ich glaube, dass ne Zenerdiode zur 
Erzeugung der Spannungsreferenz nicht so gut ist, da die glaub recht 
stark Rauschen. (Hoff mal es stimmt was ich hier wieder behaupte)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.