mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit virtueller Masse + Oszi


Autor: Hermann P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle!


Ich habe eine ganze simple Schaltung aufgebaut, die im Prinzip aus einer 
Spannungsquelle besteht, an die ein Spannungteiler geschaltet ist. 
Dahinter hängt ein OPV, der als Spannungsfolger geschaltet ist.
Den positiven OPV Eingang kann ich mittels einer zweiten Supply 
variieren.

Wenn ich nun die Mitte des Spannungsteiler als Bezugspotential nehme 
(bei Messung der Ausgangspannung), so erhalte ich wie gewünscht am 
Ausgang zwischen +1 / -1 V (bei 2 Volt Versorgung des OPVs), je nach 
Eingangspegel.

Nun das Problem: Wenn ich die Spannung Ausgang - virtueller Masse mit 
einem Oszilloskop messen will und die Masse Klemme des Tastkopfes an 
meine virtuelle Masse lege, so kann ich keine +/- Spannung messen, 
sondern nur mehr 0 - 2 Volt.

Kann sein, dass mir das Oszilloskop die virtuelle MAsse "verzieht"?!

WIe ist dem Problem beizukommen?


Danke im Voraus!!

Grüße,
Hermann

Autor: tt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Masse deines Scope ist mit PE verbunden !!!!

Autor: Karoly Kovacs (koka55)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das ist das ewige Problem mit den Oszis.

Man muss evtl. ein (echtes!) Trenntrafo verwenden.

Karoly

Autor: yyyy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alter Trick:

Man baut sich ein Netzkabel nur für das Scope, bei dem der Schutzleiter 
nicht angeschlossen ist. Nach dem Messen gleich dieses Kabel wieder 
entfernen.

Nur für Laborbetrieb und nur von und mit Fachleuten geeignet.

Nicht zum Netzspannung messen, das geht zwar auch, da muss man aber mehr 
als Ahnung haben.

Autor: Hermann P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, danke erstmals für die Antworten. Nur das Problem ist definitov 
nicht mit einem Trenntrafo zu beheben, hab ich probiert.

Muss wohl sonst wo eine Masseschleife im Aufbau haben ;-)

Und außerdem, wozu hat ein Tastkopf den "clips" dabei, den man als 
MasseBEZUG verwendet, wenn das Oszilloskop sich sowieso immer auf die 
Betriebsmasse (PE) bezieht?! Diese Aussage versteh ich nicht ^^

Danke!

Mfg,
Hermann

Autor: yyyy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weil zum Beispiel nicht jede Schaltung an Schutzleiterpotential 
angeschlossen ist, z.B. bei einer Batterieversorgung.

Bei hohen Messfreuquenzen gibt es noch weitere Gründe.

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hermann P. wrote:
> OK, danke erstmals für die Antworten. Nur das Problem ist definitov
> nicht mit einem Trenntrafo zu beheben, hab ich probiert.
>
> Muss wohl sonst wo eine Masseschleife im Aufbau haben ;-)
Misst Du nur mit einem Kanal? Wenn Du mit zweien misst, denkst Du 
hoffentlich dran, dass die Tastkopf-Masse-Anschlüsse natürlich auch 
miteinander verbunden sind...

> Und außerdem, wozu hat ein Tastkopf den "clips" dabei, den man als
> MasseBEZUG verwendet, wenn das Oszilloskop sich sowieso immer auf die
> Betriebsmasse (PE) bezieht?! Diese Aussage versteh ich nicht ^^
Zum Messen brauchts immer zwei Potenziale. Und wenn das eine Potenzial 
in der Schaltung sowieso schon auf PE-Potenzial liegt, dann kann man die 
separate Anschlussklemme tatsächlich weglassen (aber auch nur dann). 
Aber in den meisten Fällen hat man eben keine PE-Masse in der zu 
messenden Schaltung, und dann muss man sich eben sein Bezugspotenzial 
schaffen, indem man einen Bezugspunkt in der Schaltung über den 
Außenleiter des Tastkopfes auf PE-Potenzial legt. Dabei muss man eben 
beachten, dass nirgends zu hohe Spannungen auftreten durch die 
Potenzialverschiebung. Wenn man das nicht gewährleisten kann, dann muss 
man mit einem Differentialtastkopf (Trennverstärker) messen, v.a. dann, 
wenn man bei einer mehrkanaligen Messung unterschiedliche 
Bezugspotenziale hat.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.