mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Schaltregler Laststrom


Autor: Gepi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe einen Hochsetzsteller mit einem LM2586 aufgebaut, der Laststrom 
sieht aus wie im Oszi-Bild oben. Wenn ich aber die Spannung (30V) nicht 
vom Hochsetzsteller sondern vom Labornetzteil nehme, dann hab ich hier 
einen relativ schönen Sinus. Hier hat der Sinus aber arge Beulen. Woran 
könnte das denn liegen? Spule? Kondensator.

Meine Bauteile:
Cout   330uF Panasonic FK-Serie
Cin    33uF Panasonic FC-Serie
Spule  220/330/470uH mit max. 1,16/0,95/0,8 A und R = 0,6/0,6/0,79 Ohm

Frequenz Regler: 100kHz
Frequenz Sinus am Ausgang (ideal): 120kHz

Gruß

Gepi

Autor: 1234 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist ja toll. Was ist die skalierung des bildes ? Schema ?

Autor: Gepi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
... hier mit Parametern.

Autor: QAM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey!

Welchen Lastwiderstand verwendest du denn?
Bei einem Hochsetzsteller sollte der Ladestrom Dreieckförmig sein, je 
nachdem ob man gerade in der Lückgrenze ist. Um das richtig zu messen, 
musst du einen Lastwiderstand haben. Optimal wäre so ein Leistungspoti 
so wie aus dem Schulplabor damit du den lückenden und nicht lückenden 
Betrieb siehst.

MfG

QAM

Autor: QAM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sry meinte statt Ladestrom natürlich Laststrom.....

MfG

Autor: Fasti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Du hast am Ausgang eine Last welche den Schaltregler Sinusförmig mit 120 
KILOHertz belastet dein Regler hat aber nur eine Frequenz von 100kHz, 
dann sollte klar sein, woher die Beulen kommen. Der Regler kann ja gar 
nicht schnell genug auf die Belastung reagieren, wei auch wenn er 
langsamer schaltet als die Last.

Grüße

Fasti

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ QAM:
den Ladestrom des Kondensators (Spulenstrom) habe ich mit einer 
Stromzange gemessen, ich bekomme den typischen Verlauf mit einem relativ 
großen Delta I, aber der Strom wird nie Null (mind 50mA über 0A)

@ Fasti
Verzeihung wenn ich jetzt Mist schreibe aber das ist mein erster 
Schaltregler. Aber ich habe mir gedacht,dass Laständerungen vom 
Kondensator abgefangen werden. Ich meine ich habe die Schaltung per 
SMS-Software auf der Seite von National Semi erstellen lassen, die 
Komponenten sind für 500mA Strom am Ausgang ausgelegt. Oder liege ich da 
falsch mit meiner Vermutung. Wenn ja gibts ne Seite auf der das 
ausführlich praktisch erklärt ist? sprut.de und Tietze/Schenk haben mir 
bisher wenig geholfen.

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
noch was zur Last: Ich habe eine Verstärkerschaltung die aus einem 
PWM-Signal von einem Attiny ein Rechtecksignal mit 30V Amplitude (30V 
aus Schaltregler) und 120kHz macht. Dieses Rechtecksignal liegt an einer 
Energieübertragungsspule an.

Autor: 1234 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na, wenn die Last 120kHz ist sollte man das doch irgendwo messen koennen 
... tut man ja. Dh es ist alles IO. Allenfalls koennen die Ausgangs 
Elkos nach dem PWM etwas groesser sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.