mikrocontroller.net

Forum: PC Hard- und Software CRC-Fehler bei Archiven, nur unter Windows nicht unter Linux


Autor: Nils B. (nordlicht_nils)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Leut,

ich komme mit meinem Problem so recht nicht weiter:

Unter Windows XP kommt es beim Entpacken beliebiger Archive aus dem Netz 
(.zip, .rar, .cab) zu CRC-Fehlern. Wenn ich mit der gleichen Hardware 
unter Linux versuche die Archive zu entpacken, gibt es keine Fehler. Und 
das verstehe ich nicht. Was macht Windows beim Entpacken anders?

Was mich auch verwundert hat: Lade ich ein .zip-File nochmal heunter, 
erscheinen die CRC-Fehler beim zweiten Mal bei anderen zu entpackenden 
Dateien als beim ersten Mal... Kann es sein, dass Windows mir beim 
Einlesen über die Netzwerkverbindung Bits verdeht?

Um gleich vorzubeugen: Nein, ich stehle keine Software!

Obwohl ich nicht glaube, dass die Ursache ein Speicherproblem ist, habe 
ich diverse Speichertests durchgeführt. Keine Fehler gefunden.

Ist jemandem von euch das Problem bekannt? Bin für jeden Tipp dankbar. 
Zwar nutze ich Windows eher selten, aber hin und wieder greife ich doch 
nochmal drauf zurück.

Vielen Dank,
der Nils

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Immer die neueste WinRAR-Version benutzen.

Autor: Nils B. (nordlicht_nils)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Nils nochmal,

was ich vergessen habe zu erwähnen, meine Hardware:

Mainboard Asus A8N-E
Prozessor AMD Athlon64 X2 3800+
Speicher Infineon
Win XP letztes SP

Der Rechner wird nicht übertaktet betrieben.

Danke für euer Feedback!

Autor: Nils B. (nordlicht_nils)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans,

danke für den Tipp.

Das Problem tritt aber auch auf, wenn Windows versucht, ein .cab-File zu 
entpacken. Damit ist das Problem wohl unabhängig von der WinRAR-Version.

Gruß, Nils

Autor: Stefan Salewski (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>ich komme mit meinem Problem so recht nicht weiter:

Dein erstes Posting ist nicht sehr klar formuliert.

Ist das Problem das Herunterladen oder das Entpacken?

Beim Herunterladen hatte ich mit Windows auch mal Probleme -- Ursache 
war irgend etwas mit NVIDIA Firewall oder so. Ich kann mich nicht mehr 
genau erinnern, da ich eh fast nur Linux nutze.

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geh mal systematisch auf die Fehlersuche. Du spekulierst auf ein Problem 
der Netzwerkverbindung, dann schliesse das aus und verwende ein 
Ziparchiv von einer Floppy, CD oder Harddisk. Am besten das gleiche 
Ziparchiv, das unter Linux sicher fehlerfrei ist. Oder kopiere das als 
defekt angemosterte Archiv auf ein Medium und teste es wieder unter 
Windows (Harddiskprobleme?) und unter Linux.

Autor: Nils B. (nordlicht_nils)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Stefan S.:
Sorry, wenn's mißverständlich war. Das Problem tritt beim Entpacken auf. 
Die Geschichte mit der Nvidia-Firewall habe ich auch schon im Netz 
gefunden, nur nutze ich so eine Firewall nicht.

@ Stefan B.:
Danke für den Hinweis. Werde mal versuchen, ob ich mit viel geboote eine 
Sytematik erkennen kann.

Danke euch beiden!

Autor: Nils B. (nordlicht_nils)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So Problem gelöst! Vielen Dank für die Anregungen!

Falls jemand wider Erwarten ein ähnliches Problem hat, hier kurz meine 
Lösung:

Ich habe mit Linux das gleiche Archiv heruntergeladen, das mir unter 
Windows Ärger bereitet hatte. Dann Windows gebootet und die mit Linux 
heruntergeladene Datei mit WinRAR entpackt. Das hat ohne Fehler 
geklappt!
Also habe ich den Fehler irgendwo bei Firewall, Virenscanner oder 
Ethernet-Treiber vermutet. Ein bißchen herumprobiert und herausgefunden: 
Mit dem neuesten Nvidia-Treiber für die Ethernet-Karte läuft jetzt 
wieder alles.

Danke.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.