mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 6N136 anschliessen aber wie?


Autor: Willi B. (gcwilli)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich moechte mit einem atmel ueber den 6N136 etwas einschalten koennen.

da ich wenig ahnung von elekronik habe, tue ich mich da sehr schwer.
ich habe versucht, das datenblatt bei reichelt zu interpretieren.

da das auf anhieb nicht klappen wollte, hab ich statt des atmel erstmal
versuchsweise ein batterien genommen.

dabei ist folgendes herrausgekommen:

minus der batterie an pin 3 soll gnd des atmel simulieren.
der pluspol der batterie kommt auf pin 2.

auf der anderen seite hab ich an pin 5 gnd angeschlossen sowie
an pin 8 6 volt als versorgungsspannung.
ich hatte jetzt erwartet, dass bei einschalten der spannung an pin 2 und 
3 eine led zwischen pin 6 und 5 eingeschaltet wird. tatsaechlich klappt
das aber nicht.
ich habe versuchsweise 2 und 3 vertauscht, fuer den fall dass die 
emitter led
anders arbeitet.
aber im zweiten schritt hb ich das nochmal ueberprueft. an pin 7 konnte 
ich 6 volt messen, wenn an pin 2 die spannung anlag. wenn keine spannung 
an pin 2 dann konnte ich auch an 7 nichts messen. so hatte ich mir das 
vorgestellt.
an pin 6 habe ich dann analog -0,4 volt gemessen wenn spannung an 2 
anlag.

also hab ich probeweise die led an pin 7 angeschlossen. jetzt messe ich
dort nur noch 1,5 volt und die led geht auch nicht.

was mache ich falsch?

Willi

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Spannung hat deine Batterie? Vorwiderstanfd der LED? 
Vorwiderstand Optokoppler? Mal mal den Schaltplan auf? Schon mal einen 
einfachen Stromkreis aufgebaut?

Autor: Aufreger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vermutlich hast du deinen 6N136 eh geschossen, denn die LED hält es 
nicht lange ohne Vorwiderstand aus.

Ansonsten ist im Datenblatt doch ein Schaltplan drin, bau den doch 
einfach auf.

Autor: Willi B. (gcwilli)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie ich eingang schon schrieb, bin ich nicht vom fach.

einen schaltplan lesen faellt mir schon schwer. die frage ist, ob ich am 
6N136 alles korrekt angeschlossen habe.

ich habe im moment nur ganz einfach 3 volt per batterie auf der 
eingangsseite die spaeter der atmel machen soll. also an pin 2=plus und 
pin 3=minus.

auf der anderen seite hab ich 6 volt auch per batterie. minus an 5=gnd, 
plus an pin 8 = Vcc = Supply Voltage.

ich bin jetzt davon ausgegangen, dass wenn an pin 2 und 3 spannung 
anliegt=batterie angeschlossen, wird auf 6 oder 7 6 volt rauskommen, an 
die ich meine led bzw spaeter meinen verbraucher anschliessen kann. die 
led haengt mit minus an gnd und mit plus an pin 6 bzw jetzt an pin 7. 
beide funktionieren nicht. der vorwiderstand ist 38 ohm. wenn ich den 
direkt an pin 8 lege bzw jetzt pin 9 und 7 kurzschliesse leuchtet die 
led.

die frage ist nur, ist das so korrekt angeschlossen? und wenn nicht, was 
muss ich aendern.

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Willi,

die Anode der Koppler-LED liegt an "2", die Kathode an "3"
.
Bei 6V würdest Du einen Vorwiderstand von 470 Ohm benötigen.
Also "+" über Vorwiderstand an "2" und "3" an Masse.

Die Fotodiode liegt an "8" - dieser Anschluss gehört an "+"

Der Emitter "4" kommt an Masse und Deine externe LED mit

einem 470 Ohm Vorwiderstand zwischen "5" und "+"

Gruss Otto

Autor: Thilo M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Otto:
Emitter ist "5" und Kollektor ist "6", Pin "7" bleibt frei, "8" an +.

Autor: Willi B. (gcwilli)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jetzt klappt es. zum einen fehlte mir der eingangswiderstand an pin 2.
aber ich hab noch einen zweiten koppler gehabt.
beim anschliessen ist mir dann aufgefallen, dass gnd einen wackelkontakt 
hatte.

jetzt klappt es wie gewuenscht. danke fuer eure hilfe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.