mikrocontroller.net

Forum: PC Hard- und Software Parallelport KArte und Ponyprog


Autor: Ingo St. (scotch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein neuen PC und der hat kein Parallelport mehr.
nun habe ich mir eine PCI IO Karte gekauft und unter Win XP
installiert.
Leider kann ich mit Ponyprog nicht auf den LPT Port zugreifen.
die Schaltflächen zur Auswahl sind invertiert.

Hat jemand einen Tipp für mich.

Gruß Ingo

Autor: Im Grunde genommen... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...hättest du dir den Kauf der Karte nur um dieses olle Ponny zu 
benutzen, sparen können.

Kaufe dir einen AVR ISP USB (-> z. B. Reichelt) und gut ist.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das geht nur mit ISA I/O Karten, bei denen sich der LPT gleich einem 
echten EPP Port jumpern und Register-identisch ansprechen läßt. 
Ansonsten kann ich dem Vorredner nur beipflichten!

Autor: John Small (linux_80)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir läuft auch eine PCI-LPT Karte mit Pony, Bascom und Co.
Man muss nur im Gerätemanager schauen welche IO-Adresse das Ding 
bekommen hat, und das in der Pony-Init-Datei eintragen, aber die 
automatische Suche nach LPT-Ports abstellen, sonst wird bei jedem Start 
die Config überschrieben.

u.a. diese Zeile ändern:
AutoDetectPorts=NO
LPTPorts=378,EC00,3BC
PortNumber=2
Ich hab LPT1 onboard, die Zusatzkarte hat LPT2.

Bei Bascom kann man die IO-Adresse standardmässig schon selber angeben.

Muss aber nicht heissen, das es mit jeder Karte so läuft !
Meine Karte wird nur bis Win2k unterstützt, welches ich auch verwende 
;-)

Autor: Ingo St. (scotch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und danke für die schnellen Antworten.

Ich habe probiert die INI Datei anzupassen, leider ohne Erfolg.
Die Karte werde ich nun wieder zurück geben.

Evtl kaufe ich mir den den USB Adapter, oder ich löte mir einen Stecker
Selber da ich auf dem Mainboard einen Stecker für LPT habe.
Gigabyte verkauft auch ein passendes Kabel mit Slot Blende.
Aber 10.- Euro plus Versand, finde ich doch zu heftig.

Gruß Ingo

Autor: Lance 2010 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tiny 80 schrieb:
> AVR ISP USB

Danke für den Tipp funktioniert einwandfrei. Der Ingo hat wahrscheinlich 
in den INI den Port für LPT1 von 378 nicht auch EC00 geändert.

Autor: Ingo St. (scotch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Lance 2010,
das kann durchaus hinkommen.
Aber das ist ja schon einige Zeit her ;-)
Mittlerweile habe ich mir das ATSTK500 gekauft
Gruß Ingo

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.