mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pollin Evaluations Board nicht erkannt


Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hab nun seit 2 Tagen das Evaluations Board von Pollin, zusammen gebaut 
und angeschlossen. Nur jetzt sagt mir Bascom folgendes: "Could not 
identify chip id:ffffff" & "Selected chip and target chip do not match"

Yaap und Atmel AVR Studio 4 sagen gar nichts(no Board detected) und 
finden kein Board bzw. keinen IC.

Hab zwar einige Themen gefunden allerdings spreche ich kein polnisch und 
andere sind von 2005 und haben kein sichtbares Ende gefunden.

Als Chip hab ich einen AT Mega 8-16PU und es läuft über den com Anschluß 
meines Rechners(naja zumindest soll es das...)

Irgendne Idee ?

Grüße

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat sich erledig??
hast du die Fuse so eingestellt wie in der .pdf Datei von Pollin?

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt einen ATMega16 eingebaut.

Ich hab versucht dieses Testbascomprogramm  zu starten aber er findet 
immernoch keinen Chip und sagt mir: "File: xxx/testtool.bin" not found" 
wenn ich die *.bas Datei mit Bascom übertragen will und dann wieder 
"Could not identify..."

Wenn ich die die Security Bits in ponyprog auslesen möchte kommt immer 
"Device missing or unknown device".

Hab die Lötpunkte alle noch mal überprüft und nachgelötet wenn sie nicht 
100%ig gut aussahen... null Erfolg

Was mir gerade noch aufgefallen ist wenn ich beim "Interface Setup" von 
Ponyprog auf Probe klicke kommt immer "test failed".

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergleich doch mal die Fehlermeldungen wenn garnix angeschlossen ist, 
evtl kommen da die gleichen => Serielle Verbindung klappt schon nicht.

Richtige von den zwei RS232-Buchsen am AVR-Board angeschlossen?
Richtiges Kabel verwendet? (kein Crossover, 1:1 Verbunden, kein billiges 
Drei-Draht-Kabel, IIRC)
Richtige Serielle Schnittstelle in der Software ausgewählt?
Echte Serielle Schnittstelle verwendet, kein USB-Dongle o.ä.?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimmst du auch die richtige Buchse des Boards? (die 9-polige Sub-D mit 
der Beschriftung ISP ist die Richtige)
Eventuell falsches serielles Kabel? (Muss ein Verlängerungskabel sein)

AVR-Studio findet bei mir das Board auch nicht, mit Ponyprog klappt es 
aber.

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh Gott ist mir das peinlich... ich habe tatsächlich den RS232 Anschluß 
genommen und nicht den ISP weil ich dachte das der ISP nur mit nem 
Dongle über den LPT Port funktioniert...

ALso jetzt die andere Buche verwendet und mit PonyProg und der *.hex 
Datei den ATMega16 beschrieben und zum ersten mal leuchtete was :-)

Allerdings habe ich jetzt eine Frage, wenn ich das Programm auf den 
ATMega16 lade dann habe ich bei Taste 1 LED 1 Taste 2 LED 2 und Taste 3 
Summer, jedoch wird der Summer nur für den Bruchteil einer Sekunde 
angesteuert und wenn ich mehrfach auf Taster 1 oder 2 drücke geht 
teilweise alles mit an (Und bleibt auch an bis ich wieder drauf drücke 
also eher wie ein Schalter)...

Gerade dasselbe Spiel nur mit nem ATMega8 und dort funktionieren die 
Taste auch als Taster will sagen solange der Taster gedrückt ist, geht 
die richtige LED/Summer an.

Bascom erkennt den immernoch nicht, ist das richtig ? Wie kann ich ihn 
denn dann programmieren ?

Es tut mir leid, dass ich euch mit so einem Anfängerfehler, den man 
eigentlich schnell hätte umgehen können, belästigt habe.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.