mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fernsehgerätetyp mit RC-5 Code gesucht


Autor: Paul Baumann (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe hier einen Probeaufbau mit Attiny2313 und einem 
Infrarotempfänger
dran, womit ich ein paar Leuchtidioten schalten will. Das funktíoniert 
auch
(meistens), nur manchmal reagieren auch die LED, die gar nicht 
angesprochen worden sind. Das Programm müßte eigentlich gehen, denn ich 
habe das vor langer Zeit schon mal mit einer Originalfernbedienung 
(Leider habe ich die nicht mehr) getestet. Ich habe probeweise einen 
Code für Philips-FS getestet, das ist der Einzige, auf den überhaupt 
reagiert wird.

Frage: Kann mir jemand ein Fernsehgerät nennen, welches mit RC-5 Code 
arbeitet, damit ich meine Universalfernbedienung danach programmieren
kann.

MfG Paul

Autor: Niels Hüsken (monarch35)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der RC5-Code ist eigentlich recht verbreitet. Probier doch einfach mal 
nach dem Zufallspinzip ein paar Codes auf der UniFernbedinung aus. 
Spätestens nach dem zehnten solltest du einen erwischt haben.

Autor: Alex -8bit- (zehvierundsechzig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
z.B. LOEWE Calida M55H und eigentlich sämtliche Philips Fernseher, die 
haben RC5 ja schliesslich vom Stapel gelassen.

Grüße,
Alex

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist ja das Problem: Ich habe schon wie ein "armer Irrer" die ersten 
100
Codes ausprobiert. Nur einer davon geht (meist), aber eben nicht 
immer.

Deswegen wäre es schön zu wissen: Die Geräte der Firma XXXX arbeiten mit
RC-5.

MfG Paul

Autor: sowas da??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sämtlichen philips bis ca bj 2000

Autor: sowas da??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und löwe
und technisat

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
einen CD-Player könnte ich anbieten: CD-304 von Philipps, der hatte 
definitiv RC-5, die FB habe ich noch.

Autor: Niels Hüsken (monarch35)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann wrote:
> Das ist ja das Problem: Ich habe schon wie ein "armer Irrer" die ersten
> 100
> Codes ausprobiert. Nur einer davon geht (meist), aber eben nicht
> immer.

Das hört sich garnicht gut an. Ich würde eher vermuten, das etwas mit 
dem Timing nicht stimmt. Sicher das deine MCU auf stabilen 4Mhz läuft?

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich danke Euch erstmal für die Hilfe und die Ratschläge. Das Signal am 
Empfänger sieht mit dem Oszillographen gar nicht gut aus. Das kann eine
Ursache dafür sein, daß Unsinn interpretiert wird. Ich mache mal einen
Pegelwandler dran und lasse mir das Ergebnis (Adresse, Befehl) über ein
Terminalprogramm auf den Rechner ausgeben. Dann sehe ich ja, ob er schon
"Stuss" empfängt.

MfG Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Niels
Ja, ich habe einen 4Mhz Quarz dran und der schwingt auch. (Oszillograph
getestet)

MfG Paul

Autor: Niels Hüsken (monarch35)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann wrote:
> Ich danke Euch erstmal für die Hilfe und die Ratschläge. Das Signal am
> Empfänger sieht mit dem Oszillographen gar nicht gut aus.

Wenn es sich um ein Standard IR-Empfänger TSOP 17xx handelt, sollte da 
eigentlich einigermaßen gutaussehende Rechtecke rauskommen. Wenn nicht: 
Pullup vieleicht vergessen?

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, Ziehwiderstand ist dran. Ich weiß nicht, was das für ein Typ ist, 
den habe ich irgendwo mal ausgelötet und er ist nicht beschriftet. Auch 
das
Ausschalten des internen Ziehwiderstandes im MC hat keinen Einfluß auf 
die
Sache. Das Signal hat schon einen Hub von fast 5 Volt, aber es sind eher
Sinüsse als Rechtecke, die da herauskommen.

Ich will mal sehen, ob ich noch einen anderen Empfänger habe und den 
mal+
probieren.

MfG Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich weiß nicht, was das für ein Typ ist,den habe ich irgendwo mal >ausgelötet und 
er ist nicht beschriftet

Der Empfänger natürlich, nicht der Widerstand. Der ist 10k.

Schusselig
Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, Fehler gefunden! Die Fernbedienung war schuld. Mit einer anderen
(schnell vom Nachbarn) geliehenen funktioniert es, wie es soll. Die
erzeugt auch prima Rechteckimpulse, an denen man eine Wasserwaage eichen 
könnte. ;-)

Danke nochmal für Eure Hilfen und Hinweise

Erfreut
Paul

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.