mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Butterfly - Probleme beim Verbinden mit PC


Autor: Sebastian ___ (Firma: keine) (s3sebastian)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe heute meinen "Butterfly" erhalten und wollte ihn natürlich 
gleich ausprobieren, ich habe also versucht mit der Anleitung dieser 
Seite hier 
(http://www.mikrocontroller.net/articles/AVR_Butter...) 
eine Verbindung zwischen dem Butterfly und meinem PC herzustellen. 
Leider habe ich keine passenden Kabel, also habe ich ein Nullmodemkabel 
und ein paar Drähte dafür genommen, was aber nicht geklappt hat obwohl 
ich dieses Bray-Terminal wie beschrieben konfiguriert und die Pins IMHO 
auch richtig verbunden habe. Da dies nicht geklappt hat habe ich aus 
einem alten PC-Gehäuse die Kabel für die LEDs vorne herausgebaut, diese 
Lassen sich einzeln direkt in die serielle Schnittstelle des PC 
einstecken, um das ganze noch einmal zu testen. Leider ist wieder nichts 
passiert, der Microcontroller zeigt nur an, dass er auf die Daten 
wartet, der Name wird allerdings nicht gesetzt. Ich habe das 
Terminal-Programm dann noch im Kompatibilitätsmodus zu Windows98 
getestet, da ich dachte, dass es sich evtl. mit Windows XP nicht 
verträgt. Nachdem das allerdings auch nichts geholfen hat habe ich es 
noch an einem anderen PC(Win 2000) der über zwei serielle Schnittstellen 
verfügt probiert, es hat aber auf keiner der beiden geklappt. Ich habe 
auch schon versucht das ganze quasi gespiegelt anzuschließen, da sich 
das ja wenn ich den Wikipedia-Artikel richtig verstanden habe von der 
Pin-Belegung herumdreht je nachdem ob es ein Male- oder Female-Stecker 
ist. Hat jemand vielleicht noch eine Idee, was man probieren könnte?
Danke schon einmal für eure Antworten!

Autor: Sebastian ___ (Firma: keine) (s3sebastian)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe nun mit HyperTerminal zumindest mal irgendetwas übertragen 
können, leider kommt aber nie der gesamte Text an und die Teile die 
ankommen sind zum Teil auch falsch übertragen. :-(
Wenn ich z.B. "sebastian" übertragen möchte kommt nur so etwas wie 
"sebe" an.
Ich kenne mich mit diesen COM-Ports kaum aus, kann mir hier jemand sagen 
an was das vielleicht liegt? Ist die Übertragung stark störungsanfällig 
wenn man einfach ganz normale Käbelchen (Länge etwa 50cm) benutzt? 
Leider kann ich die Übertragungsrate ja nicht langsamer wählen, da der 
Butterfly nur 19200bps erkennt. Ist die Art wie ich Texte übertrage 
überhaupt richtig(ich schreibe mit PSPad eine Textdatei und Sende diese 
dann mit "Send Text File" über HyperTerminal an das Gerät, wenn ich den 
Text mit dem normalen Windows Editor schreibe passiert gar nichts)?
Danke schonmal für eure Antworten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.