mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Lautsprecher an Mega8 rauscht nur noch


Autor: Martin K. (spyro07)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
also ich hatte ja schonmal folgende Schaltung aufgebaut und mit µc 
angesteuert.
http://www.mikrocontroller.net/attachment/29196/sc...

Mir geht es jetzt um den Lautsprecherteil, denn das andere funktioniert.
Nun habe ich mal wieder das Teil angeschlossen und der Lautsprecher 
rauscht  nur noch so komisch. Woran kann das liegen?

mfg

Autor: Komiker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wohl weil komisches Rauschen am Eingang des TDA7056 anliegt...

Autor: Martin K. (spyro07)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, das kann es eigentlich nicht sein, denn der Ton wurde ja schon 
richtig ausgegeben. Habe ja nichts an der Software verändert.

Autor: Martin K. (spyro07)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, nochmal zum Verständnis der Ampfilers:

Am µc wird ja ein Rechtecksignal als Gleichspannung ausgegeben. Der 
Ampfiler macht daraus dann die entsprechende Wechselspannung für den 
Lautsprecher, oder?
Ich habe an den beiden Ausgängen des Ampfilers für den LS aber mal 
nachgemessen und da kam aber auch Gleichspannung raus. Bedeutet das das 
der Ampfiler kaputt ist?

Und noch was: wozu braucht man eigentlich + und - beim LS wenn er mit 
Wechselspannung läuft?

mfg

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Am µc wird ja ein Rechtecksignal als Gleichspannung ausgegeben. Der
> Ampfiler macht daraus dann die entsprechende Wechselspannung für den
> Lautsprecher, oder?
Nein, nein, nein!

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin K. wrote:
> Also, nochmal zum Verständnis der Ampfilers:
>
> Am µc wird ja ein Rechtecksignal als Gleichspannung ausgegeben. Der
> Ampfiler macht daraus dann die entsprechende Wechselspannung für den
> Lautsprecher, oder?

Jein.
Der Amplifier verstärkt das Signal. (Und hoffentlich ist es ihm
egal, dass du einen Gleichspannungsoffset am Signal hast). Ausser
ein bischen Eigenrauschen fügt der Verstärker nichts zu deinem
Signal hinzu. Drum heist der auch Verstärker und nicht Tongenerator.

> Ich habe an den beiden Ausgängen des Ampfilers für den LS aber mal
> nachgemessen und da kam aber auch Gleichspannung raus. Bedeutet das das
> der Ampfiler kaputt ist?

Möglich.

>
> Und noch was: wozu braucht man eigentlich + und - beim LS wenn er mit
> Wechselspannung läuft?

Weil du, wenn du 2 Lautsprecher für einen Steoreobetrieb hast,
diese ganz gerne phasenrichtig anschliessen möchtest.

Autor: Martin K. (spyro07)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also heißt das, dass ich mit dem µc schon diese Wechselspannung erzeugen 
muss. Wenn ich den Port aber ständig ein und ausschalte entsteht ja 
keine Wechselspannung, oder?

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin K. wrote:
> Also heißt das, dass ich mit dem µc schon diese Wechselspannung erzeugen
> muss. Wenn ich den Port aber ständig ein und ausschalte entsteht ja
> keine Wechselspannung, oder?

Es entsteht eine pulsierende Gleichspannung.
Das langt aber.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.