mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit CCS Installation


Autor: Mino (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe ein Problem mit dem CCS Compiler. Ich habe folgende Files 
heruntergeladen:

MPLAB V8.00 -> intalliert -> funktioniert.
demoupd.exe -> installiert.
setup_mplab_plugin.exe -> installiert.

Alle Files sind offiziell von der microchip Homepage. Installiert habe 
ich in der oben genannten Reihenfolge. Die Pfade habe ich der besseren
Übersicht wegen nicht wie vom Programm vorgegeben übernommen. 
(Fehlerquelle?) sondern angepasst.

Habe davor den CC5X Compiler erfolgreich benutzt. Wollte nun ein 
bestehendes C-Programm mal mit dem CCs Compiler umsetzen lassen.
Leider bekomme ich hierbei immer folgende Fehlermeldung:

************************************************************************ 
*
Clean: Deleting intermediary and output files.
Clean Warning: File "C:\Privat hosh\C\Programme\Test CSS Compiler\CSS 
Compiler Test\test1.o" doesn't exist.
Clean: Deleted file "test1.ERR".
Clean: Deleted file "C:\Privat hosh\C\Programme\Test CSS Compiler\CSS 
Compiler Test\neuerCompiler.mcs".
Clean: Done.
Executing: "C:\Privat hosh\C\MPLAB\Third Party\PICC\CCSC.EXE" +FM 
"test1.c" +DF +LN +T +A +M +Z +Y=9 +EA
Error: The selected compiler: "PCM" is not installed on this PC (Was 
soll das ?)
Halting build on first failure as requested.
BUILD FAILED: Mon Feb 11 08:34:16 2008
************************************************************************ 
*

Ist denn der Ansatz prinzipiell richtig ? Ich habe auch gelesen, dass 
man über:
"C:\Privat hosh\C\Compiler\PICC Compiler SW\Pcw.exe"
einsteigen soll.
Nach dem starten komtmt jedoch nach einiger Zeit die Fehlermeldung:
"Registration File Error"
PCM: Can not access internet
...diese Verion benötigt zur Validierung Zugriff auf das Internet.....
.....starten Sie dass Programm neu nachdem eine Verbindung verfügbar 
ist....
(dt. Übersetzung)
Habe jedoch zur selben Zeit das I-Net offen......?

Folgende Einstellungen sind in MPLAB noch vorhanden:
Select Language Toolsuit:  C:\Privat hosh\C\MPLAB\Third 
Party\PICC\CCSC.EXE
Set Language Tool Location:  C:\Privat hosh\C\MPLAB\Third 
Party\PICC\CCSC.EXE

Wo ligt der Fehler

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.