mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Meldung Device missing or uknown device (-24) von Ponyprog


Autor: anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!!

Ich bekomme ein Problemm beim Programmieren von einem ATMega8 mit 
Ponyprog über serielle Schnittstelle. Ich habe ein Board von Pollin und 
habe den µC damit schon programmiert und es ging, jetzt liefert Ponyporg 
mir beim Ausführen von Write Device die Meldung Device Missing or uknown 
device (-24)

Weiß jemand woran das liegen könnte? Hat das mit Fuse-Bits was zu tun?
Ich bin für jede Hilfe dankbar!

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist das zufällig das Funkboard?

Autor: anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein, das ist das andere mit einem Buzzer

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann hast du möglicherweise die Fuses verstellt. Auf Ext. Oszillator. 
Auf XTAL1 einen Takt anlegen, von einem Quarzoszillator(diesen 4Pol. 
Blechdinger) oder sonst so was, es geht auch ein NE555. Dann sollte das 
progen wieder funktionieren.

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: HIlfe für die Fuses gibt es hier 
http://palmavr.sourceforge.net/cgi-bin/fc.cgi

Autor: anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Besten Dank für die Antwort!! Ich habe hier auf der Seite unter AVR 
Fuses schon über die Methode gelesen, wusste nur nicht ob die auch bei 
meinem Fall helfen kann.

Da steht noch:   evtl. ISP-Frequenz anpassen auf <=1/4 XTAL1-Frequenz

Was ist mit ISP-Frequenz gemeint und wie passt man die an?

Autor: anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube ich habe das RSTDISBL-gesetzt  :-(
Sehr traurig. Ich habe eben in Tutorial gelesen, dass in einem solchen 
Fall der µC mit ISP-Programmer nicht mehr angesprochen werden kann. Und 
einen sogenannten HV-Programmer, mit dem es laut Tutorial gehen würde, 
habe ich nicht.

Möchte jemand, der ein HV-Programmer hat, meinen RST-disable'ten µC 
abholen. Verschenke ich gerne!!!

Autor: Kif (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja so ist das mit dem Fuse-Roulette ;) Grad für Anfänger Projekte 
reichen die von Werk gesetzten Fuse doch völlig aus

Autor: Dominik R. (drdontknow)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hatte auch die Fehlermeldung (-24) beim lesen der Fuse-Bits. Nach 
Stunden der Fehlersuche war das serielle Kabel zulang. Doh!

Ich hab etwa 20 cm Flachbandkabel genommen und die D-Sub Buchse bzw. 
Stiftleiste dran gelötet. Jetzt läuft es. Nur leider muss ich jetzt 
immer unter den Tisch kriechen.


Gruß

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.