mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit 74LS123


Autor: Lupin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe mit dem 123 angehängte Schaltung aufgebaut.

Ist abgeändert aus application note: 
http://docweb.khk.be/Luc%20Friant/Digitaal2E/05_mm...

Die Schaltung funktioniert erwartungsgemäß - wenn ich den Eingang nach 
LOW ziehe läuft die Zeit des ersten Monoflops ab und nach Ablauf der 
Zeit löst er den zweiten Monoflop aus der dann eine gewisse Zeit HIGH 
wird am Ausgang.

So weit so gut. Nur habe ich das Problem, dass die Schaltung sobald ich 
Spannung an lege einmal los läuft - was nachvollziehbar ist, denn am 
Input liegt im einschaltmoment ein LOW an (das muss auch so bleiben, da 
ich das Signal vom Input auch nutze um ein Relais an zu ziehen welches 
im Einschaltmoment nicht angezogen sein darf).

Habt ihr vielleicht eine Idee wie ich zB im Einschaltmoment eine weile 
lang die Clear eingänge auf LOW bekomme (so das der erste Ablauf 
ausgeblendet wird) - oder noch irgend eine schönere Idee?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von TTL Monoflops ist bekannt, dass sie aus Reset heraus triggern, d.h. 
wenn Reset inaktiv wird und der Eingang zu diesem Zeitpunkt aktiv ist.

Weshalb das CMOS Monoflop CD4538/74HC4538 gemeinhin als die bessere 
Konstruktion gilt. Kann schon sein, dass dies in diesem Fall hilft.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

früher habe ich dann eben CLR über 3,3k an Ub gehängt und 100n...1µ 
gegen GND.

Problem kann der langsame Anstieg werden, ich weiß nicht, was in Deiner 
Anwendung beim 123 passiert, wenn nicht beide gleichzeitig CLR als H 
erkennen. Eigentlich müßte noch ein Schmitt-Trigger dazwischen, 74LS14 
o.ä.

Gruß aus Berlin
Michael

Autor: Bensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> So weit so gut. Nur habe ich das Problem, dass die Schaltung sobald ich
Spannung an lege einmal los läuft

That's not a bug, that's a feature...

Dann schau dir mal den 74xx423 an, der macht genau das NICHT, ist 
ansonsten identisch im Verhalten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.