mikrocontroller.net

Forum: Compiler & IDEs LCD Initialisieren: Befehle aus Beispielen funktionieren nicht


Autor: F. H. (main)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich hab mir selbst in C ein paar Funktionen zusammengestellt(Im Anhang), 
damit ich mehrere LCD's mit einem µC beschreiben kann. Allerdings hab 
ich Probleme beim Initialisieren eines einzelnen LCD's.
Die Befehle zum Initialisieren sind aus verschiedenen Beispielen 
herauskopiert zum testen, keine Kombination scheint zu funktionieren.
Das LCD(HD44780) funktioniert(mit BASCOM getestet).
Kann mir jemand sagen, was/wieviel ich falsch gemacht habe?

mfg main

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Frajo H. (main)

>Dateianhang: lcd-nicht-funktionierend.rar (6,1 KB, 3 Downloads)

>Kann mir jemand sagen, was/wieviel ich falsch gemacht habe?

Ja. Du hast RAR verwendet, das hab ich nicht und werd ich auch nicht für 
dich installieren. Nutze ZIP oder poste die Files einzeln. Und warum 
kopierst du aus diversen Quelltexten was zusammen? Die Sachen hier im 
Tutorial laufen so wie sie sind.

MFG
Falk

Autor: Hannes Jaeger (pnuebergang)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und statt zusammenkopieren würde sich auch ein Blick in die 
entsprechenden Datenblätter lohnen (Chip, sowie Modul als ganzes). 
Gerade die Datenblätter von billigen Modulen sind sowas von lustig.

Autor: F. H. (main)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ok diesmal als zip. Ich hab mir Befehle aus dem Datenblatt 
zusammengedacht getestet und ein paar Funktionen etwas abgeändert, aber 
das Display wird nicht richtig initialisiert(die erste Zeile ist 
komplett schwarz die zweite komplett leer). Kann es sein, dass meine 
LCD_SendCommand Funktion falsch ist?
Normalerweise sollte (doch) spätestens nach dem LCD_Clear das LCD 
komplett leer sein.(?)

Das LCD hat einen HD44780A Chip drauf, 2 Zeilen mit jeweils 24 Zeichen.

MfG main

Autor: holger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ho, ho. Da lief ja gar nichts ;)
Irgendwie verschwanden die Daten am Port bevor Enable high ging.

Probiers mal mit den Änderungen. Ist auch viel kleiner der erzeugte 
Code!

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ main

Bitte aufpassen ! Ich hab ne andere Pinbelegung in main()

Autor: F. H. (main)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hey danke,

Ich habs zwar schon mal mit Zeigern versucht, aber da hab ich 
wahrscheinlich irgendwo anders noch einen Fehler eingebaut, danke auf 
jeden Fall.
Es funktioniert jetzt wirklich gut, jetzt fehlen nur noch Funktionen wie 
LCD_GotoXY und LCD_Printf aber das zu bauen dauert nicht lang.
Und das beste es passt auf meinen attiny2313.

danke nochmal

MfG main

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.