mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 Erkennung!?


Autor: womisa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Experten,

ich habe ein großes,unerklärliches(?) Problem.

Ich habe ein STK500 an einen PC mit Windows NT angeschlossen und einen
Atmega 16 programmiert. Ich mache eine Ausgabe über die zweite serielle
Schnittstelle un zeige dies mit dem Hyperterminal an.

Belegung:
COM1 Maus
COM2 STK500 Programmierung (RS232 CTRL bzw. RS232 SPARE)

COM2 habe ich im laufenden Betrieb, je nach Bedarf gesteckt !!!

Soweit alles ok. Dies hat über einen längeren Zeitraum ohne Probleme
funktioniert!
Plötzlich wurde das STK500 nicht mehr erkannt.
Aus Verzweiflung, mit der Vermutung STK defekt, habe ich das STK an
COM1 und die Maus an COM2 gehängt.
Wieder alles bestens!!! Ohne Probleme.

Jetzt wird das STK auch an COM1 nicht mehr erkannt.

Die Schnittstellen sind jedoch nicht (völlig?) kaputt, da sowohl die
Maus als auch die Ausgabe meines Programms am Hyperterminal
funktionieren. Nur eben das STK wird nicht erkannt.

Ich habe nun das STK an einen anderen PC mit W2K gehängt.
COM1 STK CTRL
COM2 STK SPARE
da dort eine PS2 Maus ist.
Alles funktioniert wie es soll.
Nur ist die Frage wie lange ????
Kann man beim Umstecken im laufenden Betrieb die COM Schnittstellen
schießen? Ich weiß, eine solche Frage sollte man immer mit ja
beantworten. Jedoch habe ich bisher die ser. Schnittstelle in dieser
Hinsicht als "robust" eingestuft.
Es sieht bei mir so aus, als ob das STK ein
 "COM Schnittstellenfresser" ist.
Spaß bei Seite. Hat jemand eine plausible Erklärung oder einen guten
Rat. Außer unter Spannung sollte man nicht umstecken!
Bin für jeden konstruktiven Beitrag dankbar!

Viele Grüße
Achim

Autor: Frank Linde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Achim,

wenn mich nicht alles täuscht (bin zu faul zum Nachschlagen), dann darf
eine normgerechte RS-232-Verbindung auch unter Spannung getrennt und
gesteckt werden (im Gegensatz zu einer LPT-Schnittstelle). Allerdings
habe ich schon öfter PC-Schnittstellen gesehen, die nicht mal die
geforderten Spannungspegel erreichten, da mag es auch sein, dass sie in
anderer Hinsicht empfindlich sind.

Mein STK-500 stöpsele ich jetzt schon seit Jahren munter im laufenden
Betrieb an und ab, ohne negative Effekte. Hast Du mal gemessen, ob
Deine Massepegel vielleicht unterschiedlich sind? Es kommt vor, dass
man bei aufgetrennten Leitungen zwischen den Massen zweier Geräte
einige zig Volt messen kann, das könnte natürlich auch eine RS-232
himmeln. Ansonsten fällt mir nur noch die Story von der Dame im
Kundenkreis ein, welche ihren Arbeits-PC regelmässig durch statische
Entladungen neu gebootet und gelegentlich auch zerstört hat. Aber ich
vermute mal, als Elektronik-Interessierter hättest Du das wohl gemerkt
und selbst die richtigen Schlüsse gezogen...

Gruß, Frank

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.