mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD auf Platine spinnt


Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Experten,


bin ziemlich neu in der µC Materie und hab folgendes Problem. Mein 24x2 
LCD Display laeuft einwandfrei auf meinem STK 500. Ich hab mir dann eine 
Schaltung auf einem Steckbrett aufgebaut und alles hat auch super 
geklappt. Jetzt hab ich mir eine Platine anfertigen lassen und nun 
spinnt das Display. Die Hintergrundbeleuchtung funktioniert aber es 
werden nur Fragezeichen und sonstige verwirrende Zeichen angezeigt.
Die restlichen Funktionen des µC funktionieren einwandfrei, nur eben das 
Display nicht. Ich hab die Verbindungen schon oefter ueberprueft, aber 
da stimmt alles. Ich weiss einfach nicht mehr, was ich noch ueberpruefen 
koennte. Koennte es sein, dass unterschiedlich lange Datenleitungen(ein 
paar Centimeter) fuer das Problem sorgen.
Vielleicht hat ja jemand schonmal ein aehnliches Problem gehabt und kann 
mir helfen. Ich weiss einfach nicht wo das Problem liegen koennte.
Danke schon mal!!!

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Daniel (Gast)

>koennte. Koennte es sein, dass unterschiedlich lange Datenleitungen(ein
>paar Centimeter) fuer das Problem sorgen.

;-)
Nicht wirklich.

>Vielleicht hat ja jemand schonmal ein aehnliches Problem gehabt und kann

Tausende. Das forum quillt geradezu über von LCD-Fragen.

Die Wartezeiten genau einhalten, ggf. massiv erhöhen, nach JEDER LCD 
Aktion. Gerade bei der Ansteuerung von E.

MFG
Falk

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Falk,
es lag an den delay Zeiten. Jetzt funktionierts super. Woran kann das 
denn liegen. Ich hab doch auf einer Platine noch bessere Verbindungen 
als mit den Kabeln die ich am Steckbrett verwende, oder? Und wo kann ich 
was ueber die Zeiten nachlesen. Oder muss ich da jetzt probieren und 
somit die minimalste Zeit ermitteln.
Danke, super Forum

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Daniel (Gast)

>es lag an den delay Zeiten. Jetzt funktionierts super.

Hallelulia!

> Woran kann das denn liegen.

Hast du den gleichen Takt verwendet wie auf dem STK? AVR Fuses 
richtig gesetzt?

>Und wo kann ich was ueber die Zeiten nachlesen.

Im Datenblatt?

> Oder muss ich da jetzt probieren und somit die minimalste Zeit ermitteln.

Nein! Sowas endet in planloser Murkserei.

MfG
Falk

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal. Ich stehe hier vor einem Raetsel. Bei unterschiedlichen 
Spannungsquellen muss ich eine unterschiedliche delay Zeit einstellen. 
Wie kann das sein. Auch wenn die gleiche Spannung anliegt.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Daniel (Gast)

>Hallo nochmal. Ich stehe hier vor einem Raetsel. Bei unterschiedlichen
>Spannungsquellen muss ich eine unterschiedliche delay Zeit einstellen.

Wie kommst du darauf?

>Wie kann das sein. Auch wenn die gleiche Spannung anliegt.

???

MfG
Falk

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Haste denn beide Spannungsquellen auf gleiches Potential gelegt? D.h., 
Masse mit Masse verbunden?

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meine Platine hat eine gemeinsame Masse. Da ich aber in meiner Werkstatt 
testen moechte und an meinem PC programmiere(steht im Buero), habe ich 
auch zwei Spannungsquellen, die ich jeweils an die Platine anschliesse. 
Ich habe noch einen Spannungsregulator auf der Platine, der mir 
konstante 5V liefert. Daher kann ich mit der Spannungversorgung 
variieren.(zwischen 5 und 20 Volt). Wenn ich nun bei den zwei 
Spannungsquellen 12 Volt einstelle, dann funktioniert das Display bei 
der einen Spannungsquelle und bei der anderen spinnt es wieder rum. Sind 
beides gute hochwertige Spannungsquellen.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Daniel (Gast)

>der einen Spannungsquelle und bei der anderen spinnt es wieder rum. Sind
>beides gute hochwertige Spannungsquellen.

Strombegrenzung zu niedrig eingestellt?

MFG
Falk

Autor: snooze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich habe noch einen Spannungsregulator auf der Platine, der mir
> konstante 5V liefert. Daher kann ich mit der Spannungversorgung
> variieren.(zwischen 5 und 20 Volt)

Ein 5V Linearregler kann aber keine 5V Ausgangsspannung liefern, wenn 
man ihn nur mit 5V speist... Vielleicht liegt es daran ?

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab gerade von einem Kollegen erfahren, dass die eine Spannungsquelle 
des oefteren Probleme macht. Keiner weiss warum. Hab jetzt eine dritte 
benutzt und eine Batterie und es funktioniert jedesmal. Daher hat sich 
das Problem geloest. Danke Falk fuer deine Hilfe!!!
Strombegrenzung war es nicht. Die war hoch genug.
Eine Frage haette ich da noch. Im Datenblatt dieses Moduls steht leider 
nichts von irgendeiner Zeit. Gibt es da allgemeine Datenblaetter die man 
vielleicht auch anwenden koennte. Die Funktionen hab ich von dieser 
Seite. Daher ist es ein Standarddisplay. Dies ist die Produktnummer: 
MC24021A9-SBLW

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Daniel (Gast)

>nichts von irgendeiner Zeit. Gibt es da allgemeine Datenblaetter die man
>vielleicht auch anwenden koennte. Die Funktionen hab ich von dieser
>Seite.

Also wenns ein HD44780 & CO Controller ist, dazu findet man einige 
Datenblätter. Und die Zeiten dazu.

HD44780
http://www.lcd-module.de/

MFG
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.