mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MAX233 - wodurch kann er kaputt sein?


Autor: jdr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich versuche gerade die serielle Kommunikation mit einem ATmega16 (ist 
aber hier nicht relevant) zustande zu bringen, was leider nicht klappt.
Ich benutze einen MAX233 und messe folgende Spannungen gegen Masse an 
den Pins (der AVR ist nicht angeschlossen, nur das serielle Kabel an 
Transceiver 1 und die Spannungsversorgung)

T1IN: 4,5V
T2IN: 4,5V

R1OUT: 4,4V
R1OUT: 4,4V

R1IN: -6,8V
R2IN: 0V

T1OUT: 0,1V (!!!!!!!)
T2OUT: 0,3V (!!!!!!!)

V-: 0,5V (Hier scheint der Knackpunkt zu liegen!)
C2-: 0,1V
C2+: 4,3V
V+: 9,3V
VCC: 4,95V (Spannungsversorgung des MAX scheint also OK zu sein)
C1+: 7,4V
CS-: 0V
(ich glaube die anderen sind nicht so wichtig)

Anscheinend ist das Dingen im Eimer, weil V- ja irgendwo bei -10V liegen 
sollte, aber bei +0,5V liegt, oder sehe ich das falsch?

Wodurch kann das passiert sein, es ist mir nicht bewusst, dass ich 
irgendetwas falsch angeschlossen hätte. Zwischen VCC und GND habe ich 
einen 100nF-Kondensator, aber das spielt ja denke ich keine Rolle.

Wenn ich direkt am seriellen Kabel RxD und TxD verbinde, kriege ich ein 
lokales Echo. Wenn ich hinter dem MAX R1OUT und T1IN verbinde, nicht.

Ich benutze einen USB-Seriell-Konverter, der mit einer anderen Schaltung 
mit MAX232 einigermaßen funktioniert.

Autor: Entwickler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Betreibst Du den MAX233 ohne Kondensatoren (was ja ok ist)?

Wurde der Baustein heiss? Mir sitzt ein Erlebnis mit dem MAX232 im 
Nacken, bei dem ich den Ausgangs-C für +10V gegen Masse statt gegen VCC 
geschaltet. Der Baustein ging wohl in den Latch-Up und hat sich mit dem 
Netzteil angelegt... er hatte verloren.

Autor: jdr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ja, ich betreibe den MAX233 ohne Kondensatoren; deshalb hatte ich ihn 
mir auch trotz des deutlich höheren Preises rausgesucht. Der einzige 
Kondensator ist ein 100nF-Abblockkondensator zwischen Vcc und den beiden 
Massen. Ich kann mich auch nicht entsinnen, dass er heiß geworden 
wäre...sehr komisch alles. Ich habe zum Glück noch zwei Ersatz-233, aber 
es wär ja blöde, wenn die aufgrund irgendeines Fehlers auch kaputt 
gingen.

jdr

Autor: reflection (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich kenne das vom MAX232, den kann man schon rösten wenn man ihn 
ein und aussteckt. Ist ja so viel ich weiss nicht Hotplug fähig. Kenne 
das von Demoboards die wir hier haben, da passiert das auch hin und 
wieder mal wenn man umstöpselt mit Strom drauf

Greets reflection

Autor: pcbfreak (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo  jdr ,

ich hab mir gerade mal das Datenblatt des Max233 von Maxim als Pdf
angeschaut.Einfach "Max233 datasheet pdf" ausgoogeln.
Gehäuse steht auf der 23.Seite.

Den gibt`s als Dip- und So- Gehäuse.Pin`s in Klammern werden wohl für 
So-Gehäuse sein.
Einige Pin`s müssen verbunden werden,andere dagegen unbeschaltet 
bleiben.
Das würde ich erst mal genauestens prüfen.

Vergleich mal deine Schaltung mit dem Datenblatt ob alles stimmig ist.
Dein R1IN dürfte allerdings theoretisch keine Spannung ausgeben weil es 
ein Eingang ist.V- müßte so um die -10V haben.

Den 232 kann man nicht vergleichen auch wenn der zur gleichen Familie
gehört.Da kann ein vertauschter Elektrolytkondensator auch zur
Zerstörung des Chip`s führen.Hier werden aber keine benötigt.

Wenn du hier keinen Fehler findest, haste wohl nur ne taube Nuss 
erwischt.

Gruß Martin

Autor: jdr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe eigentlich alles genauestens geprüft. Ich habe auch einen 
zweiten und dritten MAX233 angeschlossen (nur an Vcc und GND, damit der 
Fehler nicht in der externen Beschaltung liegen kann und weil ich so den 
MAX eigentlich nicht kaputt machen kann...) und ALLE liefern am Pin V- 
0,5 Volt. Ich bin langsam wirklich mit meinem Latein am Ende :(.

Autor: Dieter Werner (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Einige Pin`s müssen verbunden werden,andere dagegen unbeschaltet
>> bleiben.
>> Das würde ich erst mal genauestens prüfen.

Ganz genau, die internen Kondensatoren sind nur an Pins herausgeführt 
und müssen extern verbunden werden.


> ... und dritten MAX233 angeschlossen (nur an Vcc und GND,

Das kann so nicht passen.

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jdr wrote:
> Hallo!
>
> Ja, ich betreibe den MAX233 ohne Kondensatoren; deshalb hatte ich ihn
> mir auch trotz des deutlich höheren Preises rausgesucht.

Alter Schwede... EUR6.10, da kommen die Kondensatoren ein bisschen 
guenstiger ;)

Hast ihn denn richtig angeschlossen? Schaltplan?

Autor: jdr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, auf die Lösung von Dieter Werner bin ich in der Zwischenzeit zum 
Glück auch gekommen, genau daran lag's. Ich hatte tatsächlich einen Teil 
der äußeren Beschaltung im Datenblatt übersehen. Jetzt habe ich an V- 
-9,3V, jetzt werde ich mal den Rest der ICs wieder reinstecken, dann 
SOLLTE es eigentlich gehen :).
Danke!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.