mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Sample and Hold Kondensator mit Portpin entladen


Autor: R--- S--- (rene66)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mega 16 ich möchte gern einen Kondensator 100pF  in einer S&H Schaltung 
mit
einem Portpin entladen.

1. Portpin als Ausgang ausgabe LOW (Kondensator entladen)
2. Portpin auf Eingang ohne Pulup
3. Sampel
4. Hold -> ADC
5. zu 1 zurück

Könnte das so funktionieren?

Hardware ist ein 4053 als schalter und dann ein LM258 auf den ADC des 
mega 16

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich frage mich gerade, wozu das?

Es verlängert nur unnötig die Sample-Zeit, wenn sich die 
Eingangsspannung nur unwesentlich oder garnicht geändert hat.
Der Ladungsausgleich erfolgt über den 4053 und die Quelle, die muß 
ohnehin entsprechend niederohmig sein, damit sie die nötige Samplezeit 
nicht verlängert,

Gruß aus Berlin
Michael

Autor: R--- S--- (rene66)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oder hab ich den 4053 falsch rum angeschlossen.

Eingang auf pin 4 raus auf pin 5 zum C und auf den LM258

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Pin 9,10,11 sind bei mir die Input Select, also doe Logikeingänge für 
die MUX-Steuerung, Pin9 schaltet dabei den MUX C.
Ohne Deine Absichten zu kennen kann ich nur schätzen:
Pin5 ist Y0C, also sozusagen ein Bein des Umschalters, Pin3 ist Y1C, 
also das andere dazu und Pin4 ist ZC, also sozusagen die Mitte.
Es wird also Pin4 mit Pin5 oder Pin3 verbunden, abhängig vom Logikpegel 
an Pin9.

Ein Schaltplan von Deiner Schaltung wäre wohl einfacher.

Gruß aus Berlin
Michael

Autor: R--- S--- (rene66)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier der relevante ausschnitt.
Die gehen auf 4, 14, 15 und raus geht es mit 5, 2, 12 zum LM ausgang vom 
LM
an Port A des Mega 16. C4,5,6 sind nicht angeschlossen. R1 ist 1K, R2 
ist 1,5K

6, 9, 10, 11 sind die Steuerleitungen und gehen zu PortC des 
Controllers.

Das Problem ist das der OPV im Hold immer 3,5 Volt am Ausgang hat die 
überhaut nicht im Verhältniss zum letzten Sampel stehen.
Das es an der Software liegt kann ich ausschließen.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

sieht doch so erstmal ok aus?

Macht nicht, was es soll?

Gruß aus Berlin
Michael

Autor: R--- S--- (rene66)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Machts nicht.

keine Ahnung was das sein kann?

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

was heißt "Machts nicht."???

Mal einen MUX fest eingeschaltet? Testspannung auf den MUX-Eingang 
gelegt?
Am MUX-Ausgang nachgemessen? Am OPV-Ausgang nachgemessen? Wandlerwert 
kontrolliert?
MUX gesperrt und Spannungsverhalten am OPV-Ausgang gemessen oder mit dem 
ADC?

"Machts nucht." ist einfach Quatsch.
Du hast den Kram entwickelt, Du weißt, was Du als Funktion an jedem 
Teilstück erwartest, Du kannst überprüfen, ob das so stattfindet und 
herausfinden, wo es klemmt.
Dann kann man auch über die Ursache und Abhilfe nachdenken.

Gruß aus Berlin
Michael

Autor: R--- S--- (rene66)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,


mux eingeschaltet alles wir von vorn nach hinten so durchgereicht wie es 
sein soll. Dann Mux ausgeschaltet und am Ausgang des LM stehen 3,5 Volt. 
Mir scheint es als ob die LM mit Kapazitäten am Eingang nicht klar 
kommen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.