mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik NE555 astabile Kippstufe, tut nicht was er soll


Autor: Werner Pirkl (mops)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich will einen Oszillator der an einem Pin mit einer Frequenz von ca 
50kHz
Jetzt hab ich mich mal mit ein paar Widerständen, Kondensatoren usw ein 
gedeckt und angefangen die Schaltung wie unter 
http://www.elektronik-kompendium.de/sites/slt/0310131.htm beschrieben 
aufzubauen.

Dabei habe ich verwendet:
2x 150 Ohm Metallschicht (R1 R2)
1x 100 nF  Folien K. (C1)
1x 10 nF   Folien K. (C2)
1x 1N4001  Diode

laut Rechnung sollte an Pin 3 des NE555 eine Frequenz von ~ 48 kHz = 
1/(0.7 * (150 + 150) * 0.0000001) anliegen. Tut es aber nicht. Mein 
Frequenzzähler zeigt eine Frequenz von 10 Herz an :(
Wo liegt da mein Fehler? (ich hab die Schaltung 2x gebaut und beide male 
selbes Ergebnis.

Viele Grüße,
Werner

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mit was misst du denn die frequenz? wenn es nur ein multimeter ist, 
schau doch mal, ob das überhaupt solche frequenzen und/oder amplituden 
kann.
häng doch mal einen dicken C zwischen ne555-ausgang und 
messinstrumenten-eingang.
grüße,
holli

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
am besten schaust du einfach mal ins datenblatt, da ist auch eine solche 
schaltung abgebildet

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nachtrag:
für etwas mehr freundlichkeit für die transistoren: nimm doch 1,5k und 
dafür 10n.
kann mir zwar ned vorstellen, dass es daran liegt, aber der ne555 hats 
trotzdem ein bisschen leichter.
grüße, holli

Autor: JensG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht sind R1/R2 nicht 150Ohm, sondern 150kOhm - meß die mal nach 
(ebenso die C1 . C2 tut hier nichts zur Sache).
Ist auch ein Abblock-C zw. Pin 1 und 8?

Autor: Anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C1=1nF
C2=10nF
R1=15k
R2=15k

Autor: Werner Pirkl (mops)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Huch,

mit so vielen Antworten so schnell hab ich nicht gerechnet...

Die R sind tatsächlich 150 Ohm, Die C sind auch 100 nF und 10 nF +- 2%

Ich baue die Schaltung nochmal mit 1,5k und 10 nF mal sehn obs was tut.

Danke!

Autor: JensG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entschuldigung, daß wir Dich so verschreckt haben ... ;-)

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
^^
und wie siehts mit deinen messmöglichkeiten aus? mit was misst du und 
kannst du das als fehlerquelle ausschließen?
häng doch mal eine led an den ne555. wenn du da was flackern siehst, 
misst du wohl richtig ^^

Autor: JensG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
übrigens sind 150Ohm schon arg klein - wenn Du die Schaltung mit 12V 
betreibst , dann können beim Entladevorgang über Pin 7 schon knapp 100mA 
fließen, und das ist wohl schon knapp am Max. dieses Ausgangs soweit ich 
weiß. Jedenfalls zieht das Ding dann auch ein bißchen Strom - vielleicht 
ist deine Betriebspannung schon etwas zu weich dafür ...

Autor: Werner Pirkl (mops)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H* wrote:
> ^^
> und wie siehts mit deinen messmöglichkeiten aus? mit was misst du und
> kannst du das als fehlerquelle ausschließen?
> häng doch mal eine led an den ne555. wenn du da was flackern siehst,
> misst du wohl richtig ^^

Blinkt eindeutig (LED)

@ Strom, des ganze läuft unter 5V

Autor: Werner Pirkl (mops)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So einen Veruch (ein Kunstwerk ;)) hab ich noch gebastelt... Diesmal mit 
2x 150 Ohm + C1 = 470 nF (Elko) ergibt rechnerisch 10 kHz
Gemessen hab ich ~4kHz
Immerhin inetwa das was ich erwartet habe...
Morgen hab ich mehr Zeit und werd mal mit höheren Widerständen und 
kleineren Kapazitäten testen

Autor: Dida N. (quader)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entweder stimmt was am Aufbau nicht, oder die Messung ist falsch.

Der NE555 liefert nicht solch falsche Werte...

Bist du denn sicher, dass der Messaufbau stimmt? Und ob das Multimeter 
für dieser Messung überhaupt in der Lage ist?
Wurde ja schon angesprochen, aber darauf hast du nicht geantowrtet.

Autor: Werner Pirkl (mops)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mit meinem Multimeter beim 1. Aufbau 10 Herz gemessen. Zum 
Überprüfen dann eine LED mit Vorwiderstand drangeklemmt => blinkt inetwa 
mit 10 Herz... Mein Multimeter sollte bis ca. 50 kHz messen können 
(steht zumindest drauf)

Ich habe den Aufbau etliche Male überprüft. Es ist genau der aus der 
Anleitung.

Ich bin auch ziemlich ratlos :(

Autor: Werner Pirkl (mops)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
seufz jetzt hab ich den Fehler gefunden...

Die Widerstände hatten den falschen Wert... und zwar nen katastrophal 
anderen Wert...

Autor: BAYSAN (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ist auch normal das es nicht geht weil an deiner rechnung brauchst du 
keinen R2 dazu duan weil di DIODE diesen Widerstand kurzschließt 
versuche es mal so vll. kommst dann auf dein ergebniss

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wenn schon Diode, dann keine 1N400x, die sind für alles jenseits 
50Hz Gleichrichtung zu langsam (30µs recovery time).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.