mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 333 kHz Sinus-Schwingung auf meinem Messsignal.


Autor: BioSniper (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- 20 MHz Analog Oszilloskop
- Diodensplittrafo (Sperrwandler) Ansteuerschaltung

- Versorgung der Leistungselektronik über ein Schaltnetzteil 48V, 1,6A
- Versorgung der Steuerelektronik über ein Labornetzgerät
(Keine galvanische Trennung vorhanden)

Ich habe eine DST Ansteuerschaltung gebaut die z. Z. mit 19,2 kHz 
arbeitet (angepeilt sind zukünftig 31,25 kHz), statt des DST habe ich zu 
Testzwecken 5 Stck. Halogenlampen (je 12V, 10W) in Serie an den Ausgang 
gehängt.

Alles läuft eigentlich wunderbar, nur das ich auf meinem Messsignal am 
Oszilloskop eine sinusförmige Schwingung draufhabe: ~333kHz, ~20mV 
Amplitude. Sowohl beim Laden der DST-Primärwicklung, wie auch beim 
Entladen der DST-Primärwicklung.
Egal wo ich messe (48V Stromeingang der Schaltung, 48V-Eingang DST, 
Gate-Anschluß MOS-FET) sind die 333kHz vorhanden.

Ich habe noch eine zweite Steuerschaltung auf der Platine (die soll die 
Energie messen und überwachen die bei jedem Impuls in die 
DST-Primärwicklung fließt und erzeugt ausserdem die Steuerfrequenz via 
UC3844N), die wird aber z. Z. mit einem Labornetzgerät und 24V 
angetrieben, da sind die 333kHz nicht vorhanden. Mit Ausnahme des 
Signalausgangs des UC3844N, da hier eine Verbindung über die FETs zum 
48V Schaltnetzteil besteht.

Während ich das hier schreibe habe ich immer mehr den Verdacht das diese 
parasitäre Störschwingung vom 48V Schaltnetzteil verursacht wird.
Aber sowiet ich weiss arbeiten diese lediglich mit (50-100)kHz

Hat jemand eine Idee dazu?

Und vielleicht noch eine substantiierte Idee wie man diese Störung 
wegfiltern kann, möglichst ohne einen größeren ohmschen Widerstand?

Ich bin eigentlich ein Elektronik-Laie, ich übertreibe daher vielleicht 
etwas mit der Signalqualität.

Danke

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegen 20mV solltest du dir keine grossen Gedanken machen, solangs keine 
hochpräzise Analog-Schaltung werden soll.

Kommen wahrscheinlich vom Schaltnetzteil, oder werden in deine 
Messleitung eingekoppelt.

zum Entstören könntest du eine Drossel in der Zuleitung versuchen.

Autor: SNT-Opfer (als Gast) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Während ich das hier schreibe habe ich immer mehr den Verdacht das diese
>parasitäre Störschwingung vom 48V Schaltnetzteil verursacht wird.
>Aber sowiet ich weiss arbeiten diese lediglich mit (50-100)kHz

-> Oberwellen -> Fourier !

LC-Filer kann es dämpfen, nur sind, wie schon erwähnt, 20mV nicht der 
Rede wert.

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur mal interessehalber, oberwellen von welcher frequenz? soweit ich 
mich erinnern kann ist die grundfrequenz immer tiefer und die oberwelle 
ein vielfaches von dieser...

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Nur mal interessehalber, oberwellen von welcher frequenz? soweit ich
>mich erinnern kann ist die grundfrequenz immer tiefer und die oberwelle
>ein vielfaches von dieser...

Passt doch: Er hat 333 kHz gemessen, das ist die dritte OW von 111 KHz 
(naja, etwas über der Spezifikation) oder die fünfte von 66.6 kHz.
Irgendeine LC-Kombination seiner Schaltung passt auf die 333 kHz, 
manchmal koppelt das auch in den Tastkopf mit einer ungünstig 
angeklemmten Masse direkt ein.  Ein Vergleich mit einem anderen Tastkopf 
(z.B. mit einem Resistive Divider, einfachst nur mit 450 Ohm 
Vorwiderstand, Koaxkabel und 50-Ohm-Scope-Eingang) zeigt dann schnell, 
ob es eine Einkopplung ist oder tatsächlich auf den Leitungen vorhanden.

Autor: Schwurbl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was passiert denn wenn Du alles abschaltest? Immer noch da? Sieht das 
Signal moduliert aus (zappeln)?

333kHz ist zwar weder Langwelle noch Mittelwelle, aber sicherlich nicht 
ungenutzt. Hier in München hab ich regelmäßig 801kHz, Bayern 1...

Autor: BioSniper (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Seitdem ich die 5 Halogenlampen gegen 10 Drahtwiderstände a 17 Watt 
ersetzt habe sind die Störungen verschwunden. Keiner Ahnung weshalb, 
eine Induktivität konnte ich bei den Lampen nicht messen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.