mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit PM428 Panel und Ladungspumpe


Autor: Helmut D. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich möchte die Spannung eines Netzgerätes mittels eines PM428 Panels 
messen. Leider ist die Versorgungspannung nicht galvanisch von der zu 
messenden Spannung getrennt.(voraussetzung zum Betreiben des Panels)

Daher habe ich das Panel an die Ladungspumpe eines Max232 angeschlossen. 
(6V Zener-Diode dazwischen, sodass Versorgungsspannung ca. 10V beträgt 
wie im Datenblatt gefordert).
Das ganze läuft auch soweit, jedoch wird die Spannung falsch gemessen. 
Wenn ich das Panel am 9V-Block betreibe messe ich die korrekten 50mV, an 
der Ladungspumpe betrieben lediglich 16mV obwohl laut Multimeter 
ebenfalls 50mV an den Eingängen anliegen.

Ist die Spannung der Ladungspumpe nicht "galvanisch-genug" getrennt? 
Gibt es  eine funktionierende Alternative zur Ladungspumpe?

Bin für jeden Vorschlag dankbar

Gruß
Helmut

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eine Ladungspumpe ist nicht galvanisch getrennt. Es gibt immer noch den 
gleichen Massebezug. Ladungspumpen dienen dazu, eine Spannung zu erhöhen 
oder zu invertieren. Bei galvanischer Trennung brauchste nen Trafo.

Autor: Hans B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit dem Trafo ist die beste Möglichkeit aber vielleicht geht es auch 
mit einem Optokoppler.Versuch es doch einfach mal,würde mich 
interessieren ob dies gehen würde.

Autor: Helmut D. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe nochmal etwas durchs Forum gestöbert. Die einzige 
möglichkeit eine Gleichspannung in eine galv. getrennte Gleichspannung 
umzuwandeln wäre ein Sperrwandler (Flyback-Prinzip). Für die benötigten 
1mA jedoch zuviel aufwand. Daher werde ich es wohl mit 
7-Segment-Anzeigen und einem ICL7107 machen. Falls dennoch jemand 
konstruktive vorschläge hat, nur her damit.

@ Hans B.: Die Sache mit dem Optokoppler müsstest du etwas genauer 
erläutern. Meines Wissenstandes nach dient er dazu, Signale zwischen 2 
getrennten Stromkreisen zu übertragen. Da ja noch gar keine "2." 
Spannung vorhanden ist, weiß ich nicht wie das gehen soll.

Gruß
Helmut

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.