mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Relais-Steuerung die x-te. Noob brauch Hilfe


Autor: Hendryk (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe das Thema schon in diesem und anderen Foren gefunden. 
Allerdings wird nicht mein konkretes "Problem" behandelt.

In der Anlage befindet sich ein (kleiner) Teil einer Schaltung die ich 
gerne realisieren möchte.

Eigentlich hatte ich mir die Funktionsweise wie folgt vorgestellt 
gehabt:

Nach AN-schalten von S1 leuchtet LED1 (blau) (klappt)
Nach UM-schalten von S2 leuchtet LED2 (grün) und das Relais (12V) zieht 
an (klappt)

Mein Problem ist, dass sowohl der Spannungsregler als auch der 
Transistor innerhalb einer Sekunde EXTREM heiß werden und auch riechen.

Habe ich bei der "Planung" der Schlatung irgendetwas falsch 
dimensioniert? Etwas vergessen? Oder (falls nicht) kann ich beim Ausbau 
der Schaltung was verkehrt gemacht haben? (Anschlüsser der Bauteile 
verwechselt, u.ä.).

Die abgebildete Schaltung ist wie gesagt nur ein Teil der eigentlichen 
Schaltung. Hinter dem Hauptschalter (S1) sollen später jeweils 5 
Schalter (S2-S6) mit LEDs und Relais hängen. Außerdem kommen hinter die 
Schalter S2 bis S4 auch noch IC-Eingänge, weswegen ich die 
Standard-Position der Schalter nicht offen , sondern auf Masse gelegt 
habe, damit die IC-Eingänge dann an Masse liegen.

Ich habe schon vergleichbare Schaltungen gesehen, bei denen wurde der 
Basisstrom am Transistor mit nem Widerstand reduziert. Frage für mich 
als Noob ist jetzt, wie groß sollte dieser Widerstand sein und würde das 
mein Problemchen lösen? ;)

Vielen Dank für eure Tips und sorry für die (wahrscheinlich dämliche) 
Frage. ;)

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hendryk wrote:
> Mein Problem ist, dass sowohl der Spannungsregler als auch der
> Transistor innerhalb einer Sekunde EXTREM heiß werden und auch riechen.

Is auch kein Wunder. Wenn beide Schalter "unten" sind, fließt volle 
Möhre durch Q1 nach Masse ab :-) Bau da mal 1kOhm dazwischen

Autor: Hendryk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven,

danke für die extrem schnelle Antwort. :) Da ich keinen 1k am Lager 
habe, habe ichs mal mit nem 3.3k versucht.

Funktioniert bestens. Kaum Temperaturentwicklung am Transistor. Wenn 
doch alles so einfach wäre. ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.