mikrocontroller.net

Forum: PC Hard- und Software NFS Mountprobleme


Autor: SiO2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe einen NFS-Server, und möchte davon ein Rootfs mounten.

Exportiert habe ich /nfs, wobei /nfs noch ein Verzeichnis root enthält.
Wenn ich den Inhalt des Rootfs nach /nfs/root/ kopiere, kann ich 1 a mit 
meinem Client mounten. Wenn ich das rootfs per "mount -o loop" nach 
/nfs/roo/ mounte, kann ich nicht mounten (log mit wireshark beim Fehler: 
http://rapidshare.com/files/113237552/wirelog.log.html )
Wenn ich das rootfs jedoch nach /nfs mounte, klappt alles. Woran liegt 
das? Der Server wird auch bei jedem Test neu gestartet.

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vorweg: du hast dein /nfs/root verzeichnis schon freigegeben, oder?
Braucht einen eigenen Export-Punkt, weils ein anderes FS auf einem 
anderen Device ist.

Wenn das passt:


Folgende Optionen in /etc/exports wären wahrscheinlich interressant:
      nohide This  option is based on the option of the same name provided in
              IRIX NFS.  Normally, if a server exports two filesystems one  of
              which  is  mounted  on  the  other, then the client will have to
              mount both filesystems explicitly to get access to them.  If  it
              just  mounts  the  parent, it will see an empty directory at the
              place where the other filesystem is mounted.  That filesystem is
              "hidden".

              Setting  the  nohide  option on a filesystem causes it not to be
              hidden, and an appropriately authorised client will be  able  to
              move  from  the  parent  to that filesystem without noticing the
              change.

              However, some NFS clients do not cope well with  this  situation
              as,  for  instance, it is then possible for two files in the one
              apparent filesystem to have the same inode number.

              The nohide option is currently only  effective  on  single  host
              exports.   It  does  not work reliably with netgroup, subnet, or
              wildcard exports.

              This option can be very useful in some situations, but it should
              be used with due care, and only after confirming that the client
              system copes with the situation effectively.

              The option can be explicitly disabled with hide.

       crossmnt
              This option is similar to nohide but it makes  it  possible  for
              clients  to  move  from  the  filesystem marked with crossmnt to
              exported filesystems mounted on it.  Thus when a child  filesys-
              tem  "B" is mounted on a parent "A", setting crossmnt on "A" has
              the same effect as setting "nohide" on B.

ansonsten versuch mal in den export-options für dein 
loopback-gemountetes FS mit anzugeben:

fsid=42

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.