mikrocontroller.net

Forum: Compiler & IDEs Atmega2560 Fusebits ISP zurücksetzten


Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich programmiere mit AVR-Studio-4 und AVR-ISP2-Programmer einen 
Atmega2560,
...lief bis jetzt auch alles ganz gut....
Hab aber ausfersehen die Frequenz bei den Fuses verändert...und danach 
die ISP-Taktrate....

nun läuft gar nichts mehr:
- mc wird nicht mehr erkannt
- und es kommt immer die Fehlermeldung .... 1/4 der Frequenz ....

Wie kann ich den Chip reseten bzw. was muss ich machen, damit er wieder 
läuft?

Tut mir leid, bin leider noch ein Anfänger...

Über Hilfe würde ich mich sehr freuen!

mfg tillt

Autor: ABC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Takt an XTAL1 einspeisen, bspw. so ungefähr 1 MHz.  Je nachdem, was
du halt gerade da hast.

Autor: Uwe ... (uwegw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An XTAL1 einen externen Takt einspeisen.

Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für deine Antwort.

Kann auf meinen Db nicht XTAL1 finden, kann es sein das der Pin einen 
anderen Namen hat?

Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab das atmega 2560(100Pin) von robotikhardware

Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pin 28 - PG3  TOSC2  Uhrenquarz bereits auf Modul ?
Muss ich hier den exterenen Takt einspeisen  und wenn wie?
bin Anfänger...

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pin34 am ATMega

Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab ich auch hier gelesen:
http://www.siphec.com/microcontroller/ATmega1280-1...

Nur hab ich das Model von robotik:
http://www.robotikhardware.de/download/rnmega2560.pdf

...und da gibt es kein XTAL1

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mann! ;-) Auf dem Modul ist doch ein dicker Klotz wo Atmel drauf steht. 
Dort am Pin 34 einen Takt einspeisen... Guck doch selbst mal in den 
Schaltplan vom Modul

Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.... (-: ok ok ok ....
hab aber keinen Quarz zur Hand... gibt es noch eine andere mgl.

gruß tillt

Autor: tillt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Muss ich den internen Q. überbrügen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.