mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Wie 50Hz-Brumm auf 5V eliminieren?


Autor: Johann L. (gjlayde) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi in einem Netzteil möchte ich geregelte 5V= erzeugen, was momentan wie 
folgt aufgebaut ist:

1) Nennspannung 6V~/1.15VA bei 50Hz
2) Brückengleichrichter
3) 5V Festspannungsregler mit primär 1000µF ElKo und sekundär 470µF 
ElKo, BAT42 antiparallel.

So weit, so gut. Die Spannung vor dem Linearregler ist bei ca. 8V eff, 
der Regler hat also genug Luft zum Ausregeln.

Problem ist ein Brumm auf der Sekundärseite. Messtechnisch erfassen kann 
ich den nicht, aber wenn ich von den Effekten zurückrechne komme ich auf 
ne Welligkeit von ca. 150mV ss.
Scheint mir recht viel zu sein für nen Linearregler...

Der Regler ist ein µA7805, hatte es auch schon mit einem LM2940 
versucht, ohne Besserung.

Ist so eine hohe Welligkeit normal? Last ist nur ein µC und ein 
A/D-Wandler, der wegen der Welligkeit nicht so exakt arbeitet wie ich es 
gerne hätte.

Mit größeren Elkos ist praktisch nix auszurichten. Wie realisiert man ne 
genaue Spannungsversorgung, um zB bis auf 10mV Restwelligkeit zu kommen? 
Störend ist nur die Welligkeit, der Absolutwert der Spannung ist 
garnicht mal sooo wichtig.

Wäre hier ein 7806 vor einem Low-Drop wie LM2940 praktikabel?

Johann

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Messtechnisch erfassen kann ich den nicht, aber wenn ich von den Effekten 
>zurückrechne komme ich auf ne Welligkeit von ca. 150mV ss.

Wenn du es nicht messen kannst wie kommst du denn auf die 150mVss ?
Bei einem richtig aufgebauten Netzteil sollte es deutlich weniger als 
die 150mVss sein.

Gruss Helmi

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Woher weisst du das der Brumm 50Hz hat.
Laut Datenblatt soll vor dem Regler ein 0,33µ und nach dem Regler ein 
0,1µ Kondensator (Keramik) sein. Beide so nahe wie möglich am Regler. 
Diese sollen die Schwingneigung unterdrücken.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> BAT42 antiparallel.
Wo und wie sitzen den die?

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich tipp auf ne blitzsaubere 5V-spannung und nen fehler in adc-config 
oder -interpretation =)

Autor: Timbo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stell mal sicher dass Du keine ground loops hast! Das kann auch zu 
mysteriösem, schlecht messbaren, Brummen führen

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johann L. wrote:

> 3) 5V Festspannungsregler mit primär 1000µF ElKo und sekundär 470µF
> ElKo, BAT42 antiparallel.

470µF hinter dem Regler ist Unfug.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1.Wenn die Schaltung richtig sein sollte, kann z.B. auch die räumliche 
Anordnung des Trafos etwas ungünstig sein und Brummeinsteuungen in die 
restliche Schaltung verursachen.

2. ground loops= Masseschleife

Kind regards

Autor: Gast123 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erzeugt deine Schaltung genug Last? 78xx/79xx brauchen eine gewisse 
Mindestlast (waren das 10mA?). Zumindest der 79xx macht ohne Probleme.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gast123 wrote:

> 78xx/79xx brauchen eine gewisse Mindestlast (waren das 10mA?).

Ist mir neu. LM317 ja, aber nicht die 78xx.

Autor: Carsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn der µC ein Atmel sein sollte?

Drossel-Kondensator-Kombi an AVcc?

Autor: Carsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mensch lass uns nicht weiter raten!
Zeig endlich die Schaltung und das Layout der Platine!

Autor: GeraldB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergiß den 7805, bei Belastung wird die Spannung auf ca. 7V sinken. Und 
2V ist für den 7805 Grenzwertig.

Die Elkos brauchen nicht so groß zu sein. 220µF und 10µF sollten 
reichen. Parallel dazu noch jeweils einen 100nF kerko.

Dann kann man evtl. noch ein RC-Glied nachschalten.

Und wegen der Brückengleichrichtung verdoppelt sich die Frequenz auf 
100Hz.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Er hat doch schon mal einen LM2940 versucht.
Aber bis jetzt ist er uns immer noch die Antwort schuldig geblieben wie 
und womit er das Brummen gemessen hat. Und solange er das nicht sagt 
bleibts das hier alles ein Raetselraten.

Gruss Helmi

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wäre hier ein 7806 vor einem Low-Drop wie LM2940 praktikabel?
Allein schon dieser Gedankengang verdient den Titel
           Bastler des Monats                 ;-)

Autor: Johann L. (gjlayde) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, danke erstmal für eure zahlreichen Antworten!

Andreas Kaiser wrote:
> Johann L. wrote:
>
>> 3) 5V Festspannungsregler mit primär 1000µF ElKo und sekundär 470µF
>> ElKo, BAT42 antiparallel.
>
> 470µF hinter dem Regler ist Unfug.

An den 5V hängt ein kleiner AVR. Bei Wegfall der Netzspannung muss ich 
den Atommeiler kontrolliert runterfahren können und brauche daher den 
kleinen Puffer. Die Lösung C-Diode-C scheidet aus, weil ich denn nen 
extra-Port bräuchte zur Spannungsmessung (oder nix gewonnen hätte ausser 
Mehraufwand an Bauteilen).

Verstärkt ein so großer Sekundär-C die Schwingneigung des Reglers? Vom 
Typ ist's ein low-ESR-Elko, Datenblatt speziell zu dem C hab ich aber 
keins.

HildeK wrote:
>> BAT42 antiparallel.
> Wo und wie sitzen den die?

Direkt am Regler. Anode=Vout, Kathode=Vin

Gast123 wrote:
> Erzeugt deine Schaltung genug Last? 78xx/79xx brauchen eine gewisse
> Mindestlast (waren das 10mA?). Zumindest der 79xx macht ohne Probleme.

Last ist ein AVR ATmega168 bei 24 MHz sowie ein ADC TLC7528, Sollte also 
hinkommen.

GeraldB wrote:
> Vergiß den 7805, bei Belastung wird die Spannung auf ca. 7V sinken. Und
> 2V ist für den 7805 Grenzwertig.

hmmm also doch besser ein LM2940 o.ä.? Vom Schwingverhalten ist der aber 
mieser und nicht so einfach einzusetzen wie ein 78xx, oder?

Helmut Lenzen wrote:
> Er hat doch schon mal einen LM2940 versucht.
> Aber bis jetzt ist er uns immer noch die Antwort schuldig geblieben wie
> und womit er das Brummen gemessen hat. Und solange er das nicht sagt
> bleibts das hier alles ein Raetselraten.
>
> Gruss Helmi

An der Anzeige (D7-16) sieht man ein niederfrequentes Wobbeln. Ein 
LM2940 anstatt 7805 verstärkt den Effekt minimal. Entfernen/starkes 
Verkleinern des Eingangskondensators vor dem Regler verstärkt den Effekt 
massiv, weshalb ich davon ausging, daß die 5V-Versorge die Ursache ist.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> An der Anzeige (D7-16) sieht man ein niederfrequentes Wobbeln.
50Hz-Brumm sieht man aber i.A. nicht mehr als niederfrequentes Wobbeln. 
Und bis du an einer LED etwas siehst, muß das Verhältnis schon anders 
aussehen als 5V/150mV.

Halt doch mal ein ordinäres Multimeter im DC-Bereich an die 5V.
Was siehst du?
Und jetzt schalte in den Wechselspannungsbereich.
Was siehst du?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johann L. wrote:

> An den 5V hängt ein kleiner AVR. Bei Wegfall der Netzspannung muss ich
> den Atommeiler kontrolliert runterfahren können und brauche daher den
> kleinen Puffer.

Wenn der 470µF Kondensator direkt hinter dem Regler hängt ist das 
trotzdem sinnlos, denn bei Stromausfall fliesst dann der Strom notfalls 
rückwarts durch den Regler in den Ladeelko vor dem Regler. Somit kannst 
du den Kondensator genauso gut vor den Regler hängen.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich da oben den butterweichen Trafo Nennspannung 6V~/1.15VA lese,
dann würde ich

1.die Spannung nach den Gleichrichter am Elko bei Last messen um zu 
prüfen ob genügend Spannung für den 78xx da ist. Ob die 8V bei Last 
gemessen wurden weiß ich nicht.

2.Über längere Drähte zum Test einen ANDEREN Trafo anderer Bauart 
anschließen. Evtl. kommen auch Einstreuungen über den Trafo. In die 
diesem Fall würden Euch auch keine Eimergroßen Elkos helfen.

3.Interssant wäre noch die Masseleitung

4.Wenn der große Elko vor dem Regler ist, kann er bei Stromausfall 
länger Ladung abgeben, da er durch die höhere Spannung mehr Ladung hat.

5.Notfalls mal bei Statron.de nach einen brauchbaren Netzteil fragen.

Autor: Carsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nana..na  keine Schleichwerbung "St_atron.d_e"

Autor: Johann L. (gjlayde) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, hab mir von nem Kumpel ein Oszi ausgeliehen und ein paar Bilder 
gemacht. Ziemlich in die Jahre gekommen das Teil und mit mehr 
Wackelkontakten als funktionierenden Knöpfen. Naja, besser als nix...

Links
So sieht die Spannung hinter dem V-Regler aus. Wenn ich dem Oszi trauen 
kann, dann ist der Ripple bei ca. 10mVss und 100Hz. Die hochfrequenten 
Spikes machen keine Probleme; sie kommen von Schaltvorgängen des µC und 
die kann ich recht leicht rausfiltern. Belastung ist ca. 30mA, das Bild 
sieht fast gleich aus mit 7805 und LM2940

Mitte
Gleiche Einstellungen, allerdings ist die Reset-Leitung des µC gezogen, 
d.h. in der Schaltung wird nix an/ausgeschaltet. Der Brumm ist was 
kleiner, aber immer noch da. Belastung ist ca. 10mA

Rechts
Die Spannung vor dem V-Reg, sind rund 8V mit einem Ripple von ca 500mV


Leider ist das ein 1-Strahl-Gerät, und ich kann nicht gleichzeitig vor 
und hinter dem V-Reg messen (X/Y-Betrieb geht auch nicht, sonst hätt ich 
V_out als Funktion von V_in gepostet).

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zwischen linken und mittlerem Bild hast du nicht den Messbereich 
umgeschaltet sondern nur die Resetleitung gezogen? Wenn ja, finde ich 
den Unterschied schon erheblich, das "Brummen" wird ja um über 50% 
kleiner...;)

Autor: Johann L. (gjlayde) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael wrote:
> Zwischen linken und mittlerem Bild hast du nicht den Messbereich
> umgeschaltet sondern nur die Resetleitung gezogen?

Korrekt.

> Wenn ja, finde ich
> den Unterschied schon erheblich, das "Brummen" wird ja um über 50%
> kleiner...;)

Direkt neben der 5V-Netzteil sitzen auch Netzteile für 12V und -12V, die 
arbeiten absolut sauber.

Autor: Ekschperde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die Spannung vor dem Linearregler ist bei ca. 8V
Nimm als Spannungsregler einen Low-Drop-Regler.

Oder: Wickel noch ein paar Windungen auf den Trafo und schalte sie
in Reihe zur Sekundärwicklung.

Autor: Johann L. (gjlayde) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ekschperde wrote:
>> Die Spannung vor dem Linearregler ist bei ca. 8V
> Nimm als Spannungsregler einen Low-Drop-Regler.

Einen LM2940 hatte ich wie gesagt angetestet, damit wird es aber nicht 
besser, eher etwas schlechter.

> Oder: Wickel noch ein paar Windungen auf den Trafo und schalte sie
> in Reihe zur Sekundärwicklung.

Ich soll nen vergossenen Trafo aufpickeln????

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also komisch find ich es schon ein wenig. Die Output Voltage Regulation 
liegt beim uA7805 laut Datenblatt von TI zwischen 15 und 100 mV. Da 
liegst du ja gut drin. Auch interessant, dass inzwischen die 
Brummspannung auf ca. ein Zehntel gefallen ist. Am Anfang gingst du ja 
von 150 mV aus. Hast du schonmal andere Kondensatoren ausprobiert? 
Vielleicht ist das Problem da irgendwo zu finden. 1000 uF und 470 uF 
Elkos hatte ich bisher noch nie dran. Zumindest nicht, wenn ich nur 30 
mA benötigt hatte. Da haben immer die Empfehlungen des Herstellers 
genügt.

Autor: Ekschperde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
8 V sind einem 7805 im allgemeinen zu wenig.
Von daher sollte ein Low-Drop besser tun.

> Ich soll nen vergossenen Trafo aufpickeln????
Das ist ja nun Dein Pech. ;-)

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>8 V sind einem 7805 im allgemeinen zu wenig.

8 V sind einem ua7805 (der ist ja hier im Einsatz) im allgemeinen 
ausreichend da der Eingangsspannungen von 7 bis 20 V haben darf laut TI 
Datenblatt

http://focus.ti.com/lit/ds/symlink/ua7805.pdf

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, hab mich vertan, 7 bis 25 Volt sind es, in dem er regelt. Hupsala

Autor: Johann L. (gjlayde) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael wrote:
> Also komisch find ich es schon ein wenig. Die Output Voltage Regulation
> liegt beim uA7805 laut Datenblatt von TI zwischen 15 und 100 mV. Da
> liegst du ja gut drin.

Wenn die Spannung konstant bei 4.9V oder 5.1V ausreguliert wäre, hätt 
ich auch überhaupt kein Problem damit.

> Auch interessant, dass inzwischen die
> Brummspannung auf ca. ein Zehntel gefallen ist. Am Anfang gingst du ja
> von 150 mV aus.

Nicht gefallen. Anfangs konnte ich sie nicht messen und hab einfach vom 
Ablenkkoeffizient der Röhre rückgerechnet auf die V_ref des 
D/A-Wandlers, was wohl nicht korrekt ist.

> Hast du schonmal andere Kondensatoren ausprobiert?

Ja, momentan ist ein 470µF low-ESR ElKo vor dem V-reg. Vergrössern 
dieser Kapazität bringt praktisch keinen Effekt.

> Vielleicht ist das Problem da irgendwo zu finden. 1000 uF und 470 uF
> Elkos hatte ich bisher noch nie dran. Zumindest nicht, wenn ich nur 30
> mA benötigt hatte. Da haben immer die Empfehlungen des Herstellers
> genügt.

Mit kleineren Kondensator werden die Einbrüche noch viel größer, bei 
33µF ist es etwa 1Vss. Was ich nicht verstehe, ist dass auch dann die 
Einbrüche nicht größer werden, wenn ich statt des 2940 ein 7805 nehme.

Autor: Ekschperde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> 8 V sind einem ua7805 (der ist ja hier im Einsatz) im allgemeinen
> ausreichend

Dann sollten es aber bitte 8 V Gleichspannung sein.
Hinter einer gesiebten Graetzbrücke reichen die 8 V halt dann doch 
nicht.

Man könnte natürlich auch den Kondensator grösser dimensionieren.

Mit einem vernünftigen Oszi würde man schon sehen das die
Eingangsspannung am Regler unter 7 V fällt.

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johann L. wrote:
> Ja, momentan ist ein 470µF low-ESR ElKo vor dem V-reg. Vergrössern
low-esr - da könnte dein problem liegen. evtl ist dein elko zu 
niederohmig. versuch doch mal, 1ohm in serie zwischen 7805 und elko zu 
schalten. außerdem ist er generell zu groß.

Autor: Ekschperde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> low-esr - da könnte dein problem liegen. evtl ist dein elko zu
> niederohmig. versuch doch mal, 1ohm in serie zwischen 7805 und elko zu
> schalten. außerdem ist er generell zu groß.

Meine Güte, das ist der Siebelko einer Graetzbrücke.
Seit wann kann der zu groß sein?
Oder zu niederohmig?

Autor: Johann L. (gjlayde) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H* wrote:
> Johann L. wrote:
>> Ja, momentan ist ein 470µF low-ESR ElKo vor dem V-reg. Vergrössern
> low-esr - da könnte dein problem liegen. evtl ist dein elko zu
> niederohmig. versuch doch mal, 1ohm in serie zwischen 7805 und elko zu
> schalten. außerdem ist er generell zu groß.

Nen 1Ω in Reihe mit dem Kondensator bringt auch nix...

Ich werd's wohl anders lösen. Die V_reg hab ich von VCC abgekoppelt via 
4.7Ω + Schottky + 470µ ElKo + 100n KerKo. Ist zwar die brutale Lösung, 
aber damit ist V_reg brauchbar.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich schließe mich nach über einem halbem Jahr den Problem an.

Habe eine Spannungsversorgung +-5V mit 7805 und 7905.
Strom wird ca. auf + Seite 150mA und auf - Seite ca 50mA umgewandelt.

Spannung vor den Reglern ist genug da.

Vor dem Regler sind ca. 2,5mF an Elkos + 100nF SMD Kondensator dicht an 
den Beinen + Kunststofffolienkondensator, der wird ca. 70nF haben.
Hinter dem Regler ist ein 1,5mF Elko + 100nF SMD Kondensator + Tantal, 
dessen Wert ich nicht kenne bzw. nicht im Kopf habe.

Soll nur heißen Kapazitäten habe ich genug. Ist zwar mehr als das 
Datenblatt vorgibt aber schadet nicht.

Problem ist nun, ich habe auf der + sowie auf der - Schiene nen Brummen.
+ Seite sind 12mV
- Seite sind 5mV

Die Frage ist, ob da nen "besserer Regler" her muss oder ob man sich 
behelfen kann.

Ach so die Signale ähneln meinem Vorgänger
http://www.mikrocontroller.net/attachment/39882/oszi-5v.jpg

Kann aber noch Bilder machen wenn das etwas hilft.

Autor: Eddy Current (chrisi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo hast Du denn Deine Masse zum Messen angeschlossen? Möglicherweise 
misst Du den Spannungsabfall mit, den die Strompulse aus dem 
Brückengleichrichter beim Nachladen des Siebelkos erzeugen.

Die Masse muss vom Gleichrichter zum Elko und von da weiter zum Regler. 
Und hier darfst Du Dich zum Messen dranklemmen.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Spannung vor den Reglern ist genug da.

Wie hoch sind die Spannungen?

Autor: M. Köhler (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieder ein Beitrag der Marke:

"Hilfe, mein Datenblatt ist mir beim Rasieren ins Klo gefallen, was 
nun?"

Da ich nicht tauchen gehe hab ich im Internet geschaut, das dürfte hier 
jeder haben. Im Datenblatt zum 7805 steht zum Beispiel die Line 
Regulation von typisch 4mV und maximal 100mV, bei den "größeren" 78er 
(also 7810, 7812 usw.) wird die Line Regulation noch größer. Bei 12mV 
und 5mV liegen die Regler also völlig in den Grenzen gemäß Datenblatt.

Autor: Redegle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hatte den nächstbesten Trafo genommen und ist schon etwas her.
Das müssten 9V AC sein also ca. 11V DC Spitzenspannung hinterm 
Brückengleichrichter.

@ Eddy

Die Spannungversorgung befindet sich auf einer extra Platine.
Gemessen habe ich die Spannung auf der Platine mit meinen anderen 
Bauteilen.

Aber wenn du schon sagst das ich den Spannungsabfall mitmesse, dann 
fällt mir gerade auf das die Brummspannung nicht Sinusförmig verläuft 
sondern Impulsweise.
Oha, ich glaub ich hab nen Fehler in der Masseführung.
Ich mach mal eine Skizze des Aufbaus.

Bild im Anhang.

Sag mir Bitte das unten die Masselinie falsch ist.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Michael Köhler

Ich schrieb.

---------------------------------------------------------------------
Die Frage ist, ob da nen "besserer Regler" her muss oder ob man sich
behelfen kann.
---------------------------------------------------------------------

Btw. das mit dem Datenblatt wurde oben schon einmal erwähnt. Deswegen 
die Frage. Siehe oben.
Aber hab nichs anderes erwartet.



Würde es helfen, wenn ich die Ausgangsspannung des 7805 mit einer Diode 
auf 5,7V erhöhe und einen LP3878 da hinter schalte? Oder erhöhrt das nur 
unnötig das Rauschen?

Kann mir noch wer sagen was der Unterschied zwischen PSRR und Riplle 
Rejection ist?

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Fehler liegt in der Masseführung, würde ich sagen.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So Massefehler behoben zumindest einen sieht so aus als hätte ich noch 
nen 2ten kleinen.
Naja ist runter auf ca. 0,5mV der Impuls.
Muss mal Testen ob das reicht.

Autor: M. Köhler (sylaina)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welchen Sinn hat eigentlich die parallele Schaltung von C6/C10 und 
C5/C11? Ebenso dann noch die später nachgeschalteten C17 und C18? Kann 
man da nicht mehrere Kondensatoren zusammen fassen?

Autor: Lasst mich durch ich bin durch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Blöde Frage, wo würdest Du sonst am einfachsten 2.83033µF herkriegen... 
:-)

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C6/C10 sowie C5/C11
Ich habe zuerst 2 kleine 330µ benutzt. Später wurde ein größerer 
Ergänzt.

C17/C18 sind doch "in Reihe".
Wobei der eine zwischen 5V und 0V und der andere zwischen -5V und 0V 
jeweils am Ausgang der Regler sitzen.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Naja ist runter auf ca. 0,5mV der Impuls.
>Muss mal Testen ob das reicht.

Kannst du mal sagen was das geben soll ?
Für die Digitale Schaltungen ist das schon jenseits von gut und böse.
Auch für die meisten Analogen Schaltung dürfte das ausreichen.

Autor: Redegle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Brauch ne Dreieckspannung.
Mach das mit nem Integrator + Komparator (Standartschaltung).
Die Referenzen liegen bei mir nicht auf GND sondern sind verstellbar.
Dadurch habe ich eine gewisse Abhängigkeit von der Versorgungsspannung.

2 mal Referenz + Versorgungsspannung für Integrator.

Auf alle Fälle wird die Dreieckspannung als Referenz für eine PWM für 
eine H-Brücke gebraucht und die Spannung hinter der H-Brücke hat alle 
10ms nen Satz nach oben gemacht.

Aber ist klar alle 10ms sind die Elkos geladen worden und es gab einen 
Impuls (Flankensteilheit höher als bei 50Hz).

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst ja mal versuchen 2 Regler hintereinander zu schalten. Da 
sollte eine bessere Unterdrückung geben. Auch haben deine OPs schon von 
Hause auch eine Versorgungsspannungs unterdrückung

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Blöde Frage, wo würdest Du sonst am einfachsten 2.83033µF herkriegen...
>:-)

Blöde Frage zurück: Wie kommst du auf nur 2.8...uF? Ich seh da einige 
mF-Kondensatoren drin.

>C6/C10 sowie C5/C11
>Ich habe zuerst 2 kleine 330µ benutzt. Später wurde ein größerer
>Ergänzt.

Ah, das ist also aus der Vergangenheit erwachsen.


>C17/C18 sind doch "in Reihe".
>Wobei der eine zwischen 5V und 0V und der andere zwischen -5V und 0V
>jeweils am Ausgang der Regler sitzen.

Das die in Reihe sind ist mir schon klar, was mich hierbei etwas 
verwirrt: Warum Pufferkondensatoren zerreißen? Auch aus Aufbaugründen? 
Ansonsten hätte ich die ja an den Eingang der Regler gesetzt.

Autor: SNT-Opfer(als Gast) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Grien ...
Redegle ... hatte dir mal den Tipp gegeben mit der Stabilisierung deiner 
Offsetspannung ... dem Integrator ist es ziemlich schnuppe wie +-UB 
rumeiert, solange das Dreieck nicht an die Rails klatscht -> PSRR !

SNT-Opfer

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.