mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Verständnisfrage - 12V mit 5V steuern -> was bewirken 2.2k zw. basis und gnd?


Autor: Axel Krüger (eisman)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen : )

gestern habe ich mich einmal mit NPN Transistoren beschäftigt)

Ich habe an einem BD135 bzw. auch an einem BC328-16 ein ttl-Pegel 
(pwm)an der Basis angelegt mit passenden Basiswiderstand. Am Collector 
habe ich einen PC-Lüfter (0,26A, 12Volt) als Last an 12v geklemmt.
Massepotenzial war gleich.

Sowie ich das Kabel in 12V "steckte", begann der Mikrocontroller zu 
kochen.

Mit 5 Volt und ein paar led am Kollektor hat es funktioniert.

Dann habe ich ein 2.2k Widerstand zwischen Basis und Gnd geschalten(wie 
auf der Abbildung zu sehen 
(http://www.elektronik-kompendium.de/sites/slt/1201131.htm))

Und jetzt funktioniert es einwandfrei..


Jetzt zum Verständnis:

Der Transistor steuert duch wenn an der Basis ca. 0,7 Volt anliegen und 
(in meinem Fall der Atmel) die "TTL" Quelle", der pegel der an der BAsis 
anliegt, in der Lage ist die Strommenge = KollektorEmitterstrom/100 (bei 
zb hfe100) liefern kann.

Das war sowohl bei 12V als auch bei 5 Volt Kollektorspannung gegeben. 
Aber Warum Funktioniert es nur mit dem "R2" bei 12 Volt?

Dient er als Pull Down, damit bei TTL-LOW der Transistor sauber sperrt 
und kein KOllektor-Basisstrom fliessen kann, der den Atmel zum Kochen 
bringt?

Vielen Dank schonmal!

gruss Axel

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>gestern habe ich mich einmal mit NPN Transistoren beschäftigt)

>Ich habe an einem BD135 bzw. auch an einem BC328-16 ...
Der BC328 ist ein PNP und kann in der Schaltung so nicht eingesetzt 
werden.

Wenn der R2 fehlt, sollte es schlimmstenfalls nur dazu führen, dass der 
Transistor nicht ganz sperrt.
Dass dein Prozessor 'kocht' kann auch nicht an einem C-B-Strom liegen, 
der wäre so klein, dass dies nichts ausmacht. Selbst wenn die Basis 12V 
abbekommen würde, dann könnten Richtung Treiber nur einige mA 
zurückfließen.

Hast du denn, wie im Relais-Beispiel, eine Freilaufdiode verwendet?

Wenn du aus den 12V für den Lüfter auch die 5V für den Atmel entnimmst: 
Ist der Spannungsregler gut entkoppelt oder schwingt er möglicherweise, 
angeregt durch die Störspannung des Lüftermotors?

Ist der Effekt derselbe, wenn du statt des Lüfters eine LED im 
12V-Betrieb nimmst?

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Axel,

lies mal diesen Thread.....

Beitrag "Motor an PIC 12F675 mit PWM und PIC glüht."

Gruss Otto

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.