mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Pegelwandler für SPS 0-10 auf 6-18V


Autor: Christoph Steindl (Firma: HTBLA Braunau / Inn) (spstone)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

Mein erster Beitrag hier =)

Habe lange gesucht und hab mir das kompetenteste Forum für mein Anliegen 
ausgesucht. Leider hab ich auch nach langem blättern und suchen im Forum 
nichts wirklich passendes Finden können.

Also, es geht um folgendes: Ich schreibe gerade meine Diplomarbeit für 
meinen Ingeneuer in Mechatronik. Teil meiner Abschlussarbeit ist es, 
einen Sauer Danfoss Proportionalhydraulikschieber per SPS ansteuern zu 
können.

Meine SPS hat am Analog-Ausgang einen Pegel von 0 - 10 Volt.

Der Hydraulikschieber hat am Steuereingang eine Ruhespannung von 12 
Volt. In dieser Position bewegt sich der Schieber nicht.
Der Auslenkpegel beträgt +/- 6 Volt.

d.h. wenn ich 6 Volt anlege fährt der schieber ein, bei 18 Volt fährt er 
aus. (Nur als beispiel)

Jetz bräuchte ich einen Pegelwandler, der es mir ermöglicht im 
Ruhezustand 12V zu erzeugen (SPS Analog out auf 5V) und bei bedarf +-6 
Volt auszulenken
(in der SPS dann also 0 bzw. 10 Volt)

auweia - ganz schön lange Frage =/
Würde mich über alle nützlichen Tipps und Schaltungen Freuen -
vielen Dank im voraus!

Autor: Marc Seiffert (euro)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lässt sich einfach mit opamp lösen:

verstärk die spannung um den faktor 1.2 (erster Opamp) damit erhältst du 
0..12V. und dann addierst du einfach nochmal 6V mit einem zweiten Opamp 
hinzu. Voila 6..18V. eventuell ein paar Trimmer einbauen damits genau 
genug wird.

Autor: Christoph Steindl (Firma: HTBLA Braunau / Inn) (spstone)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DAS ging ja schnell

Hehe opamp... Operationsverstärker.. jaja da hab ich jetz kurz grübeln 
müssen...

OK stimmt. so könnte man das machen! - danke! ich werds mal probiern.

(Soll aber nicht heißen dass ich für andere lösungen unzugänglich bin)

gruß

Autor: Marc Seiffert (euro)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na 15 minuten....das geht auch schneller ^^

wenns nur ne Steuerspannung ist und nicht extremst genau sein muss 
kannst das ganze sogar mit dem guten alten LM258 Lösen, da hast beide 
verstärker direkt in einem. du benötigst natürlich noch eine 
6V-Referenzspannung die du addieren kannst. hier kannst du entweder 
einen Spannungsregler 78L06 nehmen (allerdings recht ungenau) oder dich 
anch nem anderen Bauteil umgucken. wenn du eine genaue 
Versorgungsspannung >6V hast kannst auch nen Spannungsteiler verwenden.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ingeneuer in Mechatronik
Ein Neuer in der Mechatronik ;-)
Das solltest du aber noch ein wenig üben.
Oder mach' doch gleich den Bätscheler.

Zwei Schritte führen zur einfachen Lösung:
1. Aufbohren des 0-10V Signals auf 0-12V
2. Addieren von 6V Offset
Siehe z.B. auch im Beitrag "Re: Operationsverstärker: Spannungen addieren"


Oder das alles in 1 Schritt:
           ___ 10k
0-10V o---|___|-.
                |
        10k___  | |\
      5V -|___|-o-|+\
                  |  >--o----o 6-18V
                .-|-/   |
                | |/   .-.
                |      | |
                |      | | 14k
                |      '-'
                |       |
                '-------o
                        |
                       .-.
                       | |
                       | | 10k
                       '-'
                        |
                       ---
Hier wird der OP-asymetrisch versorgt. Die Ein- und Ausgänge sind weit 
weg von den Gleichtaktgrenzen. D.h. das wird mit jedem OP funktionieren.

Autor: Christoph Steindl (Firma: HTBLA Braunau / Inn) (spstone)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

Tja stimmt die Schaltung nun?

Habe eine Versuchsschaltung mit einem Addierer und nachgeschaltetem 
Verstärker aufgebaut (OPamp TL081CN, welcher 18V Versorgung hat) und bin 
nciht zu dem gewünschten Ergebnis gekommen.

Die von Lothar Miller vorgegebene Schaltung check` ich nicht ganz *sorry

Zahlt`s sichs aus die zu probieren?

grüße

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Soll aber nicht heißen dass ich für andere lösungen unzugänglich bin)

Der besagte Zylinder hat doch sicherlich seitens des Herstellers eine 
Möglichkeit, eine SPS direkt anzuschließen. Es ist doch eher komisch, 
dass ein Steuereingang 12V+/-6V hat. Sowas hat doch gewöhnlich 
"Normal"größen wie 0..10V, 0(4=..20mA.

Frag doch mal ei dem Hersteller nach. Oder soll dieser Wandler der 
"Haken" an der DA sein?


>Die von Lothar Miller vorgegebene Schaltung check` ich nicht ganz *sorry

Die Verstärkung beträgt 2,4 (1+10k/24k). Das zu verstärkende Signal ist 
die SPannung am OPV-Eingang PLUS. Diese ist immer der Mittelwert 
zwischen 5V und der analogen Spannung der SPS:

U_sps    U_plus      U_out
--------------------------------------
0         2,5         6,0
1         3,0         7,2
2         3,5         8,4
3         4,0         9,6
4         4,5        10,8
5         5,0        12,0
6         5,5        13,2
7         6,0        14,4
8         6,5        15,6
9         7,0        16,8
10        7,5        18

>D.h. das wird mit jedem OP funktionieren.
Die Versorgungsspannung sollte nur größer 20V sein.

Autor: Christoph Steindl (Firma: HTBLA Braunau / Inn) (spstone)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die SPS hat tatsächlich einen Steuerausgang von 0 - 10V

und der Aktuator des Hydraulikschiebers hat tatsächlich einen 
Steuereingang von (Ruhestellung) 12V und lässt sich +- 6V Auslenken.

Nein Nein, der Pegelwandler wird lediglich zur Steuerung des 
Hydrauliksystems benötigt.

Autor: Martin Schneider (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider weiß ich nicht, welche Schaltung du nun genau aufgebaut hast und 
was dabei nicht funktioniert -
deiner Beschreibung kann ich nur entnehmen, daß du die Reihenfolge der 
Stufen (Verstärker, Addierer) vertauscht hast...

Mehr Info wäre hilfreich.

Die Schaltung von Lothar ist auf jeden Fall einen Versuch wert...

Ahoi, Martin

Autor: Christoph Steindl (Firma: HTBLA Braunau / Inn) (spstone)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mahlzeit,

Also ich hab die Schaltung von Lothar jetzt mal mit dem TL081CN neu 
aufgebaut und sorgfältig geprüft - allerdings mit 12K statt 14K 
Widerstand.

(Ich denke mal das wird für einen Grundlegenden Funktionstest keine 
Rolle spielen)

ABER die Messung von Ua (6-18V) egab 0. keine änderung.
Echt ziemlich seltsam.

Autor: Martin Schneider (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie ist denn die SPS angeschlossen? Masse auch?

Welche Versorgungsspannung hat der OPV? 0 und 24V wäre z.B. brauchbar?

Sind Schaltungsfehler ausgeschlossen? Ist der OPV evtl. defekt?

Wie erzeugst du die 5V?

Fragen über Fragen...
Mit der Aussage "ich habe die Schaltung aufgebaut" kann man nicht viel 
anfangen. Wie heist es doch so schön: "Gehen Sie davon aus, daß Sie 
grundsätzlich alles falsch gemacht haben. Die merkwürdigen 
Erscheinungén, die Sie messen, sind nur der Versuch Ihres Lötprodukts, 
unter den gegebenen Umständen eine Funktion trotzdem auszuführen..."

Ahoi, Martin

Autor: Christoph Kessler (db1uq) (christoph_kessler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Eine der ältesten Veröffentlichungen von Murphy's law, aus Application 
note 47 von linear.com

Autor: Martin Schneider (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aaah, eine schöne Sammlung!

Ich glaube, ich hatte den Spruch im C-MOS-Kochbuch (Don Lancaster?)
gelesen...

Ahoi, Martin

Autor: Vladimir (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.tyroller.de/
 Dieser Hersteller mach genau das was du brauchst.

Autor: Magnetus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Vladimir (Gast):

Dein Hinweis kommt ein wenig spät, nicht wahr?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon mal auf das Datum des letzten Postings geschaut?

Autor: Waldemar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist nie zu spät. Leute suchen ständig danach, und wenn man was Neues 
entdeckt kann man ruhig posten. Z.B. WAGO 750-563 AO 0/4mA-20mA und 
6-18V.
;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.