mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik NE555 Impuls am Kondensator


Autor: Reuse (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe einen astabilen Multivibrator nach der Standardschlatung mit 
dem NE555 aufgebaut, mit folgenden Bauteilwerten:
beide Rs = 1k
      C  = 1n

Anschließend habe ich mit einem Oszilloskop die Spannung an den Pins 
OUT, DISCH und TRIG/TRESH gemessen. Eigentlich sieht auch alles so aus, 
wie es sein soll. Komisch ist nur der kurze Impuls, bevor der 
Kondensator wieder geladen wird.

Wie man in den Oszillogrammen erkennt, schaltet im Moment des Pulses am 
C OUT von low auf high. Dabei schwingt OUT über und sobald das 
Überschwingen beendet ist, wird C auch wieder normal geladen. Erst jetzt 
springt auch die Spannung an DISCH. Der Impuls ist an DISCH und TRIG gut 
zu erkennen.

Falls das hilft: Habe die Werte der Rs und C variiert auf 10k, 1n. Wie 
zu erwarten war schwingt OUT insgesamt langsamer. Allerdings bleibt die 
länge des Überschwingens an OUT, sowie die des mysteriösen Impulses an 
DISCH unverändert.

Hat jemand eine Idee woher dieser Impuls kommt?

Greetz Reuse

Autor: Reuse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achja hab ich noch vergessen:
Bei der Messung war OUT unbelastet. Aber auch eine ohmsche Last ändert 
nicht viel am Bild.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist es ein Standard-Bipolar-555, also keine CMOS Version (z.b. icm7555, 
TLC555, etc.) den Du einsetzt?

Beim Standard 555 war derartiges Verhalten u.a. durch die nicht perfekte 
Innenschaltung bedingt, könnte also schon die Ursache für Dein 
Meßergebnis sein.

Autor: Reuse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist ein NE555 von Texas Instruments. Im Datenblat steht zu TTL/CMOS nur, 
dass die Ins und Outs TTL-kompatibel sind.

Autor: Hannes Jaeger (pnuebergang)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch mal einen dicken Bypass-Kondensator (10µF oder mehr, parallel 
dazu einen KerKo) über die Stromversorgungs-Pins, direkt an den Pins. 
Der Bipolar-555 genehmigt sich beim Schalten einen ganz kräftigen 
Schluck aus der Strompulle, auch ohne Last.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reuse wrote:
> Ist ein NE555 von Texas Instruments.

Also standard bipolar.

wie Hannes schon schreibt: So mach das.

Autor: Reuse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe jetzt 10µ parallel zu dem eh schon vorhandenen 100nF-Blocker 
gepackt. Das dämpft zwar die Dauer das Überschwingens beim OUT, aber auf 
der Versorgung spiked es nur so rum bei jedem Umschalten. Der Rest der 
"Fehler" bleibt auch da.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dann schließe die Masse der Schaltung auch noch schön kurz mit dem 
Schirm des Oszi-Tastkopfes zusammen. Wenn die Masse irgendwo am Oszi 
angeschlossen wird, haste auch schöne Überschwinger ...

Autor: Winfried J. (Firma: Nisch-Aufzüge) (winne)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nimm mal nen nen nicht gewendeltes R und 3-10µH in die Stromversorgung 
vor dem 10µF Elko

Autor: Reuse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe die Abblockmasche nochmal verkleinert(anderes routing). Die Blocker 
sitzen jetzt nicht nur direkt am VCC-Pin wie vorher, sondern klemmen 
direkt zwischen beiden Pins.

Resultat:
Die Spikes auf der Versorgung sind zwar noch da, aber nur 50mV hoch und 
so kurz, dass sie auf dem Graphen grade noch erkennbar sind. Der 
mysteriöse Impuls am Kondensator ist auch deutlich kleiner geworden von 
>1V auf <100mV. Der Ausgang schwingt allerdings genauso über, aber das 
scheint ja am TTL-Aufbau zu liegen.

Danke für die Tipps. Hätte nie gedacht, dass bei einer 555-Schaltung mit 
ca. 400kHz die Abblockung schon so kompliziert werden könnte.

Autor: Reuse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sooo habe mal ein bisschen mit der Abblockung gespielt und eine 
Experimentreihe erstellt. Dabei bin ich wieder auf für mich noch 
unerklärliche Dinge gestoßen.

Im rar-File ist ein Dokument wo alles drinsteht: Angezeigtes Signal, 
Volt/DIV, und vorallem welche Abblockung benutzt wurde. Ich habe einen 
100nF Kondensator und einen 1µF Kondensator parallel zum IC geschaltet 
und diesen Abblockkreis über eine 100µH Spule mit VCC verbunden. Die 
gemessenen VCCs sind aus Sicht des Netzteils VOR der Spule.

Sehr komisch ist vorallem der Sinus bei einer Abblockung nur mit dem 
100nF K. Die Frequenz entspricht der Ausgangsfrequenz des 555. Wo ist 
denn hier der Resonanzkreis der da angeregt wird.
Außerdem fällt auf, dass der Ausgang ohne Abblockung auf 20V 
überschwingt, obwohl VCC nur 12V ist. Wie geht das ohne Induktivität?

Ich hoffe erfahrene Entwickler können mich aufklären. Im Moment zweifel 
ich ein wenig an meinem Oszilloskop, obwohl das Ergebnis reproduzierbar 
ist.

greetz Reuse

Autor: Reuse (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ahhh Anhang vergessen

Autor: Falk Brunner (falk)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@ Reuse (Gast)

>Im rar-File ist ein Dokument wo alles drinsteht: Angezeigtes Signal,

Besser ZIP als Packer, siehe Bildformate.

>100nF Kondensator und einen 1µF Kondensator parallel zum IC geschaltet

Könnte für den alten bipolaren NE55 zu wenig sein.

Siehe Anhang. WOW! Das ist ja der reinste Kurzschluss. Und sowas hat 
damals ne Freigabe für die Massenprduktion bekommen? Hmm.
Ist aus dem Datenblatt des ICM7555 kopiert, von Philips.

>Sehr komisch ist vorallem der Sinus bei einer Abblockung nur mit dem
>100nF K. Die Frequenz entspricht der Ausgangsfrequenz des 555. Wo ist
>denn hier der Resonanzkreis der da angeregt wird.

Deine Zuleitung, aka Klingeldraht.

>Außerdem fällt auf, dass der Ausgang ohne Abblockung auf 20V
>überschwingt, obwohl VCC nur 12V ist. Wie geht das ohne Induktivität?

dito.

Pack mal zu den 100nF noch 100uF parallel. Dann sollte Ruhe sein. Oder 
gleich auf die CMOS Version wechseln.

MFG
Falk

Autor: Reuse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Deine Zuleitung, aka Klingeldraht.

Mmmmh natürlich sind auf dem Steckbrett dünne Drähte als Zuleitungen 
benutzt worden. Die eigentlichen Zuleitungen sind normale 
Bananenstecker-Leitungen vom Labornetzteil -> linear geregelt.

Diese kurzen Klingeldrahtstücke ham genug Henry für sowas? 
Interressant...

Autor: Felix Bonjour (e-b)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Wie weiter oben schon erwähnt: Wie ist deine Probe Angeschlossen?

Schau dir mal in folgendem PDF:

http://www.linear.com/pc/downloadDocument.do?navId...

Seite 31 an. Dort steht: "schlechter Probe Anschluss". So soll man es 
nicht machen. Ich vermute das entspricht deinem Aufbau.

Auf Seite 34 siehst du, dass der Ground der Probe direkt zum Ground des 
Messobjektes gehört. Ich glaube Jim lötet sein Ground der Probe direkt 
auf die Schaltung. Das Massekabel der Probe verwendet er nicht!
Vie Probes haben auch Dinger (keine Ahnung wie die heissen) beigelget 
die du über die Messspitze schieb kannst um eine gute Ground Verbidung 
zu erhalten.

Apropos Jim, Jim Williams ist kein "Trinker" sonder der "Anaolog Papst" 
von Linear Technology.

Such mal nach weiteren Application Notes von Jim und du kannst viel 
lehrnen.

Mach deine Messungen nochmals korrekt und poste deine Resultate.

Deine Abblock Kondensatoren gehören natürlich genau so nahe an dein 555 
wie möglich.

Cheers,
Felix

Autor: Reuse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Probe hab ich ganz normal mit dem Massekabel an die schaltungsmasse 
beim ic geklemmt. Die Messspitze hängt per Klemmhaken am VCC.

Hier ändert die Entfernung des Messpunkts vom VCC Pin übrigens nix. 
Außerdem sind die Bilder bei teilweise bei 5V/DIV gemacht. Und nicht wie 
im AN bei 500µV.

Autor: Felix Bonjour (e-b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Probe hab ich ganz normal mit dem Massekabel an die schaltungsmasse
>beim ic geklemmt. Die Messspitze hängt per Klemmhaken am VCC.
Was ist schon "normal". Wenn du Probleme wie deine lösen willst vergiss 
den "Klemmhaken" und sorge für induktionsarem Masseverbindungen.
Das gilt natürlich auch für deine Entokpplungs Kondensatoren.

Wie Fakk schon geschrieben hat zählen bie dI/dT die Henrys.

Machs nochmal wie in der AN beschrieben...

Die Vertikale Auflösung (V bzw. uV) hat damit wenig zu tun. Sie zeigt 
dir nur den Effekt deiner Messung besser.

Cheers,
Felix

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.