mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik wieder ein mal: unknown device (-24)


Autor: Thomas W. (webbel)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich muss da mal etwas ausholen.

Vor 10 Tagen wusste ich nicht was ein Microcontroller eigentlich genau 
macht.
Dann ist mir bei einem bekannten Internet-Auktions-Handelsplatz der 
Jäger und Sammler in mir durchgegangen (gelegentlich auch Messi genannt) 
und ich habe ein Posten mit etlichen Platinchen mit je einem AT90S8515 
und einem Pfostenverbinder ersteigert.

Nun habe ich mich etwas eingelesen, mir Ponyprog und einen 
Paralelladapter besorgt, ein Adapterkabel (kurz, nur 20cm) gelötet um 
auf den Pfosten zu kommen. Dabei habe ich Mosi direkt ans Beinchen 
gelötet weil es nicht mit auf dem Pfosten drauf war.
VCC und GND speise ich separat ein.

Ich habe nun mehrere Freiheitsgrade um den Fehler 24 zu erzeugen.
Bevor ich nun die üblichen Verdächtigen Lösungen bemühe benötige ich 
noch ein paar Details:

Takt: so wie das Platinchen aussieht ist der MC mit einem externen Takt 
versehen. Laut Datenblatt ist der MC mit bist zu 8MHz zu versorgen.

Ich habe aber nur Quarzoszillatoren mit >16MHz zu Verfügung... oder 
einen Tongenerator der erlauscht gefühlte 8kHz erzeugt. Irgendwo in 
einem Forum hat als Takt sogar das 1kHz Signal eines Oszi gereicht um 
den MC zu erreichen.. Trotzdem wolle mein Tongenerator nicht mit dem 
Teilchen spielen.

Was empfehlt ihr mir als nächste (Hausmittel) Schritte
gibt es einfache Mittel (totalreset) um den interen Oszi zu aktivieren

Gruss
Thomas

Autor: John Small (linux_80)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

also dieser 10-pol. Stecker ist eine eigene Erfindung, zum programmieren 
sollte der so aussehen:
STK200

Du musst Dir also einen Adapter bauen. (Damit die 10-pol. Stecker 
zusammenpassen)

Der AT90S.. benötigt einen externen Takt, dieser geht auf dieser Platine 
an Pin CLK herraus. Mit 1MHz sollte man schon auf der sicheren Seite 
sein, das es keine Probleme macht.

Autor: Thomas W. (webbel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für deine Antwort,
Den Adapter habe ich mir gebaut aus 2 Pigtails mit Pfostenverbindern.
Also muss erst ein sauberer Takt her. Son Mist - Alles an Geraffel 
fliegt in meinem Kisten Herum, aber kein Oszillator unter 4 MHz.

Gruss
Thomas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.