mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega128 Quarzproblem


Autor: Jogi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo habe mir ein Eigenes Board endlich mal Layoutet
hab ein 16 MHz Quarz verwendet.an xtal 1 und xtal 2 und 2 22p Kerkos
gegen masse geschalten,
Nun die Frage müsste der Quarz doch eigentlich schwingen wenn man auf
das Board Spannung gibt oder mus da noch Software mäßig was vorgenommen
werden?
MFG Jörg

Autor: slaby (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja im Auslieferungszustand sind die Fusebits auf interner RC Oscilator
eingestellt.
Habe das noch nie gemacht , nur davon gelesen.
edi

Autor: Jogi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke mal also schwingt er im auslieferungszustand praktisch nicht?
Danke mal Jörg

Autor: Jogi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat irgendjemand eine Ahnung wie ich die Fuse Bits bei einem Atmega 128
einstellen kann über das Avr Studio oder?
Ich programmiere über das JTAG Interface wenn ich das STK 500 Boaard
angeschlossen habe kann man die Fuse bits problemlos einstellen aber
wenn ich mein eigenes anschliese dann geht dies nicht. Kann mir da
jemand weiterhelfen
MFG Jogi

Autor: Fiffi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jogi,

>Hat irgendjemand eine Ahnung wie ich die Fuse Bits bei einem
>Atmega128 einstellen kann über das Avr Studio oder?

Bei angeschlossenem JTAGICE kannst du die Fuses über das schwarze
AVR-Symbol einstellen (als wenn er auf dem STK501 ist)...

>Ich programmiere über das JTAG Interface wenn ich das STK 500 Boaard
>angeschlossen habe kann man die Fuse bits problemlos einstellen aber
> wenn ich mein eigenes anschliese dann geht dies nicht.

Verwechselst du evtl. JTAG mit ISP ?

Das STK500 kann nur ISP. Für JTAG brauchst du ein JTAGICE ...


Was hast du genau aufgebaut ?


Gruß

Fiffi

Autor: Jogi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir ein eigenes Layout erstellt.
dies habe ich über ein JTAG Interface angeschlossen also genauso wie
ich das STK 500+501 angeschlossen habe dort hatte es fuktioniert über
das Schwarze Symbol usw .
Aber wenn ich jetzt meins anschliese dann kann ich den Atmega128 zwar
programmieren aber ich habe keinen zugriff auf die fuse bits der sucht
irgendwie immer nach dem STK 500 +501 aber wie stelle ich dies den
ab.MFG jogi danke mal

Autor: Jogi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallole ich habe es jetzt raus bekommen um die fuse bits einzustellen
mus der Chip programmiert werden und zwar CKSEL hat jemand damit eine
erfahrung oder ein solches Programm um bei einem Atmega 128 ein
externes 16 MHZ anzusprechen?
Gruss jogi

Autor: Jogi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit der Software von Yaap soll dieses auch gehen.
Weis jemand darüber bescheid geht das auch mit Pony Prog?
MFG Jogi

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.