mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Neue Version von AVR Studio kommuniziert nicht mit JTAG mkII


Autor: Oscar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe hier einen ATMega 644, den ich über die JTAG mkII Schnittstelle 
programmiere. Seit ich die neue Version von AVR Studio (4.16) 
installiert habe (war vorher 4.14), zeigt er mir bei jeder Aktion, die 
eine Kommunikation mit dem Controller erfordert folgende Fehlermeldung 
an:
"Failed to identify target on the JTAG interface.
Has the target been connected to the SPI instead?"
Ein wahrheitsgemäßer Klick auf "Nein", produziert die Fehlermeldung:
"One or more JTAG lines appear to be stuck.
This could be caused by connecting the probe backwards.
Check your connection and try again."
JTAG kann aber gar nicht verkehrt herum verbunden sein.
Ich habe bereits geprüft, dass er wirklich im JTAG mode und nicht im ISP 
mode konfiguriert ist.
An der alten Version funktioniert alles reibungslos, aber es ist 
notwendig, hier die aktuelle Version einzusetzen.

Bin für jede Idee dankbar.

Gruß, Oscar

Autor: Roland (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
hatte hierzu auch einen sonderbaren Effekt, den ich kurz schildern 
möchte.

Nachdem ich auf AVRStudio 4.15 upgedatet hatte wurde mir ein update für 
den JTAG mkII angeboten. Das habe ich gemacht, danach bekomme ich die 
Meldung, dass der Atmega 644P nicht mit der vorhandenen 4.15 Studio 
Version und der JTAG mkII Version unterstützt wird. Als nächstes das 
AVRStudio 4.16 installiert, leider immer noch die gleiche Fehlermeldung.

In der AVRStudio Kompatibilitätsliste für die Unterstützen Tools fehlt 
tatsächlich die Angabe "JD" für den Atmega644P, d.h. dass das JTAG 
debugging des Atmega 644p (und andere) nicht unterstützt wird !

Bis zum Update ging das alles!

Jetzt die gute Nachricht ist, es geht doch!
Aus sicherheitsgründen arbeite ich nur mit eingeschränkten Rechten 
(Hauptbenutzer) unter windows server 2003. Nachdem ich das AVRStudio mit 
Administratorrechten gestartet habe geht alles wieder wie vorher, auch 
das debuggen.

Jetzt bleibt nur noch das schlechte Gefühl wegen der Angaben in der 
Kompatibilitätsliste :-)

Gruß
Roland

Autor: Oscar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem hat sich mittlerweile von selbst gelöst.
Falls jemand über die Suche hergelangt und nach einer Lösung sucht; Ich 
habe vergeblich gesucht und irgendwann gings einfach wieder.
Falls jemand weiß woran das liegt, es würde mich immernoch 
interessieren.

Gruß, Oscar

Autor: Freelancer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann an der spannungsversorgung liegen wackler oder so

was zeigen deine sp werte im avr studio an?

Autor: micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, das ist IMHO ein bekanntes Problem. Google mal nach 
eingeschränkten Rechten und AVR-Studio...

Soweit ich mich erinnere muss man nur einmal mit Admin-Rechten 
arbeiten. Dann werden wohl irgendwo entsprechende Parameter 
(Schnittstellen-Config) für das MKII gesetzt. Danach läuft es auch als 
normaler User.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.