mikrocontroller.net

Forum: Markt Hitex Teletest T51


Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Emulator Hitex Teletest T51 mit Adapter PLCC84 für SAB80C517A.

Braucht man sowas noch?

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

Gegenfrage, was möchtest Du denn dafür haben?

Grüße
Steffen

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keine richtige Preisvorstellung, teuer war die Kiste einst.

Gegenfrage: Was wärs Dir Wert?

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

tut mir leid, den Neupreis kann ich Dir nicht einmal annähernd ersetzen. 
Und um gleich ehrlich zu sein, muss die Kiste ein Schnäppchen sein, 
sonst muss ich von vornherein passen.

Wenn Dich das nicht abschreckt, dann schreib mir doch bitte unter: 
steffen (punkt) hausinger (at) yahoo (punkt) de

Grüße
Steffen

P.s.: Bei ebay wurde neulich einer verkauft, ich hab die Auktion damals 
verpasst. Siehe 
http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItem&item=...

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bisschen mehr solls schon sein, zumal der PLCC84-Adapter dabei wäre.

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

ohne Adapter möchtest Du die Kiste nicht verkaufen?

Mach doch mal eine Ansage zum Preis, vielleicht werden wir uns ja einig.

Grüße
Steffen

Autor: Steffen Hausinger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

ok, offensichtlich liegen unsere Preisvorstellungen deutlich 
auseinander.

Ich selbst besitze übrigens ebenfalls einen Teletest 51, der allerdings 
nicht mehr funktioniert. Deshalb war ich an Deinem Gerät interessiert. 
Aber vielleicht hast Du ja Lust, mir bei der Reparatur meines Emulators 
weiterzuhelfen.

Kannst Du mir den EPROM aus dem Anhang auslesen? Ich suche ganz dringend 
den Inhalt als HEX-File. In meinem steht nämlich nur Datenmüll drinnen 
und ich vermute, dass mein Teletest deshalb nicht funktioniert.

Ich wäre Dir wirklich außerordentlich dankbar. Meine eMail-Adresse steht 
bei Bedarf ja oben.

Grüße
Steffen


P.s.: Vielleicht liest das hier ja auch ein anderer Teletest51 Besitzer, 
dessen Hilfe natürlich ebenso willkommen ist!!

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, ich versuche es mal mit dem EPROM. Bin aber aber erstmal eine Weile 
unterwegs.

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

das ist ganz prima!! Melde Dich, sobald Du ihn auslesen kannst!

Bis dann,
Steffen

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Matthias: Was meinst Du mit "eine Weile"? Hattest Du schon Gelegenheit, 
den EPROM kurz auszulesen?

Grüße
Steffen

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin zur Zeit außerhalb tätig, komme frühestens im Laufe der nächsten 
Woche dazu mir das mal vorzunehmen.

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so. Dann komme ich zu gegebener Zeit auf Dich zurück.

Grüße
Steffen

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

wie schaut's denn aus? Hast Du den EPROM-Dump inzwischen ziehen können?

Grüße
Steffen

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Steffen Hausinger

hast Post

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

vielen Dank für Deine Unterstützung!!

Die Daten in dem erwähnten EPROM haben letztendlich gestimmt. Allerdings 
bin ich dank Dir darauf gekommen, dass die Checksumme des jeweiligen 
EPROMs auf dem Aufkleber steht. Und dabei habe ich festgestellt, dass 
ein ganz anderer Baustein defekt ist. Bei jedem Auslesen ändert sich die 
Checksumme, deshalb nehme ich diesen Baustein als defekt an. Einige Male 
war die Checksumme aber noch korrekt, so dass ich die Daten speichern 
konnte.

Mir fehlt nun nur noch ein Löschgerät, damit ich den Baustein nocheinmal 
neu flashen kann.

Danke nochmals für Deine Hilfe!
Steffen

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist da noch irgendwo ein EPROM? Konnte nur die 2 entdecken. Habe aber 
auch nicht das ganze Sandwitch auseinander genommen.

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, bei mir waren zwei EPROM auf der oberen Platine. Also direkt neben 
dem großen M27C1001 ist bei mir noch ein zweites M27C1001 verbaut. War 
bei Dir da ein leerer Sockel?

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, der 2. Sockel war leer.

Was willste mit dem Emulator eigentlich machen?

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, ja wenn der zweite Sockel leer war, dann bedient der zugehörige 
EPROM wohl eine Zustatzfunktion, die Dein Teletest nicht hat. Ist bei 
Dir die Buchse J5 verbaut, an der die Bondout-Pods angeschlossen werden 
können?

Den Emulator benötige ich zum Reverse Engineering einer alten Steuerung 
(mit einem 80535). Das Programm hat zwar "nur" 16kB, aber ohne Emulator 
komme ich da wirklich nicht weiter. Deshalb hatte ich mir vor etwa vier 
Monaten den Teletest hier aus dem Forum gekauft. Vor drei Wochen ist er 
dann leider schon kaputt gegangen :-( Am Mittwoch hat er noch 
einwandfrei funktioniert, am Donnerstag brach er beim Selbsttest einfach 
ab - obwohl ich den Aufbau nicht einmal berührt hatte.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Fehlersuche in diesem vor 20 Jahren typischen Schaltkreisgrab stelle 
ich mir nicht gerade leicht vor. Nach J5 kann ich erst im Laufe der 
nächsten Woche sehen.

Autor: Steffen Hausinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,

da hast Du Recht. Ich habe jetzt vier Wochenenden daran verballert, ohne 
weiterzukommen.

Was möchtest Du denn nun für Deine Kiste haben? Nenn' ruhig mal einen 
Preis, meinetwegen auch per Mail.

Grüße
Steffen

Autor: Peter Skoda (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Steffen,
ich zufällig den Beitrag gelesen. Im Keller hatte ich noch´n Hitex 
Teletest 51 mit Probe für, schätze mal, 80535 ohne Handbuch und 
Software. Wenn noch Bedarf besteht. Für´n Appel und ein Ei in etwa würde 
ich mich davon trennen.

Gruß
Peter

Autor: Joerg L. (Firma: 100nF 0603 X7R) (joergl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hätte das Ding gerne. Wie kann man Dich erreichen, Du bist hier 
nicht angemeldet?
Jörg

Autor: Markus B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir fällt grad, ich hätte auch noch 2 dieser Emulatoren rumstehen.
Irgendwo hab ich auch noch ein Handbuch und die Software (DOS).
Ich hatte bei HITEX mal wegen eines Upgrades angefragt, ist möglich, 
aber unbezahlbar.
Somit stehen sie ausgemustert rum, ich benutz nur noch meinen Nohau.

Gruß
Markus

Autor: Peter Skoda (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Joerg,

nein, ich bin nicht angemeldet. Ich habe das Forum per Zufall entdeckt 
als ich nach dem Handbuch für das Teil gesucht habe. Frage: muss ich 
mich anmelden damit wir Daten austauschen können?

Gruß
Peter

Autor: Guido (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Markus B. schrieb:
> ...ich benutz nur noch meinen Nohau.

Was kostet sowas, sieht nett aus?

Autor: troll (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter Skoda schrieb:
> Frage: muss ich
> mich anmelden damit wir Daten austauschen können?
Du kannst auch deine Emailadresse direkt posten, aber möglichst 
spamsicher...

Autor: Peter Skoda (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Joerg,

hier mein EMADR.
p
l
s
k
o
d
a
ad
t
-
o
n
l
i
n
e
Punkt
d
e

Gruß
peter

Autor: Joerg L. (Firma: 100nF 0603 X7R) (joergl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Markus B. schrieb:
> Mir fällt grad, ich hätte auch noch 2 dieser Emulatoren rumstehen.

Hallo Markus,

was für PODs sind denn an den Emulatoren dran?

Danke & Gruß,
Jörg

Autor: Markus B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es waren mal 80C51 DIL dran, könnte aber sein daß ich die schon 
verbastelt habe.
Müßte ich nachschauen.

Autor: Joerg L. (Firma: 100nF 0603 X7R) (joergl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Markus B. schrieb:
> Müßte ich nachschauen.

Ich würde mich drüber freuen. Auch die "leeren" PODs würden mich 
interessieren. Danke!

Autor: Steffen Hausinger (steffenh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter Skoda schrieb:
> Hallo Steffen,
> ich zufällig den Beitrag gelesen. Im Keller hatte ich noch´n Hitex
> Teletest 51 mit Probe für, schätze mal, 80535 ohne Handbuch und
> Software. Wenn noch Bedarf besteht. Für´n Appel und ein Ei in etwa würde
> ich mich davon trennen.
>
> Gruß
> Peter


Hallo Peter,

ja, an Deinem Teletest habe ich ganz sicher Interesse! Leider war Jörg 
offensichtlich schneller.

Grüße
Steffen

Autor: Wilhelm F. (ferkes-willem)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erstaunlich, daß noch Leute mit den ollen 80C535 oder 80C537 arbeiten. 
Sicher doch nicht mehr industriell? Was habt ihr für eine Motivation für 
einen Emulator?

Autor: Joerg L. (Firma: 100nF 0603 X7R) (joergl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wilhelm Ferkes schrieb:
> Was habt ihr für eine Motivation für einen Emulator?

Man findet damit die Fehler im Assemblercode schneller.
Geht zumindest mir so. Einen Trace zu haben ist echt Gold wert.

Und warum 8051? Ganz einfach: Weil ich genug Chips habe.
Da gibts für mich keine Diskussionen.

Autor: Wilhelm F. (ferkes-willem)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joerg L. schrieb:

> Da gibts für mich keine Diskussionen.

Für mich auch nicht. Aber bekommt man die Zielcontroller denn noch neu 
zu kaufen?

Autor: Markus B. (dalotel)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, hab meine beiden Schätze auch mal geborgen.
Und sogar noch 3 POD´s dazu gefunden,
1 x 80C31 und 2 x 80C535,
sowie 2 Handbücher mit Softwaredisketten.
Beide Emulatoren laufen Errorfree hoch,
wenn ein POD angeschlossen ist.
Sogar ein RS232 Kabel dafür hab ich noch gefunden.
Und genau, hauptsächlich wegen dem Trace benutzt
ich auch solche Tools, bleibe aber meinem Nohau treu.
Deshalb sind die Hitex übrig.
Wer hat Interesse?


Gruß,
Markus

Autor: Joerg L. (Firma: 100nF 0603 X7R) (joergl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Joerg L. schrieb:
>> Da gibts für mich keine Diskussionen.
Wilhelm Ferkes schrieb:
> Für mich auch nicht. Aber bekommt man die Zielcontroller denn noch neu
> zu kaufen?

Äh, ja, sicher. Bei meinen Distis sind noch ettliche im Programm, 
ansonsten Flohmarkt und die Schrott-Tonne.
Da ich damit keine Produkte selbst herstelle und/oder verkaufe, ist das 
für mich allemal ausreichend.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.